Jump to content
Enpass Discussion Forum

Unable to Run from Current Location. Please change portable execution location.


Recommended Posts

I'm running Enpass portable on my M1 mac. I keep getting this error when I open the app, "Unable to Run from Current Location. Please change portable execution location."

Haven't been able to figure out if it's a problem with M1 or something I'm doing wrong.


Link to comment
Share on other sites

Hi @dalgza

Welcome to the Enpass Forums!

Enpass portable provides the assistance to carry all your passwords in the USB drive along with credit cards, bank accounts, ID cards, and other life-important credentials. Could you please confirm the location where you have set up your Enpass Portable File? I would also recommend checking out our user guide for Enpass portable and making sure that it is set up correctly. If the issue persists, then I will require some additional information. Please share the below details with me and I'll get it investigated for you -

  1. The version of the Enpass Portable app and OS you are using.
  2. A screenshot of the error occurring would be helpful.
  3. Are you facing this issue on any other device as well?
Link to comment
Share on other sites

  • 4 months later...

Hi, I have exactly the same problem.  Unfortunately, abhishek-dewan's answer isn't really helpful.  No matter where I start Enpass Portable (latest version) from, the said message always comes up. If there is already a defined error message like this, the support should know which requirements have to be met regarding the location.  To abhishek-dewan's questions:

1. MacMini with Intel CPU with MacOS 10.15.7

2. Why?  isn't the exact error message sufficient?  

3. No, I only have a Mac.

Best Regards


Link to comment
Share on other sites

  • 4 months later...

I have been using Enpass for years on a couple of Linux machines and on my wife's Windows device. Now I tried to use Enpass Portable. I downloaded v6.6.1 for Linux, unpacked it and copied the contents to a 2 GByte USB-stick with ext4 file system. When I try to start the executable, I get a notification, saying I need to change Enpass data location. There is an installed Version of Enpass on the device, but from what I read, it should work anyway. There is nothing I can do apart from hit Cancel. (see attached screenshot).

 The same thing happens on all other devices I have tried. I have seen mentions of this behavior from Mac users here and that was quite a while ago. Is there a solution by now?


Edited by Ferdinand
Link to comment
Share on other sites

  • Ferdinand changed the title to Can't start Enpass Portable
  • 1 month later...
On 12/19/2022 at 7:08 PM, Abhishek Dewan said:

Hi @trickzter

Our dedicated team is already aware of this issue and they are working on a fix. Unfortunately, I will be unable to share any ETA right now but rest assured, I'll be sure to notify the users on this forum when a patch is released. Your patience in the meantime is appreciated.

this makes the enpass mac portable broken. How can it be taking so long to fix it ?? 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...