Jump to content
Enpass Discussion Forum

V6.8.1 IOS, can't sync


Recommended Posts

So.... has always worked before. No longer works. Here's the deal. My nextcloud is at my domain I won't list here, let's just say cloud.something.com, which resolves to my local ip where nextcloud resides, So, if I am local, it just connects of course. If I am remote, I use a vpn, and it always just worked of course. But no more. When on vpn and cellular, I get a message on the vault settings screen that simply says "Sync error followed by No internet connection". Every 15 seconds or so, the screen refreshes. And, meanwhile, requests are logged in the apache log for nextcloud. I see these for example:

- - sfatulag3d1z 04/Jun/2022:00:01:46 -0500 "PROPFIND /remote.php" 207 /home/nextcloud/www/remote.php 68.468 4096 102.24%
- - sfatulag3d1z 04/Jun/2022:00:02:16 -0500 "PROPFIND /remote.php" 207 /home/nextcloud/www/remote.php 49.883 4096 80.19%
- - sfatulag3d1z 04/Jun/2022:00:02:16 -0500 "GET /ocs/v2.php?format=json" 304 /home/nextcloud/www/ocs/v2.php 93.371 2048 64.26%
- - sfatulag3d1z 04/Jun/2022:00:02:16 -0500 "GET /ocs/v2.php?format=json" 200 /home/nextcloud/www/ocs/v2.php 117.872 2048 42.42%

So, if I had no internet connection, I would have nothing logged. Meanwhile, I can run the nextcloud app, connects fine to remote nextcloud over vpn. I can run any app, all work fine. I can ssh into home using home local ip. I can browse files at home. I can print. I can ping any device on my network. I can use web interfaces on various devices I have. I can do dozens of things, all using local ips. But while enpass used to work on some previous version, now it simply says "No internet connection". Obviously I do have an internet connection else none of the examples given would work. So.... what changed with enpass, and, more importantly, what specific code determines that I have "No internet connection"? If I know that, perhaps we can figure this out.

Link to comment
Share on other sites

Not really sure what details you are looking for. Wireguard puts me on the local LAN from remote spot, so am running that on iPhone SE 3rd gen. I can access anything at home, dozens of things via local (LAN) IP. I gave examples. Nextcloud is running on a Linux server. It has a LAN address, That is the address I am connecting to. I can ping it, I can ssh to it, I can SMB to it, I can ftp to it from the phone with wireguard on it. Nextcloud notes (via IOS app cloudnotes) work fine when remote as well. The nextcloud app also works fine when remote, I can see stuff, get stuff, upload stuff, etc.

Wireguard allows you to split your network. Only stuff going to are routed to the home LAN. Anything else goes to normal cellular internet.

What else are you specifically looking for? I suspect Enpass would work fine if it didn't decide (for what I believe to be no good reason) that I don't have internet! Which I do since every other app works.

Link to comment
Share on other sites

I ran into exactly the same problem (no VPN though, my machine is on the same LAN with the server)  --- having updated to the version (where search speed is at least respectable), no version of Enpass will log into my nextcloud server, despite the fact that the URL, username and password are identical and other applications using the same credentials have no problem.


I then updated NextCloud to the latest version (I was several versions behind) and now it seems to work again   , at least on my desktop -- I have not retested my iOS versions yet.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...