Jump to content
Enpass Discussion Forum

6.8.2 keeps crashing after seconds


Ole
 Share

Recommended Posts

I have completely reinstalled Enpass. Unfortunately, it always crashes after a few seconds. The behavior did not exist before until version 6.7.4! Attached is the crash report.

 

-------------------------------------
Translated Report (Full Report Below)
-------------------------------------

Process:               Enpass [1600]
Path:                  /Applications/Enpass.app/Contents/MacOS/Enpass
Identifier:            in.sinew.Enpass-Desktop
Version:               6.8.2 (1082)
App Item ID:           732710998
App External ID:       850164998
Code Type:             ARM-64 (Native)
Parent Process:        launchd [1]
User ID:               501

Date/Time:             2022-06-21 21:51:50.1846 +0200
OS Version:            macOS 12.4 (21F79)
Report Version:        12
Anonymous UUID:        88945697-49E3-18E4-02B2-2239B2CC44E7


Time Awake Since Boot: 280 seconds

System Integrity Protection: enabled

Crashed Thread:        42

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000018
Exception Codes:       0x0000000000000001, 0x0000000000000018
Exception Note:        EXC_CORPSE_NOTIFY

Termination Reason:    Namespace SIGNAL, Code 11 Segmentation fault: 11
Terminating Process:   exc handler [1600]

VM Region Info: 0x18 is not in any region.  Bytes before following region: 105553552211944
      REGION TYPE                    START - END         [ VSIZE] PRT/MAX SHRMOD  REGION DETAIL
      UNUSED SPACE AT START
--->  
      MALLOC_NANO              600019fc0000-600020000000 [ 96.2M] rw-/rwx SM=ZER  

Link to comment
Share on other sites

Hi @Ole

We are looking into the concern reported by you, but our team of experts require some additional information in this case -

  1. Number of Vaults and Items you are using.

  2. Are you using any cloud sync or Wifi sync?

  3. Does the crash occur after any specific step? Life after editing an Item, creating a new Item etc?

We appreciate your co-operation in this matter.

 

Link to comment
Share on other sites

Posted (edited)
  1. i have 19 vaults: 1 iCloud, and 18 WebDAV
  2. using only cloud sync via iCloud and WebDAV
  3. the app crashing when open, regardless what I do - when I do nothing, it crashes too. It seems to crash, when the app tries to sync with the vaults

When I set up the app new with iCloud private relay off, it worked till I turned private relay on. Then the crashes appear. Then I deleted the app and all preferences und set up new again with private relay on. It worked 2 days, then it crashed again. I changed nothing. It may have something to do with this function, but what do I know? Enpass is not usable for me since then, but I need it.

Edited by Ole
Link to comment
Share on other sites

I reinstalled Enpass again and put only WebDAV-Vaults in. Now this are only 11 vaults. It crashes again, after I went up from 5 to 11 vaults.

 

Thread 24 crashed with ARM Thread State (64-bit):
   sp: 0x000000016db09290   pc: 0x0000000102c6278c cpsr: 0x80001000
   far: 0x0000000000000018  esr: 0x92000006 (Data Abort) byte read Translation fault

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...