Jump to content
Enpass Discussion Forum

6.8.2 keeps crashing after seconds


Recommended Posts

I have completely reinstalled Enpass. Unfortunately, it always crashes after a few seconds. The behavior did not exist before until version 6.7.4! Attached is the crash report.


Translated Report (Full Report Below)

Process:               Enpass [1600]
Path:                  /Applications/Enpass.app/Contents/MacOS/Enpass
Identifier:            in.sinew.Enpass-Desktop
Version:               6.8.2 (1082)
App Item ID:           732710998
App External ID:       850164998
Code Type:             ARM-64 (Native)
Parent Process:        launchd [1]
User ID:               501

Date/Time:             2022-06-21 21:51:50.1846 +0200
OS Version:            macOS 12.4 (21F79)
Report Version:        12
Anonymous UUID:        88945697-49E3-18E4-02B2-2239B2CC44E7

Time Awake Since Boot: 280 seconds

System Integrity Protection: enabled

Crashed Thread:        42

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000018
Exception Codes:       0x0000000000000001, 0x0000000000000018
Exception Note:        EXC_CORPSE_NOTIFY

Termination Reason:    Namespace SIGNAL, Code 11 Segmentation fault: 11
Terminating Process:   exc handler [1600]

VM Region Info: 0x18 is not in any region.  Bytes before following region: 105553552211944
      REGION TYPE                    START - END         [ VSIZE] PRT/MAX SHRMOD  REGION DETAIL
      MALLOC_NANO              600019fc0000-600020000000 [ 96.2M] rw-/rwx SM=ZER  

Link to comment
Share on other sites

Hi @Ole

We are looking into the concern reported by you, but our team of experts require some additional information in this case -

  1. Number of Vaults and Items you are using.

  2. Are you using any cloud sync or Wifi sync?

  3. Does the crash occur after any specific step? Life after editing an Item, creating a new Item etc?

We appreciate your co-operation in this matter.


Link to comment
Share on other sites

Posted (edited)
  1. i have 19 vaults: 1 iCloud, and 18 WebDAV
  2. using only cloud sync via iCloud and WebDAV
  3. the app crashing when open, regardless what I do - when I do nothing, it crashes too. It seems to crash, when the app tries to sync with the vaults

When I set up the app new with iCloud private relay off, it worked till I turned private relay on. Then the crashes appear. Then I deleted the app and all preferences und set up new again with private relay on. It worked 2 days, then it crashed again. I changed nothing. It may have something to do with this function, but what do I know? Enpass is not usable for me since then, but I need it.

Edited by Ole
Link to comment
Share on other sites

I reinstalled Enpass again and put only WebDAV-Vaults in. Now this are only 11 vaults. It crashes again, after I went up from 5 to 11 vaults.


Thread 24 crashed with ARM Thread State (64-bit):
   sp: 0x000000016db09290   pc: 0x0000000102c6278c cpsr: 0x80001000
   far: 0x0000000000000018  esr: 0x92000006 (Data Abort) byte read Translation fault

Link to comment
Share on other sites

  • 2 weeks later...

I suspect I have the same problem with Enpass 6.8.2 (1081).

When I launch Enpass and enter the main vault password, Enpass crashes immediately with no error message or other response.

When I launch Enpass again and enter the main password, Enpass opens as expected.
I have observed this behavior on three Macs: MacMini from 2020 and MacBook Pro from 2015, both macOS 12.4 and an old MacBook Pro with macOS 10.15, all Intel-Macs.

Enpass contains only one data vault on each, which is currently synced via Google Drive. On macOS 12.4 I installed the version downloaded from the website and on the MacBook Pro with macOS 10.15 I installed the version from the MacApp Store. So it doesn't seem to make any difference regarding the website vs. MacApp Store version in terms of crashes for me.

The problem only exists since the last two or three updates of Enpass.

Unfortunately, I cannot find a crash report in console.app

Link to comment
Share on other sites

I have the same problem.

since the last update of Enpass (6.8.2 1082) on my iMac I have extreme problems:
* Unlocking via TouchID keeps failing
* Then I enter my master password and it says it's the wrong one, I enter the exact same password the second time it works. The next time again the first time error then it works.
* I had deposited 5 vaults. Now there are only 2 safes left
* Now I wanted to add my vaults back and sync via WebDav
*** Now I get the following error message

sync error
Two tresors cannot be connected to the same account to sync data.
But I use a separate user on the WebDav server for each safe

I have the feeling that there are similar bugs as a few months ago in the iOS version after an update.

Link to comment
Share on other sites

Hi @compoundbow83

Regarding unable to connect two tresors to the same account to sync data, our dedicated team is already aware of this issue and is working on resolving this bug.

As for the Touch ID not working properly and Enpass app not recognizing the master-password for the first time, kindly create a manual backup/set up synchonization on your device and then re-install the app. After restoring your data, please enable the touch ID again. Let me know if the issue persists.

Link to comment
Share on other sites

I have re-install the App.

And even after that, Touch ID doesn't work and every time Enpass doesn't accept my master password the first time.

Because of the synchronization issue. I don´t use the same account on my Webdav.

Edited by compoundbow83
Link to comment
Share on other sites

Hi @compoundbow83

We are looking into the concerns reported by you. In the meantime, could you please share the version of the OS and also try disabling and then re-enabling the Touch ID in your Enpass Mac app to check if the issue persists? If you are getting any error, kindly share a screenshot of it as well. We appreciate your co-operation in this matter.

Link to comment
Share on other sites

My OS Version is 12.4

I have disabled and then re-enabled Touch ID, but even then the same problem, I verify myself with Touch ID then still have to enter my master password.

When I enter the master password for the first time, the message "wrong master password" appears, if I enter exactly the same password again, it is accepted.

I have test without Touch ID, the same issue with the master password. When I enter the master password for the first time, the message "wrong master password" appears, if I enter exactly the same password again, it is accepted.

I don't see any error other than "wrong master password".

I have an other error. If I close Enpass completely and open it again, I have to unlock my Pro version again

Link to comment
Share on other sites

Hi @compoundbow83

We were able to reproduce the concern reported by you, due to which the touch ID is not working for you, and Enpass is not accepting the master password on the first attempt in Mac. Our dedicated team is working on resolving it, and a patch addressing this issue will be released soon.

Regarding having to authenticate your Pro license again after completely closing the app, kindly DM me the email address to which the license is linked and the system details on which you are facing this issue. I will then have it investigated for you.

Link to comment
Share on other sites

  • 4 weeks later...

The issues under Mac OS:

1. touch ID don´t work

2. currently only one safe can be connected via WebDAV (if I want to connect the second safe via WebDav after the first safe, I just fly out when saving)

are still present!


When can we expect an update for these two errors?



Link to comment
Share on other sites

  • 1 month later...

Today is September 24th, 2022 and to date no update has been released for the macos version that fixes the updates.

current enpass version for macos: 6.8.2

current enpass version browser (chrom) extension: 6.8.0

With the current status, productive work with the app is no longer possible:

  • Touch ID not working
  • The master password must then be entered twice
  • more than one Webdave vault is not possible
  • every time I want to retrieve a password via the browser (chrome) plugin, the message "Authentication passcode" comes up and I have to enter a six-digit code

When is the bug fixing update coming out?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...