Jump to content
Enpass Discussion Forum

Enpass Wi-Fi Sync Not Working Over Ethernet After Update - Server Address Oddly Different from LAN IP Address


MrElectrifyer
 Share

Recommended Posts

Hi All,

As the title implies, after some update to the Enpass app on the Windows Store, I'm no longer able to sync my Enpass credentials from my Ethernet-connected PC (a Surface Pro 7+ running Windows 11 Pro) to my Wi-Fi-connected devices on the same Local Area Network (LAN). If I disconnect the Ethernet cable from my Surface Pro's dock and have it connect to Wi-Fi, then the Enpass Wi-Fi Sync works as expected over the LAN. This occurs both on my work and home networks.

Upon attempting to troubleshoot this issue, I noticed that when connected to the LAN via Ethernet, the Enpass Wi-Fi Sync Server Address is oddly different from the LAN IP address assigned by the router and also what is idenfied by Windows in the Network & internet settings, as can be seen below:

image.thumb.png.339182b19c9f4fc105314268a3635602.png

This is most certainly the reason why my other LAN connected devices can't detect the Wi-Fi Sync server when its connected to Ethernet, and why I now often have to be disconnecting/reconnecting my Ethernet cable whenever I want to sync my Enpass vault across my systems. Please could you look into fixing this productivity-hampering issue with the Enpass app?

Link to comment
Share on other sites

Hi @MrElectrifyer

For troubleshooting purposes, please try the below steps -

  1. I would suggest you disconnect the Wifi-Sync server from the connected devices and set it up by following the steps in the link , or manually by following the steps in this one.
  2. Ensure that you have allowed access to Enpass in your Firewall/Antivirus Settings. Moreover, if you are using any VPN service, try disabling it to check if the issue persists.
  3. Check that time is set to automatic and is same on all your devices.
  4. You can also refer to this highly useful troubleshooting guide in case you get the same error after creating a manual Wifi-sync server.
  5. Otherwise, create a manual backup of your Enpass data and then reinstall the app on the affected device.

If the issue persists, kindly share the below details and I will gladly get this investigated for you -

  1. The version of the Enpass app you are using.
  2. Any Firewall/Antivirus/VPN service you are using.
  3. Are you facing a similar issue on other devices as well?
Link to comment
Share on other sites

Hi @Abhishek Dewan

Thanks for the troubleshooting suggestions, see responses below.

On 8/1/2023 at 5:02 AM, Abhishek Dewan said:
  1. I would suggest you disconnect the Wifi-Sync server from the connected devices and set it up by following the steps in the link , or manually by following the steps in this one.
    • The issue isn't on the conencted devices, it's with the Enpass Server installed on my Surface Pro 7+.
  2. Ensure that you have allowed access to Enpass in your Firewall/Antivirus Settings. Moreover, if you are using any VPN service, try disabling it to check if the issue persists.
    • Yes, Enpass has been allowed access in both my Windows Firewall/Security, and it works over the WiFi connection, just not over Ethernet.
  3. Check that time is set to automatic and is same on all your devices.
    • Yes, system time on both my Surface Pro and phone are set to automatic.
  4. You can also refer to this highly useful troubleshooting guide in case you get the same error after creating a manual Wifi-sync server.
    • The guide's solutions for my situation (restarting system, checking date/time, and to checking firewall settings) didn't make any difference. 
  5. Otherwise, create a manual backup of your Enpass data and then reinstall the app on the affected device.
    • This would take a while to setup all over again with my 5 separate vaults. I'll try setting it on another system and see if it's any different.

If the issue persists, kindly share the below details and I will gladly get this investigated for you -

  1. The version of the Enpass app you are using.
    • v6.9.0 (1466).
  2. Any Firewall/Antivirus/VPN service you are using.
    • Yes, Windows 11's Built-in Firewall and Antivirus.
  3. Are you facing a similar issue on other devices as well?
    • Will re-attempt producing this on another system and let you know.
Edited by MrElectrifyer
Link to comment
Share on other sites

Hi @MrElectrifyer

I appreciate your cooperation in providing the requested information.

I've escalated this matter to our specialized team for a comprehensive analysis. While we await their investigation, I recommend attempting to replicate this issue on an alternate system. Please inform me of your findings, as I will also assess the problem in those environments.

#SI-3235

Link to comment
Share on other sites

  • 2 weeks later...

Hi @Abhishek Dewan

Sorry for the late follow-up. Haven't had the chance to replicate it on a separate system as of yet (busy with work/family). However, it appears the following Windows updates may have addressed the issue in some way, 'cause without making any other system changes, network changes, nor changes to my Enpass setup, the Enpass WiFi Sync server address is now matching that of the Windows settings app, and is successfully syncing over Ethernet again:

image.thumb.png.a376e285a25b46f8cf31286c50d5131b.png

Is Enpass dependent on Microsoft's .NET framework by any chance? 'Cause I have no other logical explanation of how it's suddenly working again over Ethernet.

Link to comment
Share on other sites

Hi @MrElectrifyer

Thank you for informing me that the problem you were encountering has been resolved.

It's conceivable that the bug might have originated from Microsoft's side, and we suggest maintaining the Enpass app and your operating system up to date to ensure a smooth user experience. Should this issue resurface, please provide an update on this forum. Our team will be more than willing to conduct a deeper investigation for you.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...