Jump to content
boo

[Bug] Enpass Mini: Using keyboard to copy OTP results in incorrect value

Recommended Posts

When using the keyboard to copy the value from the OTP field (by highlighting it with arrow keys and pressing enter to copy it), the OTP is incorrect and does not match what is displayed in the OTP text field. 

For example, the OTP text field for one of my accounts displayed 016406, but pressing enter copied 942757 to my clipboard.

Share this post


Link to post
Share on other sites

Hi @boo,

Thanks for writing in.

Actually, you're getting this error because the copied TOTP is only valid for 30 seconds and by the time you autofill the logins and paste the TOTP, it's already expired. However, you can opt to copy the TOTP automatically when you autofill the webpage directly from the Enpass extension. This way, you just need to paste the TOTP and don't have to worry about the countdown timer.   

Cheers!

Share this post


Link to post
Share on other sites
20 hours ago, Anshu kumar said:

Hi @boo,

Thanks for writing in.

Actually, you're getting this error because the copied TOTP is only valid for 30 seconds and by the time you autofill the logins and paste the TOTP, it's already expired. However, you can opt to copy the TOTP automatically when you autofill the webpage directly from the Enpass extension. This way, you just need to paste the TOTP and don't have to worry about the countdown timer.   

Cheers!

I'm quite sure this issue is not due to timing issues on my end.

After some additional testing, this is the specific way to reproduce the behavior:

  1. When a site requests a TOTP to log in, activate Enpass Mini
  2. Using the arrow keys, highlight the desired account from the list of Enpass items
  3. Use the right arrow key to open the account details
  4. Use the down arrow key to highlight the TOTP field
  5. Take note of the time remaining, wait until a fresh OTP is generated, and take mental note of the number
  6. Press enter to copy the TOTP and close Enpass Mini
  7. Press ctrl+v to paste into the TOTP field for the website
  8. The pasted TOTP will differ completely from the one displayed (which you took a mental note of)

This bug cannot be reproduced by manually clicking the 'copy' button on the TOTP nor by using the 'copy TOTP' keyboard shortcut (ctrl+shift+t) - both of these produce the correct/expected result.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...