Jump to content
Enpass Discussion Forum

Beta 6 | Cloud Sync post-auth redirect broken


Recommended Posts

I'm using Android 8.1.0 on Nexus 6, running Enpass

Starting with an empty vault, tried syncing with Google Drive first. I signed into the appropriate google account like normal, authorized enpass beta just like any other oauth application, and reached the authorization complete page, and nothing. No redirect. It looked like the rounded turquoise div might have been a Material designed button, so I tapped it. Nothing. I switched tasks to the Enpass Beta app again and it was stuck with the loading modal saying "Authorizing" with the loading pinwheel. I waited patiently for 10 minutes with no indication of it receiving anything from the server.

I tried again with authorizing Google Drive, this time much faster since I was already logged in. Same issue. I created a new vault, choosing to setup sync after it had some data, then tried again, and same issue. I even varied it up from using the stock AOSP browser to using Firefox Focus. Same issue no matter what. I then switched to Dropbox in case it was provider-specific. Same issue.

Link to comment
Share on other sites

I used Chrome stable (v67.0.3396.87) and it worked exactly as expected, with the exception that I needed to manually switch back to the Enpass Beta app to have it finish authorization. No indication that I could close the browser window. Slight usability issue, but not a high priority.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...