Jump to content
Enpass Discussion Forum

macOS browser extension not working


Recommended Posts


I'm using the Enpass 6.0.0 beta for macOS but there's a rather strange issue that's making it unuseable on my machine. Whenever I try to use the browser extension (tested with Chrome and Firefox, same results) nothing happens for a while and then a new tab opens saying "Looking for the Enpass app" and "If prompted, please grant permission to the browser in the pop-up to launch Epass." If Enpass is already running the tab closes after a while and nothing further happens. However when I quit Enpass and let the extension open it (by clicking the button in the browser) I am able to use it exaclty once from within the browser (the popup opens when I click the extension button a second time) but the popup doesn't know what page I am currently on so it can't provide usefull autofill information. It just opens the same way as if I clicked the taskbar icon. When I try to open the popup again the same tab as before opens and nothing happens afterwards.

Do you know what causes this issue/can you repoduce it/are you aware of it?

Screenshot 2018-09-09 at 20.12.48.png

  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...
  • 1 month later...

Same for Vivaldi 2.1.1337.51 (Chromium 70.0.3538.113). Extension doesn't connect to the App anymore. What's strange is, the Beta Download page indicates the version of the Chrome Addon being, but the version on the Chrome Web Store still is looks like there is something wrong on more than one level. Enpass 5 is bugged, Enpass 6 Beta now too.

I'll wait a few more days for a fix, if nothing comes, I'll switch to Bitwarden....

Link to comment
Share on other sites

Got it working by closing the app entirely.

Open browser and click icon.

Start the app when prompted.

It will probably fail but will start the app.

Go to system trey and right click icon.

Click on any entry for a website so it opens up that page in the browser.

Now click on the Enpass icon in the browser again.

It then prompted me to type in a random pin to attach the app to the browser.


Not sure which part o this process actually fixed it but everything's working now.

Link to comment
Share on other sites

Same Issue here.

Tried this with no success:
- Quit Enpass and click on extension icon to start Enpass, but it just opens it minimized in menu bar but throughs the error anyway.
- Restart Mac/Restart Enpass
- Reinstall browser extension
- Reinstall Enpass 6 beta

- macOS 10.14.1
- Enpass 6.0.0 (220)
- Extension
- Google Chrome 70.0.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...