Jump to content
hebusthib

EnpassNMHost Firefox and multi session on windows 10

Recommended Posts

Hi every one.
It's been more than half an hour now that I am looking for some similar issues here but can't find any, so I will try to explain myself clearly...

I use enpass from windows store on my computer running windows 10. I have installed EnpassNMHost to use Edge and Firefox extensions. Everything is fine (Edge extension first clic gives me a "connection error" tab, but second clic is always fine). Firefox extension works great from first clic.
I just created a new user session on my computer for my wife who's own pc died)... And here the trouble begins, (not because of my wife ;) ). On its session I had to install again enpass from windows store, and EnpassNMHost. Edge extension works the same way it does on my user session (my wife won't use it) , but Firefox extension won't work (she uses Firefox because I told her to for so many years...). It keeps giving me a "connection error tab". (My own session is still working, yeah :D)

Was it OK to install EnpassNMHost again on the new session?

Is there any specific I should know about for using enpass in a multiuser environment...?

Thanks for your help! Sorry if my English is approximative....

 

Share this post


Link to post
Share on other sites

Hi @hebusthib,

Sorry for the trouble you're going through.

8 hours ago, hebusthib said:

Was it OK to install EnpassNMHost again on the new session? 

 Is there any specific I should know about for using enpass in a multiuser environment...?

2

No there is no such specific scenario to use Enpass in a  multiuser environment. But, in order to use Firefox browser extension, you will have to install NMHost in all user accounts.

Cheers!

Share this post


Link to post
Share on other sites

Hi @Anshu kumar,

Thanks for your reply, I did perform the installation of NMHost in the new session. I will try to un-instal and re-instal. 

Should I check the startup program list , or any services or running program in that new session ? How can I check that NMHost is running properly, or how can I force it to load ?

Thanks again, 

Cheers !

 

Share this post


Link to post
Share on other sites

Hi @hebusthib,

Thanks for sharing the info. 

On 9/17/2018 at 3:06 PM, hebusthib said:

Should I check the startup program list , or any services or running program in that new session ? How can I check that NMHost is running properly, or how can I force it to load ?

4

NMHost is automatically started by Firefox by looking a registry key. You can also check it via the following steps.

  • Run the registry editor (Hold Windows Key and R, then type in regedit)and navigate to the location as attached in the screenshot and check if you've got an EnpassNMHost file there.

redit.png.c63bf57413ef4a6be1c5fc1e83815861.png

Thanks for your co-operation.

Share this post


Link to post
Share on other sites

Hi again !

Thanks for taking the time, 

I checked this registry key on my two sessions, and I confirm that the second session (my wife's) doesn't have this key register (after a fresh instal as an administrator).

Here is the screen I have on my own session :

snip_20180918214402.thumb.png.0c062157fce7f08ae45c0827353bb768.png

and here under, her own session:

snip_20180918214402_Laureen.PNG.dd0c281bc71e9ab9ac8b8198071de159.PNG

I hope it can help...

 

Share this post


Link to post
Share on other sites

Hi @hebusthib,

Thanks for writing back and sharing the screenshots.

Though It should work. But for quick troubleshooting, you need to manually add the key for the second user as the same way it's added for your Admin account. To do so please follow these steps:

  • Run the registry editor (Hold Windows Key and R, then type in regedit)and navigate to the location  Computer\HKEY_CURRENT_USER\Software\Mozilla
  • Select Mozilla Folder --> Right click on it --> Select New --> Key -->  Name that new key as NativeMessagingHosts.
  • Now Right click on NativeMessagingHosts Folder --> Select New --> Key --> Named it as EnpassNMHost.
  •  Double click on EnpassNMHost --> Double click on Default --> Set the same path as Admin account in the value data field.

value.PNG.7a45eb12ae107717315d14730830f695.PNGvalue2.PNG.3fadd30d66982c3792148ae3c7810f7b.PNG

Hope this helps!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...