Jump to content
Enpass Discussion Forum

[MacOS] Browser extensions not talking to v6 beta?


Recommended Posts

I now see Firefox extension 6.0.0.56 on the downloads page (https://www.enpass.io/enpass-beta-downloads/). After installation this version doesn't fail connecting to the Enpass assistant. Instead I see the Enpass popup window with the option to Allow or Reject the connection from Firefox. Clicking the Allow button appears to refresh the window, nothing else occurs. Reject closes the window till I click the toolbar icon again.  If I inspect the browser authorizations in the Enpass app preferences Firefox is not listed.

Link to post
Share on other sites

Correction, the problem with 6.0.0.56 appears to be signature verification. "Allow" should bypass the signature check but does not. However, if I disable verification in Enpass app preferences it proceeds to the pairing window.

What is odd about this is that this is a standard Firefox 63.0.3 release, no modifications, so no reason for verification to fail (worked with the prior Enpass beta).

Link to post
Share on other sites

I was having this problem, and in the process of coming to post about it, I saw the previous beta thread had been closed — which was the only way I learned there was a new build of the beta. After installing the new build, it's working for me...

...in Chrome anyway. Can't even install the new extension in Safari. Posted about it in the thread for this new beta build: https://discussion.enpass.io/index.php?/topic/4866-latest-enpass-6-beta-for-mac-is-now-available/

Link to post
Share on other sites
6 hours ago, firstwiz said:

Same problem on Linux Ubuntu 18.04, with Enpass 6.0.0(149).

Chrome version Version 69.0.3497.100 (Official Build) and extension version 6.0.0.56

The Chrome extension times out with "Enpass Assistant is unable to connect with the Enpass app."

 

 

Same for Vivaldi 2.1.1337.51 (Chromium 70.0.3538.113). Extension doesn't connect to the App anymore. What's strange is, the Beta Download page indicates the version of the Chrome Addon being 6.0.0.6, but the version on the Chrome Web Store still is 6.0.0.56. looks like there is something wrong on more than one level. Enpass 5 is bugged, Enpass 6 Beta now too.

Link to post
Share on other sites

@x2k13 @firstwiz

Build 149 is the old one! Current beta build is 197 for linux. Also the current chrome extension is 6.0.0.56, so that's correct.

Although on the beta download overview page it states Latest version: 6.0.0.149, that's wrong. You need to follow the instructions in the link there, since they updated the repository, which will contain the new beta version.

Link to post
Share on other sites
3 hours ago, Meister said:

@x2k13 @firstwiz

Build 149 is the old one! Current beta build is 197 for linux. Also the current chrome extension is 6.0.0.56, so that's correct.

Although on the beta download overview page it states Latest version: 6.0.0.149, that's wrong. You need to follow the instructions in the link there, since they updated the repository, which will contain the new beta version.

This is the output that I get:

~$ apt policy enpass-beta
enpass-beta:
  Installed: 6.0.0.149
  Candidate: 6.0.0.149
  Version table:
 *** 6.0.0.149 500
        500 h-t-t-p://repo.sinew.in stable/main amd64 Packages
        100 /var/lib/dpkg/status

As you can see, the repo is just the same as on the linked page you posted. (Can't post urls, that's why it's h-t-t-p)

Edited by x2k13
Link to post
Share on other sites

@x2k13

You need to install enpass instead of enpass-beta. enpass-beta is the old beta, enpass is the new beta:

 

$ sudo apt policy enpass
enpass:
  Installed: 6.0.0.197
  Candidate: 6.0.0.197
  Version table:
 *** 6.0.0.197 500
        500 http://repo.sinew.in/testing testing/beta amd64 Packages
        100 /var/lib/dpkg/status
     5.6.9 500
        500 http://repo.sinew.in stable/main amd64 Packages

 

Edited by Meister
Link to post
Share on other sites

So beta is now stable? Confusing ^^

Edit, apparently not:

$ apt policy enpass     
enpass:
  Installed: (none)
  Candidate: 5.6.9
  Version table:
     5.6.9 500
        500 h-t-t-p://repo.sinew.in stable/main amd64 Packages

This is how I expect it to be, stable != beta

Edited by x2k13
Link to post
Share on other sites

Aaah, I see...the repo is different from what's on the page you posted before [...testing]. Well, actually it would be correct to seperate enpass and enpass-beta in the same repo. Would be different if theres different branches, like for Debian Stable, Testing, Sid...

Edited by x2k13
Link to post
Share on other sites
21 minutes ago, Meister said:

Your're right, didn't notice that. Then I was wrong about the repository being the same as stable, it's just the name of the program then.

Hmm, whats the correct string to add to the .list for testing, can't work it out I guess.

Edit: Nevermind, got it:

deb h-t-t-p://repo.sinew.in/testing testing beta

Edited by x2k13
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...