Jump to content
blenderfox

Enpass 6.0.0. Core Dumps on Ubuntu

Recommended Posts

I have Enpass 5.6.0 on an Ubuntu machine (17.10)

I wanted to upgrade it to 6.0.0 so I followed the download Instructions the application doesn't start.

When attepting to run

/opt/enpass/Enpass

in console, it returns "Core Dumped"

I've tried purging the application, removing everything I can find related to Enpass, and reinstall but it still core dumps.

Any ideas?

Share this post


Link to post
Share on other sites

Hi,

 

Your version of Ubuntu (17.10) is no longer maintained since July 19, 2018. I advise you to upgrade to version 18.04 LTS on which Enpass 6 works. :)

Share this post


Link to post
Share on other sites

I can confirm that Enpass 6 doesn't run on Ubuntumate 17.10 here, I'll be letting this thread notify me of things I can try with my system as well.. works great on 3 debian stretch workstations so I know the enpass team have been doing a great job 

thanks

happy new year btw

Share this post


Link to post
Share on other sites

Ubuntu Mate 17.10

I couldn't open Enpass 6.0 from menu. I wrote this launcher script to make it work.

#!/bin/bash
export GDK_BACKEND=x11
export QT4_IM_MODULE=xim
export QT_ACCESSIBILITY=1
export QT_IM_MODULE=ibus
export QT_QPA_PLATFORMTHEME=gtk2
/opt/enpass/Enpass

I have a crash log if you want me to send it to you.

Share this post


Link to post
Share on other sites
On 1/1/2019 at 2:17 PM, gargolito said:

Ubuntu Mate 17.10

I couldn't open Enpass 6.0 from menu. I wrote this launcher script to make it work.


#!/bin/bash
export GDK_BACKEND=x11
export QT4_IM_MODULE=xim
export QT_ACCESSIBILITY=1
export QT_IM_MODULE=ibus
export QT_QPA_PLATFORMTHEME=gtk2
/opt/enpass/Enpass

I have a crash log if you want me to send it to you.

thanks gargolito, this fixed it for launching here on the same ubuntumate..  the only thing I have to do is throw in a custom .desktop file 

xdg-desktop-menu install user-mycustom-enpass.desktop

  .. for the time I'll be having this as a workaround until this gets patched.

 

Edited by awlks

Share this post


Link to post
Share on other sites

In my home computer (xUbuntu 18.04) enpass (version 6.0.1.239, installed through apt repository) is not starting, 

If I launch it from the menu entry nothing happens and after a while a ubuntu bug report pops up saying it has crashed.

If I start it form the command line running '/opt/enpass/Enpass' I get a 'abort (core dumped)  /opt/enpass/Enpass' error message.

The strange thing is that in my work computer (a xUtuntu 18.04 too) it works, the "only" difference betweeen both computers is that in my home computer I have an HiDPI screen.

Share this post


Link to post
Share on other sites

I fixed this -- I reinstalled Ubuntu (upgrading to Ubuntu Cosmic in the meantime)

Then I was able to get 6.0.0 to start, but it would not detect any data on my Google Drive. So I downloaded the wallet file manually, and pointed Enpass to the local copy instead, and THEN synced it up to Google Drive.

Share this post


Link to post
Share on other sites

@Vinod Kumar It was not me that couldn't find the data, Enpass itself said it could not find any data on my Google Drive during the initial sync.

Given that I was able to install Enpass 6 on a different machine (Windows) before this one, that data should have been moved to the new location anyway.

Share this post


Link to post
Share on other sites

Yeah, it ran through the "upgrading" process and I was able to login and setup sync, everything.

Then when I finally managed to get 6.0.0 running on Ubuntu, it said it couldn't find any data on Google Drive, until I copied down the sync wallet from the Enpass folder (which I'm guessing now is the 5.x data), pointed the first start wizard at it and then relinking to Google Drive after that.

Share this post


Link to post
Share on other sites
On 1/5/2019 at 10:32 AM, Vinod Kumar said:

Hi @xoner,

Try this in terminal and share results.


export QT_OPENGL=software
export QSG_RENDER_LOOP=basic 
/opt/enpass/Enpass

Its worth trying @gargolito's solution too.

Thanks.

@gargolito solution worked for me

Share this post


Link to post
Share on other sites

For me, I fixed it by updating my Ubuntu Cosmic, then Enpass would install and run.

It didn't find my data on Google Drive, so I downloaded the wallet file from the Enpass folder and pointed the startup wizard to that, then resynced.

All working here now :)

Share this post


Link to post
Share on other sites
On 1/1/2019 at 8:17 PM, gargolito said:

Ubuntu Mate 17.10

I couldn't open Enpass 6.0 from menu. I wrote this launcher script to make it work.


#!/bin/bash
export GDK_BACKEND=x11
export QT4_IM_MODULE=xim
export QT_ACCESSIBILITY=1
export QT_IM_MODULE=ibus
export QT_QPA_PLATFORMTHEME=gtk2
/opt/enpass/Enpass

I have a crash log if you want me to send it to you.

Hi,

Thanks a lot !!!!
If you make

/opt/enpass/Enpass "$@"

of that last line... it will also transmit all the arguments to the app

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×