Jump to content
Enpass Discussion Forum

Multiple issues on version 6.0.5 using Safari


pbotadra
 Share

Recommended Posts

Issues that I am facing on Enpass 6.0.5 (on MacOS Mojava, running Safari 12.0.3)

1. Search seems to freeze the App (already reported by others)

2. Enpass extension asks for authorization almost every other day - why is this the case? Why does it have to be authorized again and again?

3. When I use the assistant to fill in passwords in Safari, it does not give me a suggestion based on the domain that I'm visiting, but a list of all logins sorted in some random order

Expected behavior: Only show matches that fit to the current 2nd level domain by default. If there are 3rd level subdomains, show all 2nd level domain logins, but with the appropriate subdomain first.

4. Forms for creating items (logins, identities, Credit Card etc.): All the form fields are like plain text-fields with no help or details regarding format, validations etc. Example: In Identifies, Gender is a text-field - people may enter either Male or M (or something else). Shouldn't this be a dropdown? Same is the case with Date fields (Date of Birth etc.), there is no information on the date format - should it be dd/mm/yyyy or something else? Is this an area where you guys are actively working currently?

5. Suggestion:
When I use the assistant to fill in passwords in Safari and the correct login is presented in the window, it takes me 3 keystrokes to login:

a. "arrow down" (get out of search field)
b. Another "arrow down" to get to the login entry.
c. "Enter" to login

Better option:
Keyboard focus is directly on the first login item, so that I only need to hit "enter" (such as in 1Password)

Thanks @C__O , I re-used two of your posts in the above

  • Sad 1
Link to comment
Share on other sites

On 2/18/2019 at 1:19 PM, pbotadra said:

1. Search seems to freeze the App (already reported by others)

 

Already fixed in the latest beta version.

 

On 2/18/2019 at 1:19 PM, pbotadra said:

 2. Enpass extension asks for authorization almost every other day - why is this the case? Why does it have to be authorized again and again?

 

Can you please let me know have you enabled Ask for Browser Authorization Every Time in Enpass Browser settings. Also, if possible please share the screenshot of the problem so that we can investigate further.

On 2/18/2019 at 1:19 PM, pbotadra said:

. Forms for creating items (logins, identities, Credit Card etc.): All the form fields are like plain text-fields with no help or details regarding format, validations etc. Example: In Identifies, Gender is a text-field - people may enter either Male or M (or something else). Shouldn't this be a dropdown? Same is the case with Date fields (Date of Birth etc.), there is no information on the date format - should it be dd/mm/yyyy or something else? Is this an area where you guys are actively working currently?

I have noted down your suggestion and forwarded it to the concerned desk.

On 2/18/2019 at 1:19 PM, pbotadra said:

When I use the assistant to fill in passwords in Safari and the correct login is presented in the window, it takes me 3 keystrokes to login:

a. "arrow down" (get out of search field)
b. Another "arrow down" to get to the login entry.
c. "Enter" to login

Already fixed in the latest beta version.

Thanks!

Link to comment
Share on other sites

19 hours ago, Anshu kumar said:

Can you please let me know have you enabled Ask for Browser Authorization Every Time in Enpass Browser settings. Also, if possible please share the screenshot of the problem so that we can investigate further.

@Anshu kumar No. That option is disabled. It is definitely a weird bug. Screenshot attached.

Screenshot 2019-02-21 at 10.41.28.png

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...