Jump to content
HQJaTu

WebDAV Sync Error with code 904035

Recommended Posts

Initial vault setup from own server goes ok. Something changed in version 6.0.5 (or 6.0.6) and now my Let's Encrypt certificate spits error on every sync. This is not happening on my Mac nor iPhone. Only on Windows 10 store version does that.

Fix is to disconnect. At reconnect select "Bypass SSL certificate verification". After that, everything works ok.

This is not a blocker, more like a nuisance. Early 6.x versions worked ok, but latest 6.1.0 does not. The obvious weird thing is, that the certificate IS valid and other platforms work ok.

Enpass-Error-code-904035.png

Share this post


Link to post
Share on other sites

Hey @HQJaTu,

Sorry for the trouble you are going through.

It would be a great help if you can share the demo account of your WebDAV via PM so that we can investigate where the problem could be and try to fix asap.

Thanks for your co-operation.

Share this post


Link to post
Share on other sites
1 hour ago, Anshu kumar said:

It would be a great help if you can share the demo account of your WebDAV via PM so that we can investigate where the problem could be and try to fix asap.

Thanks for your response. I'll move this discussion to PM with details.

Share this post


Link to post
Share on other sites

Is there any update to this? I am also getting 904035 on sync on one Windows 10 computer but another Windows 10 computer works fine. Viewing the server logs I can see the one with the error isn't making any requests at all.

I also use Let's Encrypt certificates. I'm not going to bypass certificate verification for obvious reasons!

-davidc

Share this post


Link to post
Share on other sites
2 minutes ago, davidc said:

I also use Let's Encrypt certificates. I'm not going to bypass certificate verification for obvious reasons!

I have exchanged couple emails with support and clarified my case to them, but haven't heard from them since.

The current theory is, that any HTTP-proxy, transparent or regular will cause Enpass to interpret things incorrectly.

Can you confirm:

  • Storage backend. In my case its my own Linux box with the LE-cert using WebDAV. If you're getting this on a cloud provider, then it might be a different case. I know, most likely you wouldn't use LE-cert on those, but still ... covering all the bases.
  • The target URL works ok and has valid cert on your browser. In Windows 10 check also Edge as is it will use system settings just like Chrome. Firefox won't use system settings.
  • Is there is a proxy in use. A transparent proxy might generate a HTTPS-cert on the fly causing the issue. Your browser might accept the certificate root ok, but Enpass doesn't use your Windows 10 certificate storage at all.

It would help this case if you can share the above details on your setup.

Share this post


Link to post
Share on other sites

Hi,

I can confirm that no proxy is in place at either end. If I have my desktop and my laptop on the same home network (both Windows 10), my desktop can sync fine with the WebDAV server but my laptop cannot (error 904035). Both are running Enpass 6.1.0 (407). I could not find any Enpass logfile.

The server is Nextcloud on Linux with a Let's Encrypt certificate.

The certificate is accepted automatically in both Internet Explorer and Edge. It is signed by Let's Encrypt Authority X3 which is signed by the trusted CA DST Root CA X3. I have also verified that the server is sending the chain certificate from the command line.

But today it is working. Nothing has changed, I have not upgraded Enpass and the certificate on the server has not rolled over. There haven't been any Windows Updates either (I run OOSU to prevent them). Edit: it worked once, now it is giving Webdav error code 909975

-davidc

Edited by davidc

Share this post


Link to post
Share on other sites
1 hour ago, davidc said:

I can confirm that no proxy is in place at either end. If I have my desktop and my laptop on the same home network (both Windows 10), my desktop can sync fine with the WebDAV server but my laptop cannot (error 904035). Both are running Enpass 6.1.0 (407). I could not find any Enpass logfile.

Ok. Then its not the same case I have.

Quote

The certificate is accepted automatically in both Internet Explorer and Edge. It is signed by Let's Encrypt Authority X3 which is signed by the trusted CA DST Root CA X3. I have also verified that the server is sending the chain certificate from the command line.

That's what I experience. All browsers trust the certificate chain ok, but Enpass doesn't. It seems to have a certificate vault of its own.

Share this post


Link to post
Share on other sites

Hey guys,

Sorry for the trouble you are going through.

Our dev team is working into this issue and hopefully a fix will be available with the subsequent update.

Thanks for your co-operation.

 

Share this post


Link to post
Share on other sites
On 7/8/2019 at 3:22 AM, Anshu kumar said:

Our dev team is working into this issue and hopefully a fix will be available with the subsequent update.

Thanks for that. I'll be looking forward for any new software versions which might address this issue.

Meanwhile, I managed to replicate the problem on  a laptop waking from sleep. There is no proxy configured, but this specific sync error will occur towards my WebDAV server. When that happens, sync attempt will continue forever without timing out. Since there is no Cancel Sync -button available to manually abort the forever failing sync, my fix is to quit Enpass and restart. Then the problem will be fixed. However, this does not happen every time after sleep wake. It happens often enough so, that I can confirm the failure.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...