Jump to content
nech+arHU

Enpass 5.2: High CPU usage since last update

Recommended Posts

Hi,

since the last update to v5.2 I notice sometimes high CPU usage caused by Enpass. This stops only if I kill the Enpass process completely. 

Ipan9nK.png

 

Has anyone else even this behavior?

 

System:

MSI GS30 Laptop

CPU - Intel(R) Core(TM) i7-4870HQ CPU @ 2.50GHz

Chrome (v50.0.2661.94) with Enpass extension

ownCloud sync enabled (ownCloud 7.0.1)

Ubuntu 14.04 with GNOME desktop

Edited by nech+arHU

Share this post


Link to post
Share on other sites
Guest Ankur Sahu

Hello @nech+arHU,

Sorry for the problem you are facing. We are looking into it and have checked it here on all test environment setups but are unable to reproduce it. To figure out the issue, please try to figure out the cause at your end by

  • Turning off Browser Extension and check. 
  • Turning off the 'Sync' and check

Please also try restarting with a eye on other settings and setup at your end.

Share this post


Link to post
Share on other sites

Just wanna add that, for me, this doesn't happen right of the bat.
Enpass can be running for a day or a day and a half and all of a sudden (while doing something completely different, not even using the browser)
Enpass starts spiking up to 100% cpu load.

I'll try and find a way to reproduce it but that's going to be difficult

Edit:
@Ankur Does enpass sync every now and than while in background?
I noticed, while enpass was at 100% cpu load and re-opening it, it was syncing and didn't manage to "finish"

Edited by Tadly

Share this post


Link to post
Share on other sites

Alright, it's happening more frequently now (no idea why) and I'm pretty sure it's related to background syncing.
As mentioned before, everytime the cpu spikes, enpass is trying to sync (and apparently fails doing so)

Changing an entry and syncing manually works just fine.

My setup than:
Webdav server (I'm using wsgidav for that) behind apache2 with reverse proxy and a private wildcard ssl cert

Share this post


Link to post
Share on other sites
9 minutes ago, Tadly said:

I'm pretty sure it's related to background syncing.

Since I changed some settings including the deactivation of the sync function, I don't have these spikes anymore.

I used a SSL certificate from StartSSL that expired for a few days. Maybe this was the problem.

Share this post


Link to post
Share on other sites
On 6.5.2016 at 3:05 PM, nech+arHU said:

Since I changed some settings including the deactivation of the sync function, I don't have these spikes anymore.

I used a SSL certificate from StartSSL that expired for a few days. Maybe this was the problem.

Hm, as I'm using my own cert which doesn't expire in quite some time, I think there's more to that.

Just saw there's a version bump to 5.2.1.1
Let's see if that fixes anything

Edit:
Nope, 5.2.1.1 doesn't fix that issue

 

Oh and btw. this doesn't happen on windows (which I'm forced to use at work *shakes fist in anger*)

Edited by Tadly

Share this post


Link to post
Share on other sites

Hm.
For whatever reason this happens way more frequently while connected to my offices wifi than when I'm at home.

Might it be related to unstable network connections (like micro timeouts or whatever)?

Share this post


Link to post
Share on other sites

Hi guys,

Thanks a lot for your help in finding the issue. We are looking into this bug but are not able to reproduce it here and your help is really appreciable. :)

Enpass does make use of High CPU at the time of unlocking the keychain (mainly due to 24K PBKDF2 iterations), but only for less than a second. So one of the possible cause may be that under some particular conditions/environment/point of time, Enpass is failing to unlock it and constantly trying. There may be other reasons as well.

On 6 May 2016 at 5:32 PM, Tadly said:

Does enpass sync every now and than while in background?

If unlocked, Enpass initiates a sync operation (first it checks if there is something to be synced) after every 10 minutes and behavior is mentioned  here in user manual

On 6 May 2016 at 6:19 PM, Tadly said:

As mentioned before, everytime the cpu spikes, enpass is trying to sync (and apparently fails doing so)

Do you get any error when it fails doing so and does manual sync (by clicking the sync icon or Sync now button) completes the operation of sync?

On 6 May 2016 at 6:35 PM, nech+arHU said:

Since I changed some settings including the deactivation of the sync function, I don't have these spikes anymore.

Confirms that the problem is in either attempting a sync operation or in syncing data. Both these are different operations and need to unlock the Keychain (causing high CPU usage). Attempting a sync means, Enpass is communicating with WebDAV/ownCloud for any changes in data to sync and if changes are detected in local or server data (by checking time stamps), the real sync operation is performed.

So enabling sync = High CPU usage for long time indicates, there could be a problem in any of the following

  • Either communicating with ownCloud to check for any changes.
  • Every time ownCloud is indicating there are changes but it fails to sync and the process is repeated every 10 minutes.

To troubleshoot the issue further, please sync the data manually while keeping the Enpass is foreground (this will make sure that there is nothing to be synced) and then keep it in background with sync enabled. If the CPU usage becomes high for more than a second, it is confirmed that there is problem in just attempting the sync. It would be a great help, if you could please PM me a demo account on your ownCloud server.

Cheers!

Share this post


Link to post
Share on other sites

Hi Hemant and thanks for your time.

To answer some of your questions:

1 hour ago, Hemant Kumar said:

Do you get any error when it fails doing so and does manual sync (by clicking the sync icon or Sync now button) completes the operation of sync?

Nope, no errors what so ever (I assume starting enpass from a terminal won't reveal any useful informations but I'll try anyway later on)
As enpass is already trying to sync, I physically can not press the sync button myself as they are gone both within the settings and the normal UI
If I open enpass, unlock it and sync myself it works just fine.

1 hour ago, Hemant Kumar said:

It seems the issue is with WiFi bearer in Qt as mentioned here in upstream bug https://bugreports.qt.io/browse/QTBUG-49953

Renaming bearer directory i.e.

Hm, interesting.
However, renaming that directory causes sync not to work at all (even after re-configuring my sync settings)
I'm not a Qt expert but I assume the bearer stuff is something network related meaning it's kinda obvious sync doesn't work anymore?

Share this post


Link to post
Share on other sites

Just for the log...

Starting enpass from a terminal and leaving it in the background until the CPU spike happens, I end up with...

Quote

QIODevice::read (QDisabledNetworkReply): device not open

...flooding the terminal while enpass tries to sync (and never finishes)

Hemant already knows about it and got some demo login-data to my webdav server.
Let's hope that's of any help (:

Share this post


Link to post
Share on other sites

Hi guys, Are you still getting this issue?

We tried this here using the provided demo accounts of ownCloud, but not able to produce it. As requested in the PM to you, if possible can you be online on Skype or Team-viewer to discuss it further. 

Thanks for your time. Cheers!

Share this post


Link to post
Share on other sites
14 minutes ago, Hemant Kumar said:

Hi guys, Are you still getting this issue?

We tried this here using the provided demo accounts of ownCloud, but not able to produce it. As requested in the PM to you, if possible can you be online on Skype or Team-viewer to discuss it further. 

Thanks for your time. Cheers!

Funny, forgot to close Enpass today at work and just got the spike again.

Not sure who you PMed but I might be able to squeeze that in if you want (only via google hangouts or teamspeak though. Got my own teamspeak server)

Just wanna mention again that this seems to be related to wonky network connections as I only get the spikes while at work, not at home.

Share this post


Link to post
Share on other sites
On 5/20/2016 at 9:26 AM, Hemant Kumar said:

Hi guys, Are you still getting this issue?

We tried this here using the provided demo accounts of ownCloud, but not able to produce it. As requested in the PM to you, if possible can you be online on Skype or Team-viewer to discuss it further. 

Thanks for your time. Cheers!

I have also still this problem with version 5.2.1. I'm in another country for 2 months. I noticed this problem only since this travel. (When was version 5.2 released?)

I have poor WiFi at the apartment but noticed this problem also at work where I connected via cable. (But this ethernet connection is also not really reliable / stable.)

Next week I'm home again, there I have a stable connection for sure and I can tell if it is related to this problem. Currently I disabled the sync function otherwise I would got this problem a few times a day.

 

On 5/20/2016 at 9:44 AM, Tadly said:

Funny, forgot to close Enpass today at work and just got the spike again.

Not sure who you PMed but I might be able to squeeze that in if you want (only via google hangouts or teamspeak though. Got my own teamspeak server)

Just wanna mention again that this seems to be related to wonky network connections as I only get the spikes while at work, not at home.

If you say 'spike' do you mean the cpu load is only for a few seconds high?

Because for me the cpu load only goes down when I kill the process completely. I saw it already that enpass running on 90% of one cpu core for more as 30 minutes (then I killed it).

Edited by nech+arHU

Share this post


Link to post
Share on other sites
16 minutes ago, nech+arHU said:

f you say 'spike' do you mean the cpu load is only for a few seconds high?

Because for me the cpu load only goes down when I kill the process completely. I saw it already that enpass running on 90% of one cpu core for more as 30 minutes (then I killed it).

No, by spike I actually mean that its load is at 90+% all the time (up until I kill it of course).
Sorry for the confusion

Share this post


Link to post
Share on other sites

Hi,

 

Since there's no new posts for ~20 days I would like to ask you all if this issue is gone. After some time using Windows I'm going back to Linux (Arch and Mint) and I saw on AUR some comments about this thread. On a quick check on Mint 18 (beta) I couldn't see any high CPU usage but still was strange to see Enpass most of the time consuming 1~2% constantly even when it was (well, apparently) idle. 

Selection_001.png.347218d05d2c07d4526f64

Share this post


Link to post
Share on other sites
1 hour ago, Joel Teixeira said:

Since there's no new posts for ~20 days I would like to ask you all if this issue is gone. After some time using Windows I'm going back to Linux (Arch and Mint) and I saw on AUR some comments about this thread. On a quick check on Mint 18 (beta) I couldn't see any high CPU usage but still was strange to see Enpass most of the time consuming 1~2% constantly even when it was (well, apparently) idle. 

Yap, for me this issue still exists (sadly) and for the life of me I can't get wondershaper to work to test if i can reproduce it that way @home

I've basically done es much testing and "debugging" as I could with what's given.
If Team Enpass want's me to do more, I'd need source insight or whatever.

Other than that, I can't really do a whole lot more.

Share this post


Link to post
Share on other sites

Hi Guys,

Sorry for the trouble and keeping you on wait for so long time.  We have fixed the issue with WebDAV sync that was causing the high CPU usage along with some issues in memory consumption. We will release an update.

Thanks for your understanding!

Cheers!

Share this post


Link to post
Share on other sites
26 minutes ago, Hemant Kumar said:

Hi Guys,

Sorry for the trouble and keeping you on wait for so long time.  We have fixed the issue with WebDAV sync that was causing the high CPU usage along with some issues in memory consumption. We will release an update.

Thanks for your understanding!

Cheers!

Oh, you really found the issue?
That's awesome news!

Thanks a lot :)

Share this post


Link to post
Share on other sites

Hi guys,

Sorry to keep you on wait for so long. We have released a Beta version with some new features, improvements and fixes including one for this high CPU usage issue. For complete change-log and download links, have a look at

The issue was due to a nasty bug in Qt's network manager (though they claim to have fixed it but its still there in Qt) which was not giving exact state of network after the system was woke up from sleep-mode. In this beta version it has been fixed using a workaround. Some other software like ownCloud were also affected and they also managed to fix it through some workaround

Please try it and let us know about the behavior of CPU after you wake up the PC from sleep.

Cheerio!

Share this post


Link to post
Share on other sites

Grrrr, Qt... I never liked it.

Anyway.
I updated to the beta now, lets see what happens.

@Hemant
After updating I had some issues with libssl again as the Enpass binary was using libssl.so and libcrypto.so from my system installation.
This failed with:

/opt/Enpass/bin/Enpass: symbol lookup error: /usr/lib/libssl.so: undefined symbol: EVP_idea_cbc

To fix it I had to create the following symlinks within /opt/Enpass/lib:

  • libcrypto.so -> libcrypto.so.1.0.0
  • libssl.so -> libssl.so.1.0.0

I remember this (or something similar) being the case some time ago so I was wondering if you guys
could include those symlinks within the build.
If not, I'll just create them in my PKGBUILD for archlinux

Edit
And there's the CPU load again :(
Took ~1 hour until Enpass run at 100% again.

Edit 2
I just wanted to mention/clarify that the issue does not occur while suspending/resuming (It might, I never tried that).
For me, Enpass just needs to be running and at some point the CPU (one core to be exact) suddenly jumps to 100%
and stays there until I quit the application.

Edited by Tadly

Share this post


Link to post
Share on other sites

Hi @Tadly

Thanks for trying Beta and your feedback. We have released another beta version 5.2.4 with fixes for sync issue.

On 11 July 2016 at 1:20 PM, Tadly said:

To fix it I had to create the following symlinks within /opt/Enpass/lib:

  • libcrypto.so -> libcrypto.so.1.0.0
  • libssl.so -> libssl.so.1.0.0

I remember this (or something similar) being the case some time ago so I was wondering if you guys
could include those symlinks within the build.

Symlinks are now there in new beta version. 

On 11 July 2016 at 1:20 PM, Tadly said:

And there's the CPU load again :(
Took ~1 hour until Enpass run at 100% again.

Unfortunately we are unable to produce this issue and have tested for it in different scenarios. If possible, can you try a debug version through gdb so that we can have the culprit function name (at least, something to start with). If you wish, you can try that with some sample data first (with all features enabled).

Cheers!

Share this post


Link to post
Share on other sites
1 hour ago, Hemant Kumar said:

Hi @Tadly

Thanks for trying Beta and your feedback. We have released another beta version 5.2.4 with fixes for sync issue.

Symlinks are now there in new beta version. 

Unfortunately we are unable to produce this issue and have tested for it in different scenarios. If possible, can you try a debug version through gdb so that we can have the culprit function name (at least, something to start with). If you wish, you can try that with some sample data first (with all features enabled).

Cheers!

Hey @Hemant Kumar

I'll give 5.2.4 a shot right after writing this post. (I'll edit this post again once I got something to report)

In regards to testing a debug version, sure (IIRC I already offered to do that some time ago ;P)
I'm still new to c/c++ (and gdb for that matter). So if you have some instructions on what exactly you want me to do, that'd be great.
Obviously I could play around myself but with instructions  everything should be faster and less time-consuming (:

Edit:
Well, that didn't work. Got the high cpu load again.

For the record (that means every one else who's still following this thread), Hemant is preparing a debug version for me (we'll keep that discussion private for now).
Hopefully that'll give some insight (:

Edited by Tadly

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...