Jump to content
Enpass Discussion Forum

Copy to clipboard not working any more

Recommended Posts

Hi @Discordant,

Thank you for your suggestions. Use of TransientType instead of ConcealedType, was to support maximum number of Clipboard history managers at the time of introduction of this feature. It think we must re-evaluate the usage of clipboard flags according to current support status by Clipboard history managers and fix things as per your suggestions. 

Link to comment
Share on other sites

  • 3 weeks later...

@Vinod Kumar

On 8/24/2021 at 1:33 PM, Discordant said:

My tests show that Paste.app doesn't import the clipboard contents from Enpass or 1Password,

1Password v7.8.8 & Paste.app v3.0.11 on macOS 11.5.2 works fine for me, anything copied from 1P is passed along to Paste.app. I've unchecked "Ignore Passwords & Other Confidential Data If Detected" in Paste.app, as well. They recognize it's preferable to let the user decide the amount of security they need and don't force it on the user.

Hate to be a killjoy ... but I wish developers would stop trying to force security measures without ways of turning them off via a pref, for those who choose, or need this behavior. I WANT all my copied data to appear in Paste.app. And If I choose to not have that happen I can turn it off in both Enpass or Paste.app. I don't need a dev to tell me how to work safely, or force an amount of their perceived safety on the user. If need be turn on the protection by default, but give a pref to turn it off. Problem solved. And for me it is a problem—especially if 1Password has this behavior & I'm use to it.

I now own a lifetime version of Enpass. I'll be here trying to guide development, features, offer suggestions, etc, that will help Enpass be a better Mac/iOS/iPadOS app.

If this one feature alone were fixed I'd be a VERY happy camper—even though Enpass isn't a fully realized Mac app. Enpass still needs basic MacOS UI fixes, arrow keys in fields, Copy, Cut, Paste menus in the Edit menu, proper text highlight in fields in MacOS dark mode, et. al.—but this is not that discussion right now. lol

Hope this helps & does not offend.

PS ... 

I tried posting this reply a few weeks ago, but the forum software kept giving me the error that I tried posting this reply too many times—on my first try & any subsequent try thereafter no matter how long I waited. Hopefully ... many days later ... it will post. ¯\_(ツ)_/¯ 

PPS ... Since writing this post (which thankfully I saved in Pate.app) I've switched back to Enpass and running parallel to 1Password—though I am using Enpass the most.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

  • 3 months later...

I am a long time user of Enpass Pro and this weird behaviour has started to be very annoying, to be honest.

My specs are:

  • macOS Monterey 12.1 (this was happening in Big Sur and Catalina as well but not that frequently)
  • EnPass Pro 6.7.4 (938) Mac App Store version

The problem is that copying a password does not always work on all of these cases:

  • Copying the password from an already saved item
  • Copying the password from the generate new password screen (either while editing an item or from the main Enpass menu

I have searched the threads of this forum and see a lot of people have reported this issue, and your recommendation of upping the clipboard clear timeout does not work. After all, in my cases, I am trying to paste almost immediately.

Edited by WizMeister
Link to comment
Share on other sites

  • 7 months later...

Since I see users are still having this issue, it's been fixed for me on my Mac. One thing I did was stop using the App Store version & started using the downloadable version which gets updates more frequently than the App Store version. Plus I also download & use the newest beta version of (downloadable) Enpass Premium Mac.

Currently running:

MacOS 12.5.1 (21G83)
Enpass Premium Beta 6.8.2 (1083)
Paste (clipboard manager) 3.1.9

Now I can't say for sure who fixed what; whether it was Enpass or Paste, but when I copy a password from Enpass it gets copied to the clipboard & recorded & saved in Paste.  This works as expected in either edit mode selecting the password & copying, or in a saved password entry by clicking on the copy button on any field in the entry including the password.

Your mileage may vary. Hope that helps. ¯\_(ツ)_/¯

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy