Jump to content
Enpass Discussion Forum

Onedrive sync error 507978

Jonathan B

Recommended Posts

Have had enpass installed for a couple of years.  Working fine from day one when I got my SG 10+.   Today it won't sync with one drive and get an error 507978.  Tried all the suggestions on the support site to no avail.  Not sure why this error occurs as I couldn't find anything on-line with the same error code.

Any advice on how to resolve is greatly appreciated.

Link to comment
Share on other sites

Hi @Jonathan B,

Please follow the below given troubleshooting steps and let me know if the problem persists.

  • Turn off the sync on all the devices.
  • Open OneDrive in any browser --> Apps --> open Enpass folder --> Select vault.enpassdbsync --> Rename it as oldvault.enpassdbsync.
  • Now open Enpass and turn on the sync.

I also recommend to check if you have exhausted the OneDrive storage limit on your account.

Link to comment
Share on other sites

Thanks Tahreem

Plenty of space on OneDrive.  Tried what you said but to no avail.  Switched to google drive and back up and running on all devices. 

I probably should have ensured that OneDrive cleared the file on the local storage on all devices before re-enabling.  I may try that later.

For now, flipping to google drive has at least got me back up and syncing between devices..

Link to comment
Share on other sites

Hi @Jonathan B,

To check this further, as you have already switched to Google Drive for syncing purposes:

  • Please delete the sync folder of Enpass in the OneDrive account. 
  • Create a new dummy vault in Enpass app on any of your devices.
  • Connect it to OneDrive and also connect another device's dummy vault to it to test the working. 
  • Now make some dummy items in the vault and check to see if the same are synced to another device after syncing. 

Let me know if this works!

Link to comment
Share on other sites

I'm having a similar issue in Empass for Android.  Empass says my storage limit has been reached for OneDrive and it fails to reauthenticate. 

I followed the instructions to disconnect and renamed the vault in OneDrive to 'oldvault' but when trying to resync Empass to OneDrive it fails giving a message in Enpass

"The sync with OneDrive was cancelled by the user." But I did not cancel it.  Then trying again Enpass is stuck back on the error message saying my OneDrive Storage Limit has been reached.  I confirmed that I have storage available in OneDrive by copying a file successfully into OneDrive.  I pay for 1TB in my OneDrive and space is not a problem.  I noticed Enpass updated recently... is there a bug in the app?!?    Please Help - I need my password manager to be syncing!

Edited by EricK
Update on troubleshooting tried
Link to comment
Share on other sites

Hi @EricK,

Sorry for the trouble you are going through.

For quick troubleshooting, disconnect the sync from all the devices and reconnect it. If your problem persists, please share the following details so that we can investigate where the problem could be.

  • On which devices and OS versions (mention all) are you using Enpass?
  • Which Enpass version are you using on each device?
  • Are you getting any error message or code during sync? If yes, share it with us.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy