Jump to content
Thejoe

Chrome extension cannot link with Enpass

Recommended Posts

Hi i hope anyone can help me ;)

Steps to repoduce:

  • Install latest Enpass 6.3.3 (i used native App)
  • Link to cloud webdav when you can, i think this is not necessary
  • Disable Browser Code-Signature (for Vivaldi)
  • Install Extesnion on Vivaldi or Chrome
  • Try to link the Browser to Enpass
  • Browser will show the Passcode but Enpass DesktopApp do nothing

I tested it with Edge and Firefox, both work but Chrome and my Browser Vivaldi not.

24.2.2020, 22:35:47 : Connecting using websocket
24.2.2020, 22:35:47 : Opening connection on ws://127.0.0.1:10391
24.2.2020, 22:35:47 : Connection opened
24.2.2020, 22:35:47 : Connection established on port 10391
24.2.2020, 22:35:47 : Message parsed successfully
24.2.2020, 22:35:47 : Greetings from Enpass
24.2.2020, 22:35:47 : Self Initiating srp.
24.2.2020, 22:35:47 : Authentication required
24.2.2020, 22:35:47 : Termnating srp initialization process.

 

Share this post


Link to post
Share on other sites

Hi @Thejoe,

We are sorry for the inconvenience caused to you.

Sometimes rebooting the device might help with this issue, we suggest you to please try rebooting your device if you haven't tried it yet. If the problem persists, please uninstall the Chrome browser and install it again.

Share this post


Link to post
Share on other sites

I tried all, reinstall Browser multiple times, reinstall enpass multiple times, uninstall Antivirus, deaktivate Firewall, reboot, ...

I have no idea what i can do

Share this post


Link to post
Share on other sites

Hi @Thejoe,

Please revert to us with the answer to the following queries, and we will try to get it sorted out for you:

  • On which device (along with OS version) are you using Enpass?
  • Which Enpass extension version are you using?
  • Which Chrome and Vivaldi version are you using?
  • Are you using any Antivirus or third-party security-related extension?

Thanks!

Share this post


Link to post
Share on other sites
  • On which device (along with OS version) are you using Enpass?
    • Win 10 home 1909 latest patches (installed today)
  • Which Enpass extension version are you using?
    • 6.2.1
  • Which Chrome and Vivaldi version are you using?
    • Chrome: Version 80.0.3987.87 
    • Vivaldi: 2.11.1811.44 (Stable channel) (64-Bit) Latest Version 
  • Are you using any Antivirus or third-party security-related extension?
    • I use Eset with Firewall, then i reinstalled without firewall and at end i uninstalled eset completely
  • Enpass Version
    • 6.3.3 (597)
  • additional Software with Networkdrivers
    • Virtual Box, OpenVPN

I tried to reproduce it in a VM, but it works in the VM :(
I can't unterstand why the Firefox and Edge can communicate with enpass and why chrome/vivaldi not.

 

Share this post


Link to post
Share on other sites

Hey @Thejoe

Please try the below and let us know if the issue persists:

  • For Chrome: Go to System Preferences ➝ Network ➝ Ethernet/ WiFi/ Other Network ➝ Advance ➝ Proxies ➝ Web Proxy (HTTP) and in the Bypass proxy settings for these Host & Domains box➝ Add 127.0.0.1 and then try establishing connection.
  • For Vivaldi: Could you please try to check the same with the 32 bit Vivaldi and share the findings with us. 

Thanks.

Share this post


Link to post
Share on other sites

Hi,

sorry for the late response i forgot that you write back.
In my Chrome i can only go to the win10 Preferences, i have no proxy but i add it to the box and activate the Proxy. On Vivaldi its the same, but on both browsers no change.

At the moment the world are crazy and i have time. I think i will reinstall my laptop or do you want to find out the error in chromeplugin?

Share this post


Link to post
Share on other sites

Hi @Thejoe,

Thanks for writing back in.

Please let us know what you mean by

On 3/13/2020 at 2:04 PM, Thejoe said:

, i have no proxy but i add it to the box and activate the Proxy

Also let us know did you try to install the 32 bit Vivaldi and check. 

Share this post


Link to post
Share on other sites

In my Network i have no proxy and in Windows 10 i need to activate it.
image.thumb.png.99bf657f9aaf338c0ad1f4c1d07669fd.pngimage.thumb.png.76c5504d6e24fbaf8aa2e378187a5230.png

i Activate Proxy and try to connect and deactivate it and try to connect. Both don't Work.
I try the win 32 but same result.

Today i have a new "problem" the autoupdater can't download the new version but find that is a new version available. Is this the same Methode? The message came instantly no timeout. Help this? 

image.png.a6e5150bdc0d03347cadde88c2904328.png

Share this post


Link to post
Share on other sites

Hi @Thejoe,

We need a little more input from you can you please share the screenshot of Review Browse from the Enpass browser setting. Also let us know have you enabled/disabled the option Authorize browser with verified code signature only in Enpass browser setting.

Thanks for your co-operation.

Share this post


Link to post
Share on other sites

Hi,

i hope you mean this settings? I tried with both with signature and without. I reset all enpass and vivaldi settings before i install enpass and vivaldi multiple times.i think it is all standard.

Vivaldi works on my PC with Code signature.

image.thumb.png.ddb88637ad37ea903df02819a9c0338b.png

Share this post


Link to post
Share on other sites

I tried all the above mentioned troubleshooting steps but still no luck.

It would be great if you guys can install Sophos Home Antivirus (Free) and see for yourself if the enpass chrome extension works or not instead of asking people to do loads of steps.

 

Its unfair to ask people to perform lengthy steps to solve problems. its a simple way, as you are the product owner, try out on your computer to see how it behaves and let us know a perfect solution for this issue.

if this issue cant be fixed then there is no point in using Enpass product itself.

Edited by Sujithkumar

Share this post


Link to post
Share on other sites

@Sujithkumar

11 hours ago, Sujithkumar said:

It would be great if you guys can install Sophos Home Antivirus

You will either have to disable Sophos Anti-virus in order to let the extension communicate with Enpass app or bypass the localhost connection following the steps mentioned in the help article here. Let us know if this helps in solving the problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...