Jump to content
Johannes13

WebDav sync fails with 908401

Recommended Posts

I'm using nextcloud/owncloud before that as a means to sync data between desktop and android for 4 years now and enpass for about 2,5 years.

At some point this year the sync-function in the android-app (version 6.4.5.368 with android 8.1.0 at the moment) stopped working, resulting in the error 908401. I worked around that until now, but of course that defeats the point.
The sync-function still works fine on desktop and I have verified, that I use the correct login-data and the server is still accessable from the phone.

Any Ideas how to resolve this?

 

Share this post


Link to post
Share on other sites

Hi @Johannes13

We are sorry for the inconvenience caused to you.

908401 can be broken down to (908)-(401) where 908 is our internal representation of error which changes very often and the last 3 digits refer to HTTP error which is 401 here. HTTP error 401 refers to unauthorized access errors which usually happens due to incorrect username or password combination.

For quick troubleshooting, disconnect the sync from all the devices and reconnect. If the problem persists, please share the demo account of your WebDAV so that we can investigate where the problem could be.

Thanks.

Share this post


Link to post
Share on other sites

Hi, have the same problem. 
WebDAV running on Synology Diskstation, Mac Enpass syncs fine, no sync on iPhone. Error message: Connection to WebDAV not possible, please check user name and password. WebDAV is accessible from every other app on iPhone. 
 

Thanks

Edited by zyg

Share this post


Link to post
Share on other sites

Hey @zyg

Have you turned on the 2FA for your WebDAV account?

Please share the demo account of your WebDAV so that we can investigate where the problem could be. Thanks!

Share this post


Link to post
Share on other sites

Hi Garima,

absolutely no changes in WebDAV setup, iPhone sync just stopped working. And as already mentioned, the mac Enpass sync works fine and I can access the WebDAV folders with every other mobile phone app (e.g. I can see the vault file with File Browser). 
Unfortunately I can’t share the demo account as my NAS works in local network only. 

Thanks, 

zyg

Share this post


Link to post
Share on other sites

Hey @zyg

Thanks for sharing the details.

It seems, Enpass is creating the Enpass folder again on the webdav (NC)account but does not upload any data to it. This might be happening due to Enpass not having correct permissions to create/upload files on your NC Account. Please make sure you've given sufficient permissions for it, otherwise, we would be able to provide a debug build which records logs of your interaction with NC account. Those logs can be analyzed by us and provide you with a detailed answer.

Thanks.

Share this post


Link to post
Share on other sites

Sorry, I can’t follow this. The NAS permissions are given by user name and password in this case. There is no possibility to assign separate permissions to particular app. I double checked with two different apps and both can create folders and files in the dedicated NAS directory.
 

I suggest you check the change logs of the latest Enpass updates, This bug is extremely disappointing, local sync was one of the most important criteria for me to choose Enpass. 

Edited by zyg

Share this post


Link to post
Share on other sites

Hey, 
I have tried removing the sync from all devices (and removing the data), but afterwards I get the same error.

If I connect via desktop, a new Enpass-folder is created. If I only connect via android-app (same user), no Enpass-folder is created and it fails with the error 908401 even though all login-data is correct. 

I have also tried creating a new account. Again it works just fine on desktop but not at all in the android-app. I will send you a PM with the login-data for that account for you to verify, as requested.

Thanks.

Share this post


Link to post
Share on other sites

Hi Garima,

it totally slipped my mind that my iPhone runs with beta iOS14. After Apple provided another upgrade this weekend, the WebDAV sync works again. Can't explain why this only hit Enpass while all the other apps were working, but I truly apologize. Everything is fine now!

Best, zyg

  • Like 1

Share this post


Link to post
Share on other sites

I had these same symptoms, but not using NextCloud. The issue ended-up being an update to nginx that enabled some sandboxing features that was fixed by adding the webdav directory to the systemd config under ReadWritePaths. Might be the same issue with NextCloud see: https://wiki.archlinux.org/index.php/Nextcloud#Explicitly_permit_Nextcloud_directories_for_php-fpm

Edited by psophis
  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...