Jump to content
Enpass Discussion Forum

Beta 6.5.0 (699) BUG - Main Window sometimes fails to render

100 Watt Walrus

Recommended Posts

Hi folks,

Another Beta 6.5.0 (699) bug for you: Sometimes the Main Window fails to property render upon launch (i.e., when Enpass is not running in the background).

I have not yet been able to reliably recreate this, but I'll continue to look for a pattern, but here's a screenie.


(2010 MBP — macOS 10.13.6)

2020-08-27 BUG Enpass 6.5.0b window render.jpg

Edited by 100 Watt Walrus
Wrong version#
Link to comment
Share on other sites

Happened again, so I have a little more data:

  • Enpass was having performance issues, specifically Enpass Assistant was taking 30-60 seconds to open after entering the password, and I was getting beachball while that was happening
  • Enpass was consistently in the top 5 CPU users, even when no Enpass UI was open at all
  • So I quit Enpass completely
  • And when I relaunched, the "invisible window" shown in screenshots above reoccurred
  • After quitting and relaunching again, everything was fine

I'm sending an Activity Monitor process sample to support@enpass.io from after that relaunch, when the window was failing to render. If I get the hang-up issues again, I will try to send a sample of that too, since it may be a precursor.

BTW, the unlocking of Enpass Assistant seems to almost always take longer that it should, and that's from before, I just hadn't gotten around to reporting it. After typing my password, I almost always get 5-15 seconds of the "thinking..." GIF (the dots chasing each other in a circle) before Enpass Assistant unlocks. But when this is happening "normally," there's no beachball, as there was in the incident reported above.

Edited by 100 Watt Walrus
additional clarifying info
Link to comment
Share on other sites

  • 2 weeks later...

Another data point for you (if you've found the issue and don't need more examples, just let me know!):

Today crashed on me, and the same "clear window" occurred on relaunch. This bug seems to occur (almost?) exclusively when relaunching Enpass after having encountered a problem that either caused the app to crash, or was a big enough problem that I chose to quit and relaunch. This should allow you to reliably recreate the "clear window" rendering problem.

Today's scenario:

1) I was creating a new Item (by my usual non-standard method of duplicating an existing Item and editing it, because that's faster than creating from a template)

2) The new item did not automatically populate the icon with a favicon, so I clicked the icon and chose "Use Website Icon"

RESULT: "Website icon for this item is not available on server at this moment"

3) Added a second URL for this Item (there are two sites), and dragged that URL field above the original URL field

4) Clicked the icon, but before clicking "Use Website Icon" again, I did a CMD+S (it's a habitual reflex for me to save as I go on everything, so this was done absent-mindedly)

4) But in the moment before the save occurred, I realized I was saving without having clicked "Use Website Icon" again (the contextual menu was still displayed), so while the save was taking place, I clicked "Use Website Icon"

RESULT: Crash.

5) Relaunch

6) Fill out crash report request and submit

RESULT: Enpass launched with "clear window" problem

7) Quit Enpass, relaunch

RESULT: Enpass launches normally (although as mentioned in a different thread and reproduced by your team, it doesn't remember the size or position)

8) Search for the item created in Steps 1-3

RESULT: The item is there...and its icon is the site's favicon, even though the result of Step 2 was an error telling me the icon couldn't be fetched. (BTW, this isn't the first time I've tried to "use website icon," got that error, but later it turned out the icon was fetched after all.)

So there are three bugs here:

  • "Website icon for this item is not available on server at this moment" error is not always accurate — sometimes the icon is fetched, but doesn't show up until quitting/relaunching Enpass
  • Crash when doing CMD+S followed immediately by "Use Website Icon" before the Save action has been completed (obviously a corner case, but worth mentioning)
  • And the original problem: Main Window renders clear upon relaunch after a crash or quitting due to a problem


Edited by 100 Watt Walrus
Link to comment
Share on other sites

I've found a way to reliable reproduce this problem — and it seems to point to another bug:

1) Launch Enpass Main Window

2) Preferences > General > uncheck Show Enpass in Menu Bar

3) Close Main Window

HERE's THE NEW BUG: Instead of closing the window and continuing to run in the background, removing Enpass from the Menu Bar results in Enpass quitting when the window is closed. I'm going to make a separate thread about this bug.

4) Re-launch the Enpass Main Window (double-click icon in Applications, or launch from Spotlight)

RESULT: Enpass is launched but the Main Window renders "invisible" with just the outline of the window and the red-yellow-green dots in the upper left corner

NOTE: This is 100% reproducible the first time you launch after unchecking "Show Enpass in Menu Bar." Subsequent launches may or may not render the window correctly. But if you go back into Preferences, then turn back on Show Enpass in Menu Bar and then repeat steps 2-4, you will get the same result 100% of the time.

Link to comment
Share on other sites

  • 4 months later...
This topic is now closed to further replies.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy