Jump to content
Enpass Discussion Forum

Autofill Accessibility on Android 11


Recommended Posts

Hi!

Enpass was always working on my Galaxy S8 with Android 9. Yesterday, I installed enpass on my new S21 with Android 11, and suddenly the accessibility autofill service is no longer working. This happens with any site, for instance whe logging in to amazon.com in Chrome. I see the the Touch to Autofill notification in the adressbar, I can click it, and select Amazon, but it doesn't autofill. This happens on any site, and any app. I can see the notification, but the credentials are never filled. It only applies to the accessibility service, the regular autofill for apps that support it works. But for those that don't have this api, such as spotify, it doesn't work.

I tried disabling enabling it tens of times. I reinstalled the app a few times. Also, I ensured that enpass was not part of any battery saving measures on the device.

Tdlr; autofill by accessibility is working on older Android versions, but for the same sites and apps, doesn't work on Android 11 (OneUi 3.1)

Link to post
Share on other sites
  • 2 weeks later...

Hi @mdlc @jddddd @jnyer1227,

Sorry for the inconvenience.

Our QA team is not able to reproduce the issue can you please let us know the following details so we can further investigate:

  • Which Enpass version are you using?
  • Share the screenshot of your Enpass Autofill setting?
  • If possible ,share the video of the issue? It will help in a clear understanding of the problem before further proceedings.

Thanks!

Link to post
Share on other sites

Hi, I can confirm that this issue also exists on my Galaxy S21 running One UI 3.1, based on Android 11. I believe this issue may be exclusive to Samsung devices running One UI 3 or One UI 3.1.

I hope the team can sort this problem out asap as it's very frustrating to see that I am unable to autofill via accessibility service on my new phone.

Many thanks

Link to post
Share on other sites
On 2/23/2021 at 12:35 PM, Garima Singh said:

Hey @itservicesx & @mdlc

Thanks for sharing the inputs. For further testing, could you please disable 'Android auto-fill service' from the Enpass Browser settings and then enable the 'Auto-fill using accessibility'. Now try to auto-fill again on the same device and and share your findings with us.

Hi! I tried this, but it only makes things worse, since it disables the autofill for native forms, but it still doesn't work in the browser as described.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...