Jump to content
Enpass Discussion Forum

OneDrive sync error - Error Code: 1204060


Recommended Posts

I've just started getting a OneDrive sync error on my Android 11 phone.

Something went wrong while syncing with OneDrive. Error code: 1204060

I've tried "Force Stop" and relaunch - no change.

I've tried disconnecting OneDrive sync and re-enabling, no issue re-establishing but still get the error when trying to sync.

No issue with using OneDrive app on same phone to access the Enpass folder being used for sync.

Link to comment
Share on other sites

Hi @Anthony,

Please follow these troubleshooting steps and let me know if the problem persists. Make sure to take a complete backup of Enpass data and save it locally(in the device which has all the Enpass data saved).

  1. Disconnect the Onedrive sync from all your devices.
  2. Open Onedrive app or in the browser → Go to App → Open Enpass folder → Select vault.enpassdbsync file → Rename it as oldvault.enpassbdsync.
  3. Now open Enpass, re-setup the sync with OneDrive on all the devices and check.

If sync starts to work fine, you can delete the renamed old backup file from Onedrive.

Error Code: 1204060 comes when there is a SSL CERTIFICATE ERROR FROM SERVER SIDE.


Link to comment
Share on other sites

Thanks @Gulshan Dogra - having done nothing, I'm now only seeing Error code: 1204401 even after rebooting my phone.

What does this indicate?

I'm seeing no issues on any of my other devices. I have 6 devices (1 x Android phone, 3 x Android tablets, 2 x Windows 10 PCs) so disconnecting 'all devices' is quite an effort and not something I'm keen to invest time in unless there is no other way forward!

Link to comment
Share on other sites

I've managed to "fix" the issue, but I'm not convinced that what I did really fixed the problem. However, worth sharing in case it helps someone else.

I found this thread (

..and one of the instructions was "Log in to the site https://account.live.com/consent/Manage with the same Microsoft account and delete all the permissions for Enpass."

I went and took a look and found multiple sets of Enpass apps with associated permissions so I revoked/removed all the 'old' ones. I worked on the theory that the one with the matching icon and a 'most recently used' date in the previous 24 hours was the one to retain.

After doing that, I disconnected sync on my phone and was able to successfully re-establish sync without any error.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...