Jump to content
Colin Davidson

UWP App Stuck at Master Password

Recommended Posts

Hi,

I've been using the Windows 10 phone App for a while now - full version - and the installation on my Surface Pro 4does not work.

It initially worked perfectly in sync however it now fails and I left it a while to hope a fix would arrive, but perhaps I'm the only one...

I've uninstalled the app (perhaps leaving cache in the background) and restored the passwords from onedrive from my phone during installation, but i'm still stuck at the Master Password with no option for Windows Hello.

I recently updated to Anniversary edition and it didn't work before the update either.

Cheers,

 

 

Edited by Colin Davidson

Share this post


Link to post
Share on other sites

Hi @Colin Davidson,

It seems that you are facing the problem in unlocking using Windows Hello. For that please make sure you have Enabled Windows Hello from Enpass Settings. To do so please try these steps:

  • Login into Enpass by entering the Master Password.
  • Now go to Enpass Settings--> Security --> Enable Windows Hello. For more details please have a look at user manual link here.

Please let me know if it doesn't work after turning on Windows Hello with all possible details you could share.

Cheers!

Share this post


Link to post
Share on other sites

Hi,

The issue is that I cannot use the master password and cannot unlock.

The app is dead to me in Windows 10 on my surface pro 4, therefore I can't get in to turn off WIndows Hello.

As I say, if there is a way to clear the cache for the application then let me know, but currently an uninstall/reinstall is doing nothing.

Cheers,

Share this post


Link to post
Share on other sites

I seem to be having a similar problem.

I am no longer able to login using my master password on my Surface Pro 4.

However my master password works fine on my Windows Phone.

Both installations sync to Onedrive. It seems the Enpass app on my Surface Pro has become corrupt.

Now don't know what to do in fear I get locked out of my phone too if reinstall Enpass on my PC

Share this post


Link to post
Share on other sites

glad it's not just a single user issue and can be recreated!

I'm using windows hello and am reluctant to turn it off as I'm not 100% sure I know my master password so don't want to lock it out for testing.

the purpose of the universal platform is that it should work on all.

Perhaps consider a settings option to turn off hello, or is it just failing at that point?

Share this post


Link to post
Share on other sites

Hello,

After some investigation I have found a bug in Enpass.

I know what is causing the problem and found a workaround. This is explained in blue below.

I started having this problem the last few days. The only thing that could have triggered it was that I briefly tried out the Windows Hello login feature but then later turned it off. Since then I have been having the problem.

Cause: Enpass thinks I am using a US keyboard layout.

I live in the UK and my keyboard is UK English layout. But Enpass thinks I have a US keyboard! This was the reason why my master password kept on being rejected!

I proved this by doing the following:

  • Typing my master password directly into Enpass. Every time the password was rejected.
  • I then launched Notepad and typed out my master password. I cut and paste the master password from notepad into Enpass. Enpass accepted it!

My master password contains the character '#'.

  • Knowing this I tried typing in my master password directly into Enpass but this time instead of using the '#' button on my keyboard I entered 'SHIFT' and '3' which is the US equivalent of typing the character '#'.
  • Enpass recognised the password as valid and everything worked ok.

After Enpass accepted the password it seemed to revert back to UK English keyboard layout. I know this because when it auto locks and I re-enter the password normally it works ok.

However when I reboot my PC and launch Enpass for the first time it again wrongly assumes I am using a US keyboard. I then have to repeat the last two bullet points in order to access my passwords.

Can the Enpass Team look into this issue as a matter of urgency, many thanks.

Edited by Maceo

Share this post


Link to post
Share on other sites

@ Colin Davidson

Try typing your master password as if you were using a US keyboard. Its the special characters you need to be careful with. The following link shows the US keyboard layout.

Hopefully you will find Enpass on your Surface will now accept your master password if you pretend to be US ;) 

http://www.uk-yankee.com/articles/us-vs-uk-keyboards-layouts-and-how-type-poundeuroother-symbols

Share this post


Link to post
Share on other sites

I have no option to enter a password - Master or otherwise.

No Pin/Iris/Face/Fingerprint recognition.

The application is dead on my surface pro 4.

As for the keyboard bug, that was a good spot, but surely no application should be language specific especially one where special characters are so important!?

Share this post


Link to post
Share on other sites

@Colin Davidson

Sounds like you need to uninstall and reinstall the app! if you cant even type in your password!

It would be good to post a screenshot to get an idea of what you are encountering.

Edited by Maceo

Share this post


Link to post
Share on other sites

I've tried that, started fresh with the same master pass to try to inport but then it crashes at that point.

whether it's 'hello' or my data I'm unsure, but I'm a one device man now for a multidevice app/platform

Share this post


Link to post
Share on other sites

I installed Enpass from Windows Store on a Desktop without "Hello" and there was no issue - I just inserted the Master Password.

This desktop isn't used often - this is not a solution, so please use this as diagnosis that Hello seems to be the issue.

Cheers,

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×