Jump to content
mikeg

Workaround for OneDrive Sync Issue

Recommended Posts

Hello. Enpass cloud sync using OneDrive usually works very well for me. But this morning I experienced the problem of some changes made in the traditional Win32 desktop application not syncing to other devices (Windows tablet and Lumia 950). When I tried manual sync, the phone and tablet would fail repeatedly. "Last attempt" time updated, but "Last synchronized" date remained old. 

Then, I opened the Windows 10 UWP app on my PC, entered the same changes  I had made in the Win32 app, manually sync'ed, then tried to sync the phone and tablet again--and they both worked! So, it appears the Win32 application causes problems with cloud sync in my case--although the cause and workaround could be different for others.

Desktop: W10 1607 build 10.0.14393.187 | Enpass (UWP) 5.1.6 | Enpass (Win32) 5.3.0.1
Tablet:     W10 1607 build 10.0.14393.187 | Enpass (UWP) 5.1.6
Phone:    W10 1607 build 10.0.14393.189 | Enpass (UWP) 5.1.6

Edited by mikeg

Share this post


Link to post
Share on other sites

I have had problems with sync to OneDrive with the desktop app too. Had to disconnect and reregister. Also, authentication does not work with Edge on Insider build 14926 (and before). Had to set the default browser to something else (Opera in this case) and it worked as expected. Then set the default back to Edge. It is the only thing that I have found that doesn't work with Edge. Thanks.

Share this post


Link to post
Share on other sites

 

On 19/09/2016 at 10:49 PM, mikeg said:

 

Hello. Enpass cloud sync using OneDrive usually works very well for me. But this morning I experienced the problem of some changes made in the traditional Win32 desktop application not syncing to other devices (Windows tablet and Lumia 950). When I tried manual sync, the phone and tablet would fail repeatedly. "Last attempt" time updated, but "Last synchronized" date remained old. 

Then, I opened the Windows 10 UWP app on my PC, entered the same changes  I had made in the Win32 app, manually sync'ed, then tried to sync the phone and tablet again--and they both worked! So, it appears the Win32 application causes problems with cloud sync in my case--although the cause and workaround could be different for others.

Desktop: W10 1607 build 10.0.14393.187 | Enpass (UWP) 5.1.6 | Enpass (Win32) 5.3.0.1
Tablet:     W10 1607 build 10.0.14393.187 | Enpass (UWP) 5.1.6
Phone:    W10 1607 build 10.0.14393.189 | Enpass (UWP) 5.1.6

 

Sorry to hear about trouble @mikeg! Unfortunately, we are unable to reproduce this issue in our test lab. I would like to leave the thread open to find out if other users is experiencing the same issue.

 

 

On 19/09/2016 at 2:42 AM, JeffB said:

I have had problems with sync to OneDrive with the desktop app too. Had to disconnect and reregister. Also, authentication does not work with Edge on Insider build 14926 (and before). Had to set the default browser to something else (Opera in this case) and it worked as expected. Then set the default back to Edge. It is the only thing that I have found that doesn't work with Edge. Thanks.

Actually this issue is related to browser as when you enable sync, Enpass open the respective cloud login page. After entering the login details it will show a landing page, while displays 'Continue with Enpass.' But the Internet Explorer and Edge browser will not redirect the user to the landing page. Although your sync will work as the issue arise only with the landing page.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...