Jump to content
Enpass Discussion Forum

Start Enpass hidden


Recommended Posts

  • 4 weeks later...

In my previous post I only tested it in the way of quitting Enpass and manually starting it with the "-minimize" option which worked as already described. But I still got the issue after login.

After some time trying to find out what exactly causes the issue, I tried to remove the startup entry completely. But Enpass still started on login even if it should not as there is no startup entry.

Then I figured out that KDE by default saves the opened application in the session and restores them after login. But in that case, Enpass is started with "-session <some long session id>" instead of the "-minimize" option which obviously results in having the main window visible on start.

I've now configured KDE to always start a clean session on login without restoring previous opened applications and re-enabled the "Open Automatically at System Startup" option in Enpass. Now Enpass is starting with only the tray icon visible.

There is also an option to exclude specific application from session restoration, so excluding Enpass from the session restoration should also work. But in my case, I keep the session restoration completely disabled.

Link to post
Share on other sites
  • 9 months later...

I solved this problem using pkill and sleep command on autostart script (I'm using plasma desktop, the time perfect for me was 10 seconds), ex. "pkill Enpass && sleep 10 && /opt/enpass/Enpass -minimize".

Edited by lw4z
After more tests
  • Thanks 1
Link to post
Share on other sites
  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...