Jump to content

fermati

Members
  • Content Count

    22
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by fermati

  1. Trying to solve the Logitech issue I discovered that Enpass6beta is bypassing some macOS setups. Under Mojave/System Preferences/General I have the following choices: Show scroll bars: Always Click in the scroll bar to: Jump to the next page That works fine in the Finder and with other applications, but Enpass6beta is disregarding those choices. The scroll bar only shows when I click somewhere in the scroll bar column, and it disappears after a couple of seconds. And the cursor moves to the spots where I clicked instead of going down or up one page. Some, myself included are not really pleased with the Mac version of Enpass6beta appearance being imported from the Windows side. It seems that you may also have imported things under the hood at the same time. I hope you can fix this.
  2. You're a welcome Anshu kumer. Just an update about the main window moving from the main screen to the secondary screen: after doing a fresh install of Mojave (I was on a testing partition earlier), the main window always reopen on the main screen, never on the secondary one.
  3. Another cosmetic issue similar to the dark blue color for the links (see Martva post above): when text in the search field is highlighted, it is in a blue color that is way too similar to the background color. Look at the screen capture below, it is almost impossible to distinguish the two colors.
  4. Another bug I just discovered (macOS 10.14, Mojave). The main Enpass6 beta window was open. I had Firefox open and it was in the foreground. When I hit command-H to hide Firefox, the Enpass6 main window was hidden as well, although it was not the foremost application. It happened again with other software. It does not happen all the time, but every time I hit command-H to hide a software window, the Enpass6 window flashes even it is not hidden by the process (I can briefly see the desktop for a fraction of a second behind the window). If I am using any software and I do a command-click on the Desktop to hide that application the Enpass6 window is also hidden at that point.
  5. Agreed, and under Mojave, once you uncheck Preferences/Security/Autolock When Main Window is Closed, reentering the main password or PIN is not necessary after a command-H. The problem is that it is not required when the main window is closed (command-W) so it may be a security issue if you work in a public space. But when alone at home it could be a trick you can use until they fix the issue.
  6. There is a safety issue that should be resolved: after doing a search for a software license I found 2 sets of data (2 versions of the same software). After using the license to activate the newest version of the software I started using it or a while. When done I went back to Enpass6 beta and thinking that the search text was still selected I hit Delete. In fact the 2nd set of data was selected and it was directly sent to the trash. I was able to move it back to where it belongs, but I think we should have a confirmation menu prior to data being sent to the trash.
  7. A little annoyance: I am using 2 screens with my setup. Until this latest beta (220), after launching Enpass6 (or 5) for the 1st time I was dragging the main window to the secondary screen. That's where it stayed and reopened after any computer restart. That's no the case anymore. The first time v220 was launched I dragged its main window from the main screen where it opened first to the secondary screen. After a restart the Enpass window moved back to the main screen, and it happens after almost all restarts (not all, though). It is happening under Sierra and under Mojave.
  8. Thanks for your reply. But that should be implemented with the beta version so we can test it under different environments. Adding it at the end of the beta process is only calling for problems later. Also, could we have only 1 thread for the beta testing program? I asked the same question in the main thread (https://discussion.enpass.io/index.php?/topic/4576-a-new-beta-update-of-enpass-6-is-now-available-for-linux-macos-and-windows/& dedicated to the latest version (220), but I find the answer here. Could you regroup those different threads dedicated to the beta version? TIA.
  9. Under Mojave, the Logitech issue is identical to what was happening under Sierra.
  10. If you are talking about 6.0.0 220, then yes you are right, the power consumption when in the background is down to between 0.0% and 0.1%. Thanks to the team for that!
  11. The issue I reported on September 7 about an incompatibility with the Logitech mouse has not been fixed (the Logitech Control Center has been updated to v3.9.7 in the meantime) As a reminder, it was working fine under enpass5, so it seems that it should be easy to make it work under Enpass6. Below is the post from the previous beta: Where is the WIFI sync we were supposed to get with the next beta version? It was greyed out in the previous beta, but I cannot find it anymore. As reported above, the application wide Favicons feature is not working. I had to add them one by one for each site. Also, we still cannot load favicons directly from an application. I will not even try to design my own icons again considering the problems encountered before, and the fact that we still cannot erase custom icons we add to the application. After a sync through Dropbox (that was setup with under the previous beta), it became clear that some Favicon were not ported to the iPhone version of Enpass6, while some others were. Strange. It seems we are still facing lots of instability with this version...
  12. Thanks for the info Anshu kumar! Good news about the next beta. Looking forward to experiment with it. Yeah, too bad about the Safari extension. We'll wait.
  13. Hi Anshu kumar, this beta has been out for more than 3 months now, and we provided your company with quite a few bugs and suggestions. Do you think you would have a new beta coming soon so we can see if things have been properly fixed/ implemented and maybe find new bugs/issues/suggestions? With Mojave out we need to move forward so we can use Enpass with that latest OS without too many hiccups. Also, it is a pain that the Enpass 6 extension doesn't work with Safari anymore, so the sooner it is fixed the better. Thank you very much in advance!
  14. Not a problem, thanks for your reply!
  15. Just upgraded to Safari 12 through the App Store. Upon launch I got a message stating that "Safari no longer supports unsafe extensions", and that "“Enpass 6 beta” is no longer supported. You can find newer extensions reviewed by Apple in the App Store or Safari Extensions Gallery". The Enpass 5 extension is deemed safe by Safari 12 and it has not been removed. Guess we'll have to wait for Enpass to submit the v6 extension back to Apple, or to provide an update.
  16. This is an issue with the printing process. I tried to print an item from the main application window: the item is selected in the list, then Print is selected under the File menu. A new sliding window opens from the right side of the application window with the title "Print". There is a box with 3 choices: "Selected items", "All items in the selected list" and "All items in the vault". "Selected items" is chosen. There is a print button, and when pressed you have to enter your master password. After entering the password, "Continue" is selected. After a couple of seconds the multi color beach ball appears and keeps turning for about 1 minute. Then the beach ball stops but nothing goes to the printer and Enpass6 goes back to the previous screen (the one asking what you want to print). Trying to force-quit Enpass6 (command-option-Esc) while the beach ball is turning shows that Enpass6 is not responding (expected). The same thing happens when "All items in the selected list" or "All items in the vault" is chosen. When a wrong master password is entered Enpass6 lets you know, so the problem is not due to a faulty password. To make sure there was no problems with the printing process itself on my Mac, a page was printed from a PDF document with Adobe Acrobat and everything went well. At not point during the process did I see a choice to choose a specific printer (more than one are linked to the computer). By the way, "Print" under the File menu is not associated with the usual command-P. That's it for now!
  17. Yeas I know command-H, but I also like the option-click. I know I can close the window but I would prefer the old behavior so I can keep the app running in the background. That said I am not sure it is possible for the software developers to achieve that behavior. Settings > General > Hide dock icon when main window is closed: that's the my setting ar the moment.
  18. The following is related to the web browser extension usage. On my machine Enpass6beta is set to launch at startup. After entering the master password I hide the main window by option-clicking on the desktop. What seems to be a little odd is that every time I use the extension in Firefox to fill in a logging, the main window comes back to the front. Same thing with Safari. If it is intentional I am not sure it should be kept because every time the main window has to be hidden back to the background.
  19. Thanks 100 Watt Walrus, that confirms it. Let's hope they give us the possibility to just copy/paste the icon image within the application in a later release. Yeah, I could have used Preview, but I trust Photoshop more, old habit...
  20. There's also an issue with the custom icons quality. I know that there's still some foggy area concerning those custom icons, but even after following the Anshu kumar recommendations I still see problems. This is how I created a few: go into the application Contents folder and find the the icon file (usually an icns file). Open it in Preview then save it as a png (icns cannot be opened in Photoshop). That png was then opened in Photoshop to be sized at 200px x 200px, at 72 dpi as recommended by Anshu kumar. 72 dpi is the resolution used by Enpass6beta for icons found in Users/username/Library/Containers/in.sinew.Enpass6-Desktop-Beta/Data/Library/Application Support/Enpass6/icons/item. I assumed that those files are used to create the icons within the application, but I may be wrong. The icons were then saved as png files, with larger file size selected. They were not flattened before to saving because the original png files from Enpass have an active Photoshop layer. The problem is that when used as custom icons they loose their sharpness and looks like they have jagged edges. You can see this in the images below. The second one was enlarged 200% with PhotoZoom Pro 7. As can be seen in those screen captures the original icons from Enpass6 beta are looking nice, but the custom ones are not good. What did I do wrong? How are other users creating their files for custom icons? Thank you very much in advance!
  21. As previously mentioned by 100 Watt Walrus, the categories list is not really well organized and flexible. It's really great that we can create new categories as we wish, but they should not automatically go to the bottom of the list. In fact would it be possible to allow users to reorganize that list by just dragging the categories up and down, as we can do within templates?
  22. I think there's an incompatibility between Enpass 6 beta and the Logitech Control Center. System: Mac Pro 2013, macOS X 10.2.6 (Sierra), Logitech mouse Performance MX, Logitech Control Center v3.9.6 Used with Enpass 5, the mouse works perfectly, but with Enpass 6 beta, the wheel does not work as expected. When I browse the main list with the scroll wheel, at first the list is going down (or up if going in reverse) as expected, but when the scroll wheel is used again to go further down or up the list, the list is in fact sent back upward (or downward) to where it was before the first move, then goes down (or up) again. So even after a few strokes the list is still in the same position. It seems that Enpass 6 beta is always going back to the entry that is highlighted in the list before scrolling up or down. Using the cursor in the scroll bar by clicking and dragging it works fine. I have an other maintenance partition with minimum system and applications installed, without the Logitech Preference Pane. When Enpass 6 beta is installed on that minimum system the mouse works properly. It seems the incompatibility is between the Logitech System Preference Pane and Enpass 6 beta. EDIT: the same issue is found when browsing the icon panel.
×
×
  • Create New...