Jokerman

Firefox Extension doesn´t work after update to 5.4

14 posts in this topic

Hello,

this morning i updated my enpass desktop app. Win10Pro, Firefox 50.1. No the autofill extension refuse to work.

I get this error message:

Enpass Connection Error

Please start Enpass desktop app and make sure you have checked "Enable Browser Extension" in Enpass Preferences, before using Enpass Browser Extension.

I read older threads about this issue, but nothing helped.
i tried to reinstall extension and enpass
its open in the background
browser extensions are enabled
minimaze to tray is enabled
i started enpass first and the firefox after restart

kind regards

jokerman
 

Share this post


Link to post
Share on other sites

Same error even after update 5.4.1. Happens in firefox and chrome on windows 10 desktop

 

 

enpass.PNG

Share this post


Link to post
Share on other sites

Same issue here on 5.4.1, Win10 and Firefox 50.1.0. I've also tried all the steps above and can't get the extension to work.

Share this post


Link to post
Share on other sites

Same issue here, since 5.4.* (am on 5.4.1 right now).

Using Chrome  Version 55.0.2883.87 m

Share this post


Link to post
Share on other sites

Hi guys,

Sorry to hear about your trouble. I would like to let you know that Enpass browser extension communicates to Enpass app over the localhost address.  So please check and verify that the installed Antivirus/ Firewall is interfering the localhost connections (127.0.0.1). Also, share these details

  • Have you installed any Antivirus/ Firewall/third party any security related browser extension?
  • Are you using any proxy? 
  • Are you facing the same problem in other browsers too?

Further, Open Enpass and make sure that the Enpass browser extension is enabled, now run the following command in command prompt one by one:

  • netstat -ano | findstr 10391
  • netstat -ano | findstr 10392
  • netstat -ano | findstr 10393
  • netstat -ano | findstr 10394
  • netstat -ano | findstr 10395

 
Which ever command gives the output, then run this command:

  • echo off & (for /f "tokens=5" %a in ('netstat -aon ^| findstr 10391') do tasklist /NH /FI "PID eq %a") & echo on

Note The value of  findstr 10391 can be changed according to the output. For ex: suppose the output comes after running this command "netstat -ano | findstr 10392" then you have to run this command: 

  • echo off & (for /f "tokens=5" %a in ('netstat -aon ^| findstr 10392') do tasklist /NH /FI "PID eq %a") & echo on

And share the logs via email at support@enpass.io mentioning a link to this discussion and we will take it further.

Thanks for your co-operation.

Share this post


Link to post
Share on other sites

Thanks Anshu!

I am on a active directory controlled corporate machine that is using Sophos antivirus, so I can't change settings or do anything there. I'll try safe mode later to bypass it and see if it's blocking the loopback.

I am not using a proxy and I do see the same issue in the latest Chrome version as well. Don't use Edge so I can't speak to that status.

I have run the commands you mentioned above and will send them via email as you requested.

-David

Share this post


Link to post
Share on other sites

So it looks like it may be Sophos causing this issue for me. In safe mode the extension works just fine and the Sophos web client is not running.

Share this post


Link to post
Share on other sites

Posted (edited)

Hey guys,

thanks for the hint on Sophos. That was it for me.

Here is the Solution (more of a Workaround):

If you are using "Sophos Endpoint Security and Control" like me you have to disable "Web-Protection".
Unfortunately it isn't possible to create exceptions in this module - very sad.
But.. now I can auto-fill again - that's more important as I'm taking "web security" in my own hands anyway.

Let me know if this helped you.

Edited by Kölle
possible misunderstanding of grammar
1 person likes this

Share this post


Link to post
Share on other sites

Cool, glad to hear you got it working.

I on the other hand have to get with my IT group and see if they can add an exception in Sophos for me, since I'm locked out of all settings :(

Share this post


Link to post
Share on other sites

Posted (edited)

I have also found an issue with Sophos virus protection (on a work computer). My solution was to change the properties of all web-related Sophos services to "Disabled" and to restart my PC.
The extensions (in both Chrome and FireFox which were not working before, are now functional).  
Since I do not fully understand what security features those services provide, it may not be advisable, but that at least gives one potential work around. 
(Note that I, too, did not have the ability to change the Sophos settings through the app). 
Edited by Lawrence

Share this post


Link to post
Share on other sites

Hi guys,

Sorry to hear about the trouble.  As you know Enpass extension communicates to Enpass over localhost address and it seems that Sophos antivirus is interfering the localhost(127.0.0.1) connections. One link I found on web to allow localhost connection in Sophos antivirus is https://support.asperasoft.com/hc/en-us/articles/216126878-Connect-browser-plugin-does-not-work-with-Sophos-antivirus-web-control

Hope this helps!

Share this post


Link to post
Share on other sites

Thank you Anshu,

that helped! Now I have active Web-Protection with working Enpass Browser Plugin :)

For the others: I took Solution 1 in the link above and it works like a charm.

1 person likes this

Share this post


Link to post
Share on other sites

I have sophos home and after adding enpass to the  Potentially Unwanted Application Exceptions in Sophos home autofill was back in business.

 

Seems the above fix was not permanent, next day it did not work anymore. I have added 127.0.0.1 in the exception list and for now it works again.

 

Edited by Michel68

Share this post


Link to post
Share on other sites

I have the same issue - running Ubuntu 16.10 / FF 50.1.0 / Enpass 5.4.1.  The browser integration stopped working in the last few days, I think with the Enpass upgrade.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now