Jump to content
Enpass Discussion Forum

Internal Error 995 - no restore from backup


Recommended Posts

after windows update enpass delete all data from vault and i can't restore from backup anymore (internal error 995). when i try to setup a new vault i get error "setup default location" somthing like that. but i can't change it. i used the traditional 32bit version and all worked fine. its just the Microsoft Store Version is bugged.

Anmerkung 2020-05-22 132946.png

Anmerkung 2020-05-22 133008.png

Link to comment
Share on other sites

Hey @Enpassly and @Unstiglitz

Thanks for reporting this issue.

Our QA is looking into this issue. Meanwhile if you are using Enpass on any other devices and syncing with any cloud services then enable sync or restore with the same cloud account. Also, please let me know on which device along with OS version you are using Enpass? 

Thanks for your co-operation.

Link to comment
Share on other sites

Hallo. Ich habe auch beiden Laptop das Problem. Die Mobilen Geräte synr problemlos mit dem GoogleDrive. Nur die Desktopvariante hat Probleme. Wenn ich die Backup-Datei (runtergeladen von GoogleDrive), bekomme ich die Fehlermeldung: "Etwas ist schief gelaufen, Fehler -1". Die Autorisierung über GoogleDrive endet auch in einer Endlosschleife.


Link to comment
Share on other sites

The first post in this thread may have the same problem as I have.
I don't have a solution, only a theory as to why, that I described here:

So, uninstall the Windows Store App and install the Traditional Win32 application instead, while Enpass sort out their App.

@JürgenO above seems to also have a non-english character user account name, right?

@Unstiglitz, here is a wild guess at helping you: it requires some computer experience.  Try it at your own risk...
First, do not uninstall the Windows Store App.
If the App auto-updated the vault may still be there, just that the buggy new version can't find it.  Go to 
where XXXXXX is your user account name, and also the last bit may differ, it seems kind of random.
If you find that folder, there should be a subfolder LocalState, and in that one, a folder Vaults, then lastly "primary".
There, you should hopefully find at least two files:
and I also had a "fc19cda3-6d60-4443-b283-d036928dfc44.enpassattach"
Copy these to another folder temporarily.

Now, install the Traditional Win32 application.
Start it and say you are a new user, and set up a new vault.  Never mind the password or any contents...
Close the application and also quit the system tray Enpass icon: right click, menu to the left, quit.

Go to C:\Users\XXXXXX\Documents\Enpass\Vaults\primary
where again XXXXXX is your user account name.  This is where the Win32 application stores its data.
At this point there is likely only two vault files there.
Now copy your "rescued" files from above, to this location, replacing the files already there.

Now, restart Enpass from the start menu.  Your old vault should be there, accessible with your old password.

And lastly: do set up a cloud synchronization!

Good luck!

/Håkan, Sweden

Edited by IrmaIsfot
Realized how to make @-remarks! ;-)
  • Thanks 1
Link to comment
Share on other sites

Hello Irmalsfot

thank you for the Information.

Yes, I  have a non-english character user account name.

On my second PC with W10 1909 the Enpass App. But the last Update is not installed an its work fine. So it seems, the last Update is corrupt!


On my Laptop I installed the Traditional Win32 application and I can synchronize.


Thank you 





Link to comment
Share on other sites

Hi All.

Sorry for the trouble you are going through.

Our QA is looking into this issue. Meanwhile, can you please share the screenshot of the OS version you are using. To see which version of Windows 10 is installed on your PC:

  • Select the Start button and then select Settings.
  • In Settings, select System > About.

Thanks for your co-operation.

Link to comment
Share on other sites

As I see it, this issue has nothing to do with the Windows 10 version.

It is a bug that has been introduced in the Windows Store Enpass App somewhere between 6.4.1 (642) that worked, and 6.4.2 (662) that does not work.

I'm on 1909, but to prove my point, I have fired up different Windows versions in VMware.

1511 x64 finds the Enpass App in the Windows Store, but it is not compatible, see screenshot below.

1703 x64 English
1809 x64 English
1909 x64 Swedish
1909 x64 English International

All four of these versions behave consistently: if a Windows User Account has a non-english character in it, in my case "å" from Håkan,
the Windows Store Enpass App will not work. 
Unless run as an Administrator, where it creates a "faulty" folder in parallel of the actual User Account:
And this only brings local vault functionality anyways; it fails to sync with Google Drive.

As this bug is very easy to reproduce, your developers shouldn't have a hard time finding it.

Good luck!




  • Like 1
Link to comment
Share on other sites



I have a same problem. I tried resync from my google drive but the program always crashed without message. And when I restart it I am in a same never ending loop. After that I tried use backup file but a got a "-995" error massage. I am very angry for that.  

Link to comment
Share on other sites

@ Irmalsfot

Thank you very much for your contribution from Saturday. Support, which I contacted with the same problem did not give me the solution so far, but you have! :)

I will be using the desktop version from now on. Also, my user on Windows 10 also has an accent aigu...

Edited by 123ABCXO
  • Like 1
Link to comment
Share on other sites

same problem for me. I have special character in my Windows username ( á ) so restore from backup failes with error -995. Restore from webdav or other netowrk source crashes Enpass without any notice.

I installed the traditional 32bit version and it works well.

Link to comment
Share on other sites

Hi All,

Sorry for the trouble you are going through.

We really understand your concern. Our team is trying to best to find the issue asap, your co-operation will be highly appreciated. Meanwhile, we will recommend you to try the website version of Enpass using this link (website version is given at the bottom of the page) and share your findings with us.

Note: Make sure to save the backup file and install the latest version of Enpass for Windows from the website. After installation, restore the backup file and check. Once the backup file restore is successful, please uninstall the store version. 


Link to comment
Share on other sites

I have the same problem. Yesterday it worked well. Today all my data were gone. When restoring back up I got message 'internal error 995'. I installed the app again, but still the same. Trying to register as a new user gives the message: Vault locatoin cannot be found change to default location. When I push the 'default location button' I get back to the restore screen. Any clues?

My device is a laptop. Windows 10 pro x64.

I have no 'non-english' characters in my username.

On the apple laptop of my wife it still works fine.

Edited by LejoS
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...