Jump to content
Enpass Discussion Forum

Search Performance


Recommended Posts

I am evaluating Enpass, to move away from LastPass since I like the Windows phone integration in Enpass.

I have approx 400 items in my password list, when I type in the search box Enpass locks for approx four seconds per character I type. This is too slow. Are there known issues with search speeds? Why does it lock the whole interface anyway? I can't click elsewhere within Enpass or even move the window.

I am running Windows 10 on an i7 with 16Gb of memory. I am syncing using OneDrive so don't expect that to be slowing it down.

Any thoughts appreciated.

Thanks,

John

 

Link to post
Share on other sites

Hi @JohnR,

Sorry for such long delays you are facing in searching items. Is the delay of 4 second is there on Windows 10 Phone or Desktop? For desktops running UWP App, it shouldn't be so much.

By default, Enpass performs deep search i.e. in all fields of a item, so it takes time to decrypt and search in each field of each item and the Microsoft UWP App takes long time in performing cryptography operations compared to any other platform. More items means more search time. Mobile phones have less processing power than desktops, so UWP App on Windows Phone tends to be more impacted.

I should clarify here that Enpass searches very smoothly on all other platforms without any noticeable delay. Its our bad here in UWP App, that we don't show progress wheel while searching, but a fix to that is underway.

The solution for faster search is to search in title of item only. You can turn on this option in "Settings->Customize->Search in->Title only". 

  • Like 1
Link to post
Share on other sites

Hello @JohnR,

The desktop version should search in a jiffy. Four seconds is too much. We have fixed a issue causing high memory usage that also impact the search performance. The fix is available in beta version. So, we request you to try installing latest beta from here 

and let us know, if your issue resolved or not. 

Link to post
Share on other sites

Thanks, that is much better, although there is still a noticeable (fractional delay). I would have expected it to search in the background without any delay in typing? Anyway, its much better and now usable thanks.

Thanks also for the Vivaldi support, one more box ticked.

Looks like I have to have Enpass running before I start Vivaldi though otherwise it won't connect.

John

 

Link to post
Share on other sites
10 hours ago, Anshu kumar said:

The solution for faster search is to search in title of item only. You can turn on this option in "Settings->Customize->Search in->Title only". 

Nice workaround! Helped me on my Lumia 950 (Windows 10 Phone). Thanks!

Hope you will nevertheless improve search performance on UWP App and bring back "pin to start" function pls :)))

Thank you!

Edited by Monk32
Link to post
Share on other sites
  • 5 months later...
Guest
This topic is now closed to further replies.
×
×
  • Create New...