Jump to content
Enpass Discussion Forum

Sync on Windows 10 (WebDAV) not working


cpoh
 Share

Recommended Posts

Hi everyone,

perhaps someone has an idea:

- i'm using enpass on desktop (mac, win) and my iDevices.
- everything is updated and latest versions
- i just noticed, that the sync is runnung nor more (error) - was running for years
- if i delete the enpass data on my Synology NAS, i can newly sync the data from all apple devices
- if i then try to sync the windows enpass i get an error 915993 or 907987 or after new install 908403
- if i delete the enpass data and try to newly sync the data from windows, i can see the creation of a tmp file in the webdav folder, but get an error 915993 and the tmp-file is deleted.

What can i do to sync enpass under windows again? nothing really changed there that could cause this (i think).

Thank you very much.

PS: i do have added PWs to the windows Enpass, so i would prefer this database to sync, as all aother devices have an older DB (dated to the last successful sync 2 weeks ago).

 

Edited by cpoh
Link to comment
Share on other sites

Hey @cpoh

Welcome to the forum!

Did you recently updated the DSM? There is a known issue where the WebDAV sync is broken for Synology devices with latest update and the same is being discussed here-

Quote

 

We have notified the Synology team regarding this issue. If this is your case, we recommend you to wait for the update from the Synology. Otherwise, please share a demo account (via PM) on your WebDAV server and we'll look into it.

Thanks!

Link to comment
Share on other sites

Posted (edited)

Thanks for the welcome :-)

No, i did not update the DSM, i'm still at the latest 6.xx.
On my iDevices it seems to work, after deleting the data on the NAS and re-sync them from an iPhone / iPad. Both iPad and iPhone are syncing, so i suspect the WebDAV is working.
My Mac and my Win-Machine are throwing the above error codes.

Edited by cpoh
Link to comment
Share on other sites

I have a similar problem. I use a Nextcloud for syncing. This is also added on three Android devices without any problems. Only on my Windows PC the setup of Nextcloud or WEBDAV does not work. As an error I get the message "Could not connect to the specified Nextcloud server". I turned off the Windows firewall briefly and it did not change the problem. I also changed the default browser from Chrome to Edge and this also did nothing. I also tested reinstalling Enpass and the Win10 app. Both brought nothing.

System Informations:
Windows: Windows 10 Home Premium 20H2 Build 19042.1081
AntiVirus: Windows Defender
Firewall: Windows Firewall
Network: All devices are operated in the same network

Enpass Versions:
Windows PC: 6.6.2 (827)
Android Smartphones (Poco F2 Pro and Xiaomi Mi 10): 6.6.7.510
Android Tablet (Xiaomi MiPad 4): 6.6.7.510

Edited by dontobi
Link to comment
Share on other sites

Hi @dontobi,

Welcome to Enpass community,

Thanks for sharing the details. As far as I understood, you can sync Android devices successfully but unable to sync with your Windows PC. So in able to reproduce this issue on our end, is it possible for you to share the demo account (via PM) of your WebDAV server for further investigation.

Link to comment
Share on other sites

Posted (edited)

I just discovered some odd behaviour:

When i delete the enpass folder used for syncing (it will be recreated by Enpass) and either:

  • setup syncing from Windows Enpass -> Folder is beeing recreated -> syncing under Windows works -> Sync from Apple (Mac or iPhone/iPad) throws error
  • setup syncing from Apple Device (Mac or iPhone/iPad) -> Folder is being recreated -> syncing under MAC/iDevice works -> Sync from Windows throws error

So it actually seems (to me) that there is a problem with the Enpass-Sync over different OSes?

Edited by cpoh
Link to comment
Share on other sites

Hey @cpoh

Thanks for sharing your inputs. It will help us to pinpoint the issue if you can  share the logs using the below method with the website version of the Enpass app

  1. Disconnect the vaults from syncing.
  2. Enable logs by following the steps-  Open Enpass --> Settings --> Advanced --> Logs --> Enable it.
  3. Then setup sync again with WebDAV and wait for error.
  4. When you receive an error --> Go to Advanced settings --> Logs --> Copy the Logs in any text editor and share with us here over PM or via mail at support@enpass.io
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...