Jump to content
Enpass Discussion Forum

Enpass browser extension steals focus in webform when using iframes


Recommended Posts

I didn’t see any bugtracker on your site, so hereby a bugreport in the forum as well. When using enpass browser extension in Firefox or Chrome with sites which include iframes and forms the extension gives the following error in browsers console:

 

Error: Promised response from onMessage listener went out of scope 80 background.js:8:59712

The extension then steals focus to the first field of the form, after that it’s impossible to select text on the iframed-webpage, the extension returns the focus directly to the form again. I created a page where I can reproduce this behavior: https://www.db-works.nl/enpass-bugreport/ , please check this site with steps to reproduce.

Tested with:

  • Windows 10 Enterprise Version 20H2 (OS build  19042.1165)

  • Firefox 94.0.2 (64-bits) + Enpass extension for firefox version 6.7.0

  • Chrome Version 96.0.4664.45 (Official Build) (64-bit) + Enpass extension for chrome version 6.7.4

Hopefully you can fix this bug.

  • Like 3
Link to comment
Share on other sites

  • 3 weeks later...

I think I'm having the same issue after updating the extension in chrome. I have noticed it on several websites where the first field of a form is always in focus no matter which field I click on. I found I can tab to get to other fields or it is easier to disable the enpass extension. This is driving me nuts in Salesforce!

  • Like 1
Link to comment
Share on other sites

Hi @Deuntje, @drob, @stealth

You will be glad to know that our dedicated tech team has reproduced the bug on their end due to which this issue is occurring, and they are now working on a possible fix (to be implemented in the upcoming Enpass versions). In the meantime, please add the web pages on which this issue is occurring to the block list of your Enpass Extension Settings page. Here is how you can do it - 

  1. On your browser, go to its Settings → Extensions → Enpass Extension → Details.
  2. A new page will open. Please scroll down on that page and select “Extension Options“.
  3. On the Enpass Extension Settings page, scroll down to “ Inline Autofill Menu Blocklist“, copy the URL of the webpage where this issue is occurring and paste it in the “ Add URL “ field followed by an asterisk in the end.

#SI-2505

image.png

Appreciate your patience and co-operation in the meantime.

  • Like 3
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...