Jump to content
Enpass Discussion Forum

Logout, Tag and Password issues with 648 update


Brian185
 Share

Recommended Posts

Hello everyone, this is my first post.

The recent update to the Enpass front end (648) has certainly improved the appearance. Unfortunately however, this has come at the expense of some useful functionality, described below.

1) The logout symbol (padlock) has now disappeared. Somewhat surprising for a security app! Setting logout on exit (suggested by the Help Desk) is a nightmare when multitasking or autofilling from the browser, and force stopping it produces issues.

2) On entry, all records are now displayed alphabetically by default, requiring scrolling through a long list. Who uses a filing system like that? Display by tag is now consigned to a sub menu, split over more than one page, and entries are displayed in some unfathomable order. If we have to use this system, at least present them in alphabetical order.

3) The incredibly useful feature to long press a password to display a count against each character no longer works. Dark blue numbers on a black background is not a good combination! Acknowledged by Enpass, the fix failed to make the most recent update.

Sorry if all this all sounds negative. I really do like the app!

Link to comment
Share on other sites

Hi @Brian185

Welcome to the Enpass Forums.

I will gladly assist you with all your queries -

1) The logout symbol (padlock) has now disappeared. -

We have changed the UI of the Android application with the recent update. You can set Lock on Leaving or Lock After under Enpass app → Settings → Security → Auto-Locking.

image.png.83aa6b3ee163f2978da044df00611868.png

 

2) Tags are not sorted -

We were able to reproduce this issue and it has been fixed in our recent update. Please update your Android Enpass app to ver 6.8.2 and share your findings with us.

3) Long Pressing a password does not show character count/ Difficulty reading blue numbering on a black background -

Character count not showing after long pressing a password issue has also been fixed in our update. Kindly update your app and let us know if its still not showing for you. Regarding blue characters on black background, our development team is working on fixing it and a patch will address this issue in the future versions of Enpass.

#SI-2805 #SI-2820 #SI-2833

 
 
Link to comment
Share on other sites

Hi Abhishek,

Thanks for the reply. Glad that the latter two issues have been sorted. I look forward to receiving the latest update.

I cannot agree with you about "lock on leaving". Having this set means that if you reply to a WhatsApp message, say, whilst leaving the Enpass window open, you are logged out of Enpass. Even logging on to an online site (like this one) from Enpass results in being logged out when autofill is initiated. I find it unworkable, especially with a long complicated master password. Am I missing something?

Best regards

Brian

 

 

Link to comment
Share on other sites

Hi there,

I have Version 6.8.2 installed and, sadly,  it doesn't address any of the issues discussed above.

I have a Samsung Galaxy S7 phone running Android 8.0. Could that be the issue?

Link to comment
Share on other sites

6 hours ago, Brian185 said:

Hi Abhishek,

Thanks for the reply. Glad that the latter two issues have been sorted. I look forward to receiving the latest update.

I cannot agree with you about "lock on leaving". Having this set means that if you reply to a WhatsApp message, say, whilst leaving the Enpass window open, you are logged out of Enpass. Even logging on to an online site (like this one) from Enpass results in being logged out when autofill is initiated. I find it unworkable, especially with a long complicated master password. Am I missing something?

Best regards

Brian

 

 

I think you do, if you set "Lock on leave", you want to authenticate each time Enpass goes to foreground, that's the whole point. 

Majority of Android users use biometrics, which makes unlocking as fast as unlocking the screen. 

If you don't have or want to use biometrics, you can change you password making sure to use a keyfile and a shorter password 

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

Hi Abhishek,

Thanks for your interest and help.

As requested, I have backed up the Enpass data, wiped the data from the app, and uninstalled it. I have then re-installed the app from the Google Playstore and re-loaded the data. I have attached some screenshots showing:

1)App Version No. from Main Menu

2)Tag List

3)Password with character count.

As can be seen, the tag and password issues have not been resolved. The logout issue is a design decision. I don't agree with it ( I think that every security app should have a logout button) but I can live with it if I have to.

Hope this might shed some light

Best regards

Brian

 

 

Screenshot_20220525-133135_Enpass.jpg

Screenshot_20220525-133213_Enpass.jpg

Screenshot_20220525-133337_Enpass.jpg

Link to comment
Share on other sites

Hi @Brian185

Thanks for trying the steps I shared with you.

Regarding blue characters on black background, our development team is working on fixing it and a patch will address this issue in the future versions of Enpass. As for the tags not showing in a sorted manner, I have notified our testing team about it and will get back to you soon with an update. In the meantime, I would suggest restarting the device to check if it resolves the issue. Thanks for your co-operation while we look into this issue.

Link to comment
Share on other sites

Hi Abhishek,

Many thanks for your continued interest and help in these matters. I have also noted that the legibility problems experienced are also present in dark mode, not a mode that I work in.

I have restarted and reinstalled the app and switched the phone off and on many times, with no resolution to the tag issue. The initial display of tags is alphabetically sorted. It's pressing the "more" button that seems to cause the problems.

Best regards

Brian

 

Link to comment
Share on other sites

Hi @Brian185

Thank you for updating me on this matter that you are facing this issue even when choosing the dark mode.

Our dedicated team has reproduced the bug on our end due to which the tags are not showing in a sorted manner. Our development team is working on a patch which will address this issue. Enpass appreciates your continued support and patience while we work on fixing this bug.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...