Jump to content
Enpass Discussion Forum

6.8 'sluggish'


Recommended Posts

Since Enpass 6.8 and upwards (currently on 6.8.1), Enpass is way more sluggish than 6.7.

It feels like debug-mode is on or something.

This is observed in most actions, starting up Enpass, switching category, adding items, switching views/tabs.

I ran it in a VM at first thinking it was purely poor virtualization performance, but it's the same experience on a physical laptop with Windows 11.

Whats up with that?

Link to comment
Share on other sites

  • 1 month later...

is there anything I can contribute with, or..?

There is no change after update to build 1084 from Microsoft Store yesterday.

It feels like, from 6.8, the complete vault isn't loaded in RAM after decryption but every view is loaded ondemand since there is a 1-2 second delay when navigating around. Or some added memory cleaning has been added?

I have a pretty new and speedy HP DragonFly with a Intel i5-8265U..

Link to comment
Share on other sites

Hi @Ivarson,

I appreciate your response. We have recently released another version 6.8.2 for Windows. Please try that and let me know if that works fine. Otherwise, please help me with the following details:

  1. Share the number of items, vaults, and attachments in your Enpass. 
  2. Help me with the cloud sync accounts.
  3. Please confirm if you are using Windows 10 or 11. 
Link to comment
Share on other sites

  • 3 weeks later...

Used 6.8.2 build 1084 from Microsoft Store for a while and it's still slow.

Since you claim that Enpass shares the same core across OS:es, and the Linux nor Mac-versions aren't slugish, It has to be something in the GUI.. although there's no difference for me in modern versus classic theme.

I've got 4 vaults atm. with 408 items in total.

Windows 11 21h2.

Further more, I have credential guard, bitlocker and a EDR running.

Never the less, prior to 6.8 the performance was way better and Enpass Portable still runs smothly.

Now when I launch the Enpass Helper from systray or a browser plugin, it takes between 1-3 seconds to load the list, and also general navigation within Enpass mainwindow takes noticable time.

Unless you've intentionally put lots of extra checks in for Windows, it feels like your codelogic does something too many times in the app's Eventhandlers..

Link to comment
Share on other sites

On 7/4/2022 at 12:32 PM, Manish Chokwal said:

Hi @Ivarson,

I appreciate your response. We have recently released another version 6.8.2 for Windows. Please try that and let me know if that works fine. Otherwise, please help me with the following details:

  1. Share the number of items, vaults, and attachments in your Enpass. 
  2. Help me with the cloud sync accounts.
  3. Please confirm if you are using Windows 10 or 11. 

Any response from them devs for Windows?

Link to comment
Share on other sites

  • 4 weeks later...

Please tell me if you need more data from me regarding the slowness of the Windows apps.

I currently use Portable version 6.6.1 since that's still quick, but it lacks plugin Pop-up support in the browser plugins as well as Windows Hello-support.

I'm surprised there aren't more voices about it. The Linux-app is still quick and responsive so it's nothing in the Core-part of Enpass..

Link to comment
Share on other sites

It's now 1 week or more I am experiencing a very slow response in various situations and various OSs (android, MacOs). It's terribly slow like never before, sometimes unusable.

I am using release 6.8.2 (1082) on MacOS 12.5.1.

I am using release 6.8.2.666 on Android 12, Nothing Phone 1

 

please let me know in case a beta release would become available.

 

regards

Edoardo

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...