Jump to content
Enpass Discussion Forum

Enpass is very slow, freezes, and crashes


Recommended Posts

Hi team

I am using the latest version of Enpass on Mac and iOS devices, installed via the App Store. Enpass gets very slow, freezes, often crashes to an extend that the app is not usable anymore. I have 800+ password entries in 1 vault. My sync service is a local WebDav service.

Any help is very much appreciated.

Link to comment
Share on other sites

Hi @Bob2

Welcome to the Enpass Forums.

Please share the below details with me, and I'll have this further investigated for you -

  1. The  version of the Enpass app and OS you are using on your iPhone and Mac.

  2. The  number of Items and vaults you have saved in your Enpass app on both devices.

  3. Is there any particular step after which the lag occurs (updating an Item, adding a new Item etc) on your devices?

  4. Is the Enpass app showing you a crash report after the crash? If yes, kindly share it with me.

Link to comment
Share on other sites

Hi @Bob2

We are investigating the issue which you reported. Our dedicated team is looking into it but requires some additional information in this case. Could you please check and share the size of the vault.enpassdb file? The complete path is library/Container/Enpass/Data/Documents/Primary/vault.enpassdb. Your cooperation in this case is appreciated.

Link to comment
Share on other sites

Hi @Bob2

To replicate the exact scenario due to which you are facing this issue, could you please share the attachment size you are using in total? Under the file location: library/Container/Enpass/Data/Documents/Vaults/Primary/vault.enpassdb, please share -

  1. 'enpassdb' file size
  2. Total file size of all the .enpassattach file

(Please refer to the below screenshot)


Link to comment
Share on other sites

I also started having this issue. First on my android, where i noticed it was not as bad if i diabled my wifi, thinking it had something to do with sync. yesterday my laptop (debian linux) started going really slow as well. i saw this thread about the db size and I looked:

on Sept 5, my db went from 13M to 245M

-rw-r--r-- 1 dab dab  13M Aug 25 08:52 2022-08-25-1661431923-1_vault-1460_items-auto.enpassbackup
-rw-r--r-- 1 dab dab  13M Aug 26 16:04 2022-08-26-1661544254-1_vault-1460_items-auto.enpassbackup
-rw-r--r-- 1 dab dab  13M Aug 28 16:29 2022-08-28-1661718568-1_vault-1455_items-auto.enpassbackup
-rw-r--r-- 1 dab dab  13M Aug 30 09:41 2022-08-30-1661866906-1_vault-1455_items-auto.enpassbackup
-rw-r--r-- 1 dab dab  13M Aug 31 19:38 2022-08-31-1661989102-1_vault-1455_items-auto.enpassbackup
-rw-r--r-- 1 dab dab  13M Sep  2 09:48 2022-09-02-1662126497-1_vault-1455_items-auto.enpassbackup
-rw-r--r-- 1 dab dab 245M Sep  5 23:04 2022-09-05-1662433424-1_vault-1454_items-auto.enpassbackup
-rw-r--r-- 1 dab dab 245M Sep  6 10:10 2022-09-06-1662473384-1_vault-1451_items-auto.enpassbackup


I tried to create a backup, as it was the only option i could find, but it created the same size. i tried looking for large objects, but the app has become too slow to navigate at all. is there any way i can export everything and reimport? this is really going to block me from getting any work done at all until it's fixed.

Edited by dab
Link to comment
Share on other sites

Add another user to the list that is having this problem, roughly for a month now, under Android and Linux. Enpass is now unusable. I resorted to exporting the database as text and entering passwords manually

Local vault files:

└─ [07.09.22 10:39:13] $ ls -alh
total 556M
drwxrwxr-x 2 4.0K Sep  7 10:36 .
drwxrwxr-x 3 4.0K Sep 10  2021 ..
-rw-rw-r-- 1  87K Sep 10  2021 19aec948-de48-410f-a866-dc46644415ea.enpassattach
-rw-rw-r-- 1 556M Sep  7 10:36 vault.enpassdb
-rw-rw-r-- 1  496 Sep  7 10:36 vault.json

I also notice that my Backups have exploded in size:

  • On 10th of August backups went from 7MiB to 51 MiB
  • On 5th of September backups went from 51MiB to 513MiB

I will check my other machines later to see if I notice the same exploding size backups

I normally sync via a private WebDav file store, and tried switching to file sync instead, but nothing seems to help. I have 648 entries in a single vault.

  • When unlocking the vault, Enpass will freeze for about a minute, pegging one core at 100%
  • When searching for an entry in the vault, Enpass will take anywhere between 5s and 30s to filter the list
  • Clicking on the Enpass icon in the browser takes about a minute to show the pop down asking for a password, if the vault is still locked

EDIT: Version used under Linux -> 6.8.1 (1063)

Edited by fjimenez
Fixed typo
Link to comment
Share on other sites

I debugged this issue further and can share the following:

vault.enpassdb was initially 850 MB. I exported Enpass data to json and realized that 1 entry had a huge list of password history entries. I manually removed them. The json file size got reduced to 6MB. After I have imported the data from the modified json file, vault.enpassdb is now 400MB.

I have 70 enpassattach files with a total size of 8MB.

I turned off "Use Website icons" and "Check compromised passwords". Having those options turned off, Enpass is more responsive, but still not optimal.

I also get the impression that while Enpass is syncing with WebDav, the main Enpass window is not responsive.

Edited by Bob2
  • Like 1
Link to comment
Share on other sites

It seems to have worked, Enpass is working again and responsive. I did the following:

  1. Exported all passwords as json file. This was around 600MiB
  2. Removed all historical passwords. This reduced the file size to around 2MiB
  3. I disabled the sync for my vault, and then deleted the vault
  4. I created a new vault and imported the modified json file
  5. The Vault file is now 1.8MiB in size
  6. I enabled syncing via webdav to a new location so the old synced vault wouldn't interfere
  7. I then removed the vault from my Android phone, and synched from the new webdav location

All is working fine after this process. I have yet to migrate my other machines.

I hope the bug is found and squashed, I don't fancy doing this on a regular basis

Link to comment
Share on other sites

Hi @all

Thank you for your patience while we investigated this concern.

We were able to reproduce this issue on our end, and our dedicated team is working on a fix which will be implemented in the upcoming build. In the meantime, for Windows and Mac users, we have launched Enpass beta v6.8.3. You can try the beta version from hereand any feedback related to this issue would be appreciated.

Link to comment
Share on other sites

The closest I have is a mac that's on OS 11.6, and testflight requires os 12 to install. My main systems are linux and android. I see an android beta but it doesn't look like it has the update in it. Can you give us a release date on these others platforms? As much as i've liked using enpass, this is critical to my business, and if i could find the export i'd be using bitwarden full time already.

Link to comment
Share on other sites

Hi @joeldatabox, @dab

I can certainly understand your disappointment in this matter.

Unfortunately, I will not be able to share any exact ETA for when the new build/beta will be launched for other platforms. Rest assured that our development team is working hard to roll out the updates on all platforms as soon as possible. Any inconvenience caused is deeply regretted, and we appreciate your patience and support in the meantime.

Link to comment
Share on other sites

  • 2 months later...

Same at my side...: Hello! I am new to enpass. I like the desktop app (downloaded from enpass website, not MS Store) and iOS app, however I have a problem: I am transferring 850 records from splash ID. Import (csv) worked fine, now I need to name all user fields. This works (manually) fine. However, the desktop app (Windows 11, brand new system, app v6.8.4 (1167) gets very slow after editing about 20 - 30 records and freezes at some point ("no feedback"). Closing the app and reopening it does not help, sometimes even the re-login freezes. It then sometimes takes several minutes until the app starts again. But editing the entries remains unbearably slow. I can't use the app like this, unfortunately. I have the impression that it has to do with sync pausing, password checking and/or showing old passwords - but can't solve the problem on my side.... Any ideas?

Link to comment
Share on other sites

Hi @MacGordon

Welcome to the Enpass Forums.

For troubleshooting purposes, create a manual backup of your Enpass data and then reinstall the app. If the issue persists, please share the below details with me and I'll have this further investigated for you -

  1. The cloud service you are using to synchronize your data.
  2. The number of Vaults and attachments you have in your Enpass app.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...