Jump to content
Enpass Discussion Forum

Enpass doesn't work Ubuntu 22.04.1 LTS


Dorora
 Share

Recommended Posts

I used enpass for years now, on win10, debian, ubuntu, Fedora, Pro app on android ect, and that my first real fail with it

 

I just make a fresh install on laptop and install enpass after add repo, as usual, but, if i try to lauch from gui, nothing happen, from terminal :

 

parcell@parcell:~$ enpass
La commande « enpass » n'a pas été trouvée, mais peut être installée avec :
sudo snap install enpass
parcell@parcell:~$ sudo enpass
sudo: enpass : commande introuvable
parcell@parcell:~$ 

I really don't know what to do right now because nothing happen :/
That's work fine on another laptop, same model, same ubuntu version.

 

(already try to remove and reinstall, reboot, try the snap package but this is an old version)

Open to any suggestion :)

Link to comment
Share on other sites

After the latest update last week enpass stopped working for me as well. Looking in /var/log/syslog (using command "sudo tail -f /var/log/syslog") while trying to start enpass I noticed the following error message:

/opt/enpass/Enpass: error while loading shared libraries: libxcb-xinput.so.0: cannot open shared object file: No such file or directory

Installing the required library using "sudo apt install libxcb-xinput-dev" solved the problem for me. However, I think this should be considered a bug since it required me to install a development library.

  • Like 2
Link to comment
Share on other sites

I can confirm this behavior. I just installed the available updates on PopOS 22.04 (Based on Ubuntu), and Enpass wouldn't start anymore, with the error message mentioned above. As noted above 

5 hours ago, Kilathaar said:

using "sudo apt install libxcb-xinput-dev"

will fix the issue.

Note that, if not started from the terminal, the error will never be shown, but Enpass will just refuse to start without any error, so @Manish Chokwal perhaps it may be good for other users to withhold the update for Ubuntu 22.04, or add the above mentioned package as a dependency...

(Note: Probably `sudo apt install libxcb-xinput0` should also work. This is included in the above package, but just contains the file that's needed, instead of development dependencies)

Edited by TomBrouwer
Added note on more lightweight installation package
Link to comment
Share on other sites

Hi, I am also getting this issue. It's on a brand new computer with a fresh install of Ubuntu 22.04.1 LTS. After following the installation instructions on the enpass website (installs successfully without warnings or errors) and attempting to launch the application from the Enpass icon, nothing happens. I tailed the logs like another person mentioned above and there was literally zero output, it's like the icon application icon is doing nothing.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...