Jump to content
Enpass Discussion Forum

One-tap autofill populates username box in web site with email address in my vault


Recommended Posts

I faced an problem and hope you fix it.

I have an item in my Enpass vault which has both a username and an email address.



When I try to populate a username box in a web site which corresponds to the above item with my username by tapping my credential which Enpass shows on the keyboard (the one-tap login function), instead it enters my email address registered in the same item.
Instead, tap the key icon which appeared to the right of my credential above the keyboard, choose the item from the pop-up list, also result in the same.



However, instead of choosing an item from the list, tap Enpass…, choose the item from the Enpass overlay, then Enpass populates my username as expected.


Other information

As far as I remember, this unexpected behavior had started since ver. 6.9.0.
I believe in previous versions, the one-tap auto fill entered my username as expected as well as choosing the item from the Enpass overlay.


Could you see and solve the problem?



  • iOS/iPadOS ver. 16.6
  • Enpass ver. 6.9.1
Link to comment
Share on other sites

Hi @banana

For the Item in which you are facing this issue, please ensure that the Field type of your email address is ‘Email' and similarly the Field type of your username is 'Username’. You can also refer to this link.

If the Field type’s are set correctly, please take a note of your credentials of this website, then remove the item that you have saved in your Enpass app for this web page. Once done, enter the credentials on the webpage, save the Item again and try auto-filling.

If case the above steps do not help, kindly share the below details and I'll gladly get this checked for you -

  1. The version of the browser you are using.
  2. The apps/URL of the webpages on which you are facing this issue.
Link to comment
Share on other sites

  • 3 weeks later...

Hi @Abhishek Dewan


Thank you for following up and I'm sorry for taking time.

Of course, my username and email address were registered in each correct Field type.


I faced the problem on iOS and I understand Enpass iOS app can not save credentials entered on a webpage.

So, I tried via Enpass Win app.

On Win 11, I deleted the item and synced with iOS. I confirmed the item was removed also from the vault on iOS.

Then, again on Win 11, I entered the username and password on the webpage in Chrome, saved them via Enpass Chrome Extension, added my email address to the newly registered item (of course in 'Email' field), and synced the vault with iOS again.

I tried autofill on iOS but unfortunately, reproduced the same result.

In this try, I found the problem did not occur with Enpass Win app: it correctly entered my username to the username field on the webpage even when the item also had my email address.


In the above try,

1. I used Safari on iOS 16.6.1.

2. The website was Twitch (https://www.twitch.tv). But I had the same problem on other web sites where they required my username but not email address, and both of them were included in one item in my Enpass vault.


I hope the above will help you fix the problem.

Thank you.

Edited by banana
Link to comment
Share on other sites


I recently switched to an iPhone and autofill doesn’t work very well.

Enpass always tries to autofill using email even when the website is asking for a username.

I can reproduce this error 100% of the time with absolutely every single website that wants a username instead of an email for login.

For example: https://bethesda.net/en/dashboard?cogs_modal=login&redirect_to=transaction-history%2Fproduct-codes&redirect_to_site=accountsSite

It works on my android phone, it works on my mac (macOS), and I’m pretty sure it works on my PC (Windows). It only fails on iPhone.

I have an iPhone 15 pro max, with iOS 17

I also tested on another iPhone (pro 12, iOS 16) with a different enpass account. Same issue.

This makes Enpass very hard to use on iPhone.


Edited by Melvin
Link to comment
Share on other sites

I think this is a new issue with the recent 6.9.2 update. I’ve been using Enpass for years and never had this issue until this past week. 

That same update also made it so that the app forgets my license and makes me reverify at least once a day. I don’t know if they just don’t test things before releasing them, but I expect better from an app I’m trusting with the keys to literally everything. 

Link to comment
Share on other sites

  • 3 months later...
On 9/29/2023 at 6:49 PM, Abhishek Dewan said:

Hi @banana

Upon a thorough discussion and investigation, we were able to reproduce the bug. Our development team is now working on fixing it as a priority, and a patch addressing this issue will be released soon. We appreciate your kind patience and cooperation in the interim.

Any news on that fix? It makes app useless on mobile devices 

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...