Jump to content
JohnnyDoe

Imported entries from 1Password are missing some properties

Recommended Posts

Hi

I'm about to switch from 1Password to Enpass (on macOS). Unfortunately I'm having some trouble importing my data from 1Password into Enpass. I exported it to the 1PIF format and successfully imported this file into Enpass. But I noticed that some properties are not imported properly.

Sometimes an entry is missing the website property, meaning the URL where those credentials are used at. It is skipped completely.

And the timestamps from 1Password aren't imported as well. The data.1pif file does contain the values createdAt and updatedAt which Enpass should use, but the imported entry in Enpass always shows the time of when it was imported. I would much prefer the original values to be restored.

Entries containing TOTPs also don't show up correctly in Enpass. The key is imported but I have to manually recreate it as a TOTP field for it to show the six digit authentication code.

The following is an example export file from 1Password which reproduces all of these issues (I obfuscated username and password).

{"uuid":"803B0E883AF54E88A1752C536FA5FC57","updatedAt":1548268955,"locationKey":"fu-berlin.de","securityLevel":"SL5","openContents":{"faveIndex":1000},"faveIndex":1000,"contentsHash":"88049c01","title":"FU-Berlin","location":"https:\/\/identity.fu-berlin.de","secureContents":{"fields":[{"value":"johnnyXXX","name":"username","type":"T","designation":"username"},{"id":";opid=__8","value":"passXXX","name":"userPassword","type":"P","designation":"password"},{"value":"Weiter","id":"submitInput;opid=__10","type":"I","name":"_eventId_submit"},{"value":"Zurück","id":";opid=__11","type":"I","name":"_eventId_back"},{"value":"Abbrechen","id":";opid=__12","type":"I","name":"_eventId_cancel"}],"htmlMethod":"LB1","sections":[{"fields":[{"k":"concealed","n":"TOTP_5CC0A7495EBC452BB1F3C316996BC67F","v":"abcdef","t":""}],"title":"","name":"Section_C64CC239B5A4406A9929896BE2341861"},{"title":"Verwandte Objekte","name":"linked items"}],"URLs":[{"url":"https:\/\/identity.fu-berlin.de"}]},"txTimestamp":1548268955,"createdAt":1548268100,"typeName":"webforms.WebForm"}
***5642bee8-a5ff-11dc-8314-0800200c9a66***

Thanks in advance

Share this post


Link to post
Share on other sites

I agree. Their seems to be several issues when trying to move from 1password.. I believe the issue to be mostly because of the export from 1password. They've pretty much made it impossible to switch to a different manager without loosing data. 1password puts a lot of content in the "form details" instead of in the main details which is really frustrating. When exporting to the 1pif format, the title for the form fields are taken from the website you came from when adding your details so for example "username" might be entered as "choose a username" or "pick a login" or "Enter your email" etc.. Or let's say the "url" might be called "website" or "webpage" or "webpage2". When importing to any other manager we will either loose those entries completely or they will be imported as "other" or whatever. The only way to export from 1password is to a standard csv. Then we can at least open it in a spreadsheet and make sure the entries look ok, this is however extreemly tedious if you have a few hundred entries. Unfortunately we also loose any multiple urls in the export and any other extra information we might want..  

In any case I will definitely add my vote to this as well. Please figure out a way to import 1password 1pif -data in a correct way since many entries become unusable in enpass after import.

Share this post


Link to post
Share on other sites

Hey @guys,

We have fixed some issues regarding 1password import and pushed a new update. Please update the Enpass app and share your findings.

Thanks for your co-operation.

Share this post


Link to post
Share on other sites

Unfortunately the new update (6.0.3) didn't fix any of my issues. I tried to import again and the result is exactly the same.

Edited by JohnnyDoe

Share this post


Link to post
Share on other sites

I just updated yesterday and then again today so it's a minor update I assume (still 6.0.3). In any case, all my 545 entries seem to have been imported perfectly for the first time ever in any manager including attachments which has never worked for me! Super happy about this! Thank you! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×