Jump to content
davidc

1password import only partially completed

Recommended Posts

Hi

I am moving from 1Password 4.6.2

From the File menu, I choose Export, choose 1PIF format, then put it in a new directory on its own and name it "data.1pif"

It confirms it has exported all 465 of my passwords.

In Enpass, I choose File, Import, 1Password, then point it at the directory that I put data.1pif in.

It confirms it has imported 249 passwords.

So it has failed to import around half of my passwords and hasn't given any errors or reasons why this would be so. Looking at the Enpass vault, I can indeed identify many passwords that are simply missing.

This looks like it has already been reported at 

 but the response there only deals with the "no title" issue (which isn't the problem for me), it does not address the issue of a large number of passwords not being imported at all.

Thanks

David

Share this post


Link to post
Share on other sites

Hey @davidc,

I'm really sorry for the inconvenience caused to you.

We have tested this issue in our lab and were you unable to reproduce it. However, one possible reason for the problem you are facing might be because of the fact that Enpass doesn't import trashed data from 1password 1pif. 1Password exports vault data as well as trashed data when you try to export all the data in Pif format. But in Enpass we don't import trashed items. I would request you to check if there are items existing in the trash folder? If so please move it to the main vault and then export the data. Also, please let me know on the category of items that are lost so that we can investigate further.

Thanks for your co-operation.

 

Share this post


Link to post
Share on other sites

Hi Anshu,

image.png.f331a46072a719e4069f56daf1baab41.png

I have 13 items in Trash so there are still 452 active logins exported. Everything is a Login item, no credit cards or anything.

I have attached some screenshots below but of course I have had to obfuscate some details on a public forum:

image.png.97600a66e7b96dbb84383b48dd51cccb.png

249 items imported (the additional 3 are new items I created directly in Enpass, making 252 total):

image.thumb.png.aec3bf1f8942658e7c6d1563f6bf9843.png

You can see for example that AAAAAA was not imported.

It looks normal in 1password:

image.png.f12c051aac7bed1863ac277588d97c22.png

From my perspective, it looks pretty similar to BBBBBB which was imported successfully:

image.png.6657861f15fbf7ff369b075740acdce3.png

Both have their username and password fields identified, so I don't know what the difference is, or why one is imported and the other isn't.

Here is the JSON from the 1PIF file for both of these entries too (I have obfuscated all sensitive fields with "xxx"):

***xxx[a uuid]***
{"keyID":"xxx[a hex string]","locationKey":"AAAAAA","typeName":"webforms.WebForm","location":"AAAAAA/login","uuid":"xxx[a hex string]","createdAt":1414531293,"title":"AAAAAA","securityLevel":"SL5","openContents":{"autosubmit":"default"},"updatedAt":1414531294,"contentsHash":"xxx[a short hex string]","secureContents":{"fields":[{"name":"login.User","value":"xxx[my username]","id":"loginform-user","type":"T","designation":"username"},{"name":"login.Pass","value":"xxx[my password]","id":"loginform-password","type":"P","designation":"password"}],"htmlAction":"AAAAAA/Login","htmlName":"loginform","htmlMethod":"post","URLs":[{"url":"AAAAAA/login"}]}}

***xxx[same uuid as above]***
{"keyID":"xxx[same hex string as above]","locationKey":"BBBBBB","typeName":"webforms.WebForm","location":"BBBBBB/weblogin.htm","uuid":"xxx[a different hex string]","createdAt":1522174876,"title":"192.168.3.1","securityLevel":"SL5","openContents":{"autosubmit":"default","usernameHash":"xxx[a long hex string]"},"updatedAt":1522174876,"txTimestamp":1522174876,"contentsHash":"xxx[a different short hex string]","secureContents":{"htmlForm":{"htmlMethod":"LB1"},"fields":[{"designation":"username","value":"xxx[my username]","id":";opid=__0","name":"sUserName","type":"T"},{"designation":"password","value":"xxx[my password]","id":";opid=__1","name":"sSysPass","type":"P"},{"name":"btnOk","id":";opid=__2","value":"Login","type":"B"}],"URLs":[{"url":"BBBBBB/weblogin.htm"}]}}

 

Hope this helps track down the issue. I'm surprised it isn't a more common problem as it's happening to fully half my logins!

David

 

Share this post


Link to post
Share on other sites

Hi

Have you had any luck tracking down the problem please? I am having to keep 1password around because I can't afford to lose half my passwords; that defeats the point of a password manager.

Regards

David

Share this post


Link to post
Share on other sites

I have the same problem - exportet 362 Items - imported 169......

Version 1Password Mac 7.3.1

Version Enpass Mac 6.1.0

Regards

Klaus

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...