Jump to content
Enpass Discussion Forum

Webdav sync broken: error 907018

Recommended Posts



i am using Enpass a long time now and its working great. Since probably the last updates the WebDAV sync to my Owncloud/Nextcloud is broken.

On all my devices (Windows/Mac/iOS) webdav-syncing fails with error 907018


What is this about?

how can i solve that?





Link to comment
Share on other sites

  • 3 weeks later...

Same behaviour on my side.

Nextcloud 17.
On iOS, macOS Catalina. Will test it on Fedora and Debian, too

Logs while syncing:

MYIP - - [01/Nov/2019:09:23:50 +0100] "PROPFIND /remote.php/webdav/Enpass/vault.enpassdbsync HTTP/1.1" 401 4520 "-" "Mozilla/5.0"
MYIP - - [01/Nov/2019:09:23:50 +0100] "PROPFIND /remote.php/webdav/Enpass/vault.enpassdbsync HTTP/1.1" 207 1664 "-" "Mozilla/5.0"
MYIP - - [01/Nov/2019:09:23:51 +0100] "GET /remote.php/webdav/Enpass/vault.enpassdbsync HTTP/1.1" 401 1597 "-" "Mozilla/5.0"
MYIP - - [01/Nov/2019:09:23:51 +0100] "GET /remote.php/webdav/Enpass/vault.enpassdbsync HTTP/1.1" 200 362903 "-" "Mozilla/5.0"

Tried it with the URL syntax:



File ist available and writable.
Last sync is done 5 days ago.
Since then it isn't possible to sync anymore with nextcloud

Edited by cmgrube
Insert Logs from Server
Link to comment
Share on other sites

@Tahreem : any news on this bug ?

The sync has been broken for a while now and it's starting to be really annoying to have to type every password on my phone (my previous one died on me, and I can't start get Enpass to work/sync on it at all).
Furthermore, I don't have a backup for my new passwords (I'm trying to save them on the same device (tablet), but the other ones (phone, windows, linux) don't have the most recent ones).

Let me know if you want a PM with a webdav account to test it.


Enpass versions :

phone (Oneplus 3T / Android 9 / OxygenOS 9.0.5) :

tablet (Galaxy Tab S6 / Android 9 / OneUi 1.5):

Linux (Ubuntu 19.04) 6.2.0 (533)

Windows 10 : (Edit) 6.2.0 (542)

NextCloud version : 16.0.6 (stable channel, updated today)


Edited by minidev
Link to comment
Share on other sites

Hey @Tahreem, I've send a email with the nextcloud test account.

Unfortunately, as I explained in the mail, I have interesting new information :

I've created a new vault (with the credentials I've sent to you by mail), and surprise, the new vault syncs with no problem! Same nextcloud server / config, same enpass app! (just an empty vault and a new user)

My guess is that I have something in my main vault that prevents Enpass to sync...

Link to comment
Share on other sites

@Tahreem : some experimentations on my part that may help the devs :

  • I did look at the last modification date of my vault on nextcloud : 5 november
  • 2 of the entries created after this date attracted my attention : 2 wifi passwords that Enpass did save but ... I wasn't able to see any actual password : there was just an Icon «System», which when clicked did open my tablet settings menu
  • I deleted these 2 entries (move to trash, then delete them from trash)
  • tried to sync : NO SUCCESS

Then :

  • I did create a local backup of my (current and only) vault.
  • Created a new vault, and used the previous backup to restore.
  • Configured a webdav sync with my another nextcloud account (the admin one : booh that's bad)
  • Sync : SUCCESS

Conclusion : the current “broken” vault that don't sync, can be synced when backed up to a file and then restored in another vault.

Link to comment
Share on other sites

  • 10 months later...

Hi Garima, I use the following versions of Enpass:

  1. on Windows 10 Pro (version 2004, build 19041.572) I use latest Windows Store version;
  2. on Android 8.1.0 (an ungoogled version of Android called /e/, see https://e.foundation/) I use version;
  3. on an iPod touch (iOS version 12.4.8) I use version 6.5.2.

All of them give the same issue, although yesterday one of the Windows devices still synced, but after reconnecting the sync it doesn't any more o.O.

I think I did delete the data on the WebDAV account two weeks ago and restored the data from a backup afterwards, but this didn't solve the problem.

Thanks for your help, I hope you can figure this out!

Link to comment
Share on other sites

Dear Garima, I am happy to inform you that the sync works again on all of my devices!

As you suggested, I disconnected all my devices and ticked the option to delete the information from WebDAV as well. After that there still remained a (smaller) file called 'vault.enpassdbsync' in the Enpass cloud folder on WebDAV, which I deleted as well. Then, I linked my main device to WebDAV again, and after that, the sync was functional again.

I suspect the problem might have occurred because of my slow internet upload speed, which might have caused the sync file to get corrupted.

Thanks a lot for your help!

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...