Jump to content
Alexxander

WebDAV Sync Error Nextcloud

Recommended Posts

Hello everyone,

I have a problem with my Nextcloud 19 WebDAV synchronisation. I use the latest Android and Linux version of Enpass with password and key file. After less then one day the sync is broken and Enpass claims that the password for the WebDAV data is required. 

I already disconnected all devices, deleted the file on the Nextcloud Server and even exported everything to a csv file and created a new password vault. Unfortunately with the same result. After a few hours the sync is broken again.

Is that a bug or a known problem with the latest Nextcloud version?

Thanks in advance

Alex 

 

 

Share this post


Link to post
Share on other sites

Hi @Alexxander,

Welcome to the forums!

Please share the following details so that we can investigate where the problem could be.

  • On which devices and OS versions (mention all) are you using Enpass?
  • Which Enpass version are you using on each device?
  • Are you getting any error message or code during sync? If yes, share it with us.

Share this post


Link to post
Share on other sites

Hi @Pratyush Sharma

 

For testing I'm only using my android phone. I disabled all other devices. It's a android 10 device with Enpass 6.4.5.368.

The password vault was initially created on Debian Linux, Enpass version 6.4.1 (643) 

In general I'm use the latest Linux and osx version of Enpass.

I don't get an error code only the option to solve the issue. In English it would be something like: " Synchronisation error. The password for the data on WebDAV is required" Then Enpass asker's me for my password but does not accept that password. 

 

Best,

Alex 

 

 

 

 

Edited by Alexxander

Share this post


Link to post
Share on other sites

I am also having this issue, it tells me that I cannot sync to the cloud because the password is incorrect, however the master password has not been changed. I even tried changing the master password to the current password and it still does not recognize the master password for the cloud. I am using iOS13.5.1 on my iPhone and Windows 10 on my PC.

Share this post


Link to post
Share on other sites

I can confirm that. I'm using nextcloud + webdav sync with windows and android. Actually, I have to disconnect and reconnect the webdav sync far to often.... Its horrible, I don't know if a vault is up to date or not.

 

Share this post


Link to post
Share on other sites

I have the exactly same problem.

 

I am also using Nextcloud 19 for syncing via webdav.

 

Enpass Clients are the latest iOS App on latest iOS and the latest Enpass client for Debian Linux (Buster).

 

Both stopped syncing from one day to another round about 2 or 3 weeks ago.

Quote

I don't get an error code only the option to solve the issue. In English it would be something like: " Synchronisation error. The password for the data on WebDAV is required" Then Enpass asker's me for my password but does not accept that password. 

Same for me!

I did not changed anything (I know, this is what they always tells you)

Edited by oliwor

Share this post


Link to post
Share on other sites
On 7/10/2020 at 8:09 PM, oliwor said:

I have the exactly same problem.

 

I am also using Nextcloud 19 for syncing via webdav.

 

Enpass Clients are the latest iOS App on latest iOS and the latest Enpass client for Debian Linux (Buster).

 

Both stopped syncing from one day to another round about 2 or 3 weeks ago.

Same for me!

I did not changed anything (I know, this is what they always tells you)

 

This is quite anoying. Since march somethings seems to be broken. Also I do not understand, why Enpass seems to change a vault password to the webdav password or to something else. We use Enpass for a long time now and also use webdav for sharing various vaults for department passwords. this is no more working. As soon as somebody changed back the password from the vault an did a fresh sync, all others are locked out. As soon as I resync with my iphone, the mac version is also locked out. Always with the same data errors. The vault seems to have a whatever other password then, which couldn't be accessed anymore. They messed up something really heavily in webdav.

I also filed a bug report on that already. But didn't get any answer at all. 

Share this post


Link to post
Share on other sites

Hey @Butimo

Welcome to the forum.

We acknowledge your feedback and apologize for the inconvenience. We're already working to resolve this in the next update which will release in the upcoming week.

Share this post


Link to post
Share on other sites
33 minutes ago, Garima Singh said:

Hey @Butimo

Welcome to the forum.

We acknowledge your feedback and apologize for the inconvenience. We're already working to resolve this in the next update which will release in the upcoming week.

Good to hear. Let me know, if further support is needed or if you need more information.

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Garima Singh said:

Hey @Butimo

Welcome to the forum.

We acknowledge your feedback and apologize for the inconvenience. We're already working to resolve this in the next update which will release in the upcoming week.c

Just curious: So you figured out what causes this behaviour? Can you tell some details?

  • Like 1

Share this post


Link to post
Share on other sites

Hi All,

Thanks for the patience.

To help us diagnose this error further, could you please perform these steps-

  • Download the debug version of Enpass from this link for windows device.
  • Disconnect the vaults from syncing(temporarily of course)
  • Enable logs by following the steps-  Open Enpass --> Settings --> Advanced --> Logs --> Enable it.
  • Then setup sync again with WebDAV and wait for error.
  • When you receive an error code --> Go to Advanced settings --> Logs --> Copy the Logs in any text editor and share with us via mail at support@enpass.io.

Also please confirm if there is different master password on different devices connected to same cloud?

Thanks for the co-operation.

Share this post


Link to post
Share on other sites

I don't use any windows devices.

 And I am a little bit confused. In your last posting you told us that you will release a new version next week in which this error is fixed.

Now you are asking for information to find the error?

Edited by oliwor

Share this post


Link to post
Share on other sites
17 hours ago, Garima Singh said:
  • Download the debug version of Enpass from this link for windows device.

I do not have Windows as well. Just Mac and iOS

Share this post


Link to post
Share on other sites

Hi @Alexxander @oliwor @Butimo,

Sorry for the inconvenience caused to you.

To investigate further on this issue, we want a little input from your side, so please take the backup of Enpass data and perform these steps and let me know if the problem persists.

  • Download the debug version of Enpass from the below-mentioned link.
  1. Windows: https://dl.enpass.io/beta/windows/setup/6.5.0.681/Enpass-setup.exe
  2. Linux: https://dl.enpass.io/beta/linux/setup/6.5.0.681/enpass-setup.deb
  3. Mac: https://dl.enpass.io/beta/mac/package/6.5.0.681/Enpass.pkg
  • Now open Enpass --> Settings --> Advanced --> Logs --> Enable it.
  • Then set up the sync again with WebDAV and wait for the error.
  • When you receive an error occurs --> Go to Advanced settings --> Logs --> Copy the Logs in any text editor and share with us via mail at support@enpass.io.

Please confirm if there is a different master password on different devices connected to the same cloud?

Thanks for the co-operation.

Share this post


Link to post
Share on other sites

I tried it out and sent the report+log. I cannot even setup my other vaults. After having the first configured, I always get login/password errors by setting up others.

I may also find another issue. If you have to many failed logins on nextcloud, your login gets throttled up to 30 seconds. Looks like Enpass is then running into a login timeout and shows it as wrong credentials. Do you run into a timeout on your side? This even adds up login attempts on nextcloud. This has also an effect to all other usages of nextcloud coming from the same IP.

Share this post


Link to post
Share on other sites

Hey @Butimo

We are really sorry for the trouble you are getting.

Please be informed that we have received your logs and other issue details and our team is working their best to investigate the issue. Your co-operation will be highly appreciated.

Thanks for understanding.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...