Jump to content
Enpass Discussion Forum

The "Restore from Google Drive" dialog incorrectly asks for a key file

Peter Pan

Recommended Posts

Hi all,

I'm using an M1 Mac with macOS Big Sur 11.1 (20C69) and Enpass 6.5.2 (726).

When I try to import a vault from Google Drive, Enpass restore dialog asks for a keyfile. But, there is no key file for this vault. I can't import the vault without a keyfile. It works on various other devices without a key file being "required".

Does anyone know the problem?

Here is a screenshot:


Edited by Peter Pan
correction of spelling
Link to comment
Share on other sites

I checked this again on an Intel-based Mac. Also macOS 11.1 (20C69) and Enpass 6.5.2 (726). No issue here!

I have observed that it does not appear to be the case with all vaults at the M1 Mac! So with another vault, the problem does not occur on an M1 Mac. It occurs reliably with my main vault.

No key file is requested for my main vault on an Intel-based Mac:

Link to comment
Share on other sites

Hey @Peter Pan

Welcome to the forum!

It seems there is 2 vaults(primary and secondary), primary vault doesn't have a keyfile and you are trying to restore the data from Google-drive in the secondary vault which has a keyfile. Please check again the particular secondary vault keyfile and use the same to restore the data.

Let me know if you have any concerns.



Link to comment
Share on other sites

  • 2 weeks later...

Hey @Garima Singh

For the test, I tried to restore the vault as a single vault or in a multiple-vault configuration as the primary vault or as a secondary vault. Always with the same result that Enpass asks for a key file during recovery.

With all other devices, regardless of whether macOS, iOS or Windows, I was able to recover this vault without a key file in the past. Now it seems that Enpass via Rosetta on M1 devices requires a key file for this vault, although the vault can be used on all other devices without a key file.

What else can I try? Is it possible to activate the key file for testing on another device for the vault and then deactivate it again to check whether it then works without a key file on the M1?

Thanks for your support.

Link to comment
Share on other sites

Hey @Peter Pan

We regret the inconvenience.

As far as I understood, you can access the same vault on any other device and you are getting this issue while trying to restore the same vault on the M1 macOS.

Also, please confirm if you have used keyfile in Enpass in past and later removed it? If yes, this could be a rare bug in Enpass and we will fix it soon. Meanwhile, we can try deleting your data from Google Drive and replacing it with the data from the correct device (on which you don't have keyfile).

Please follow the below steps to resolve this issue-

  1. Please disconnect sync from all your devices which is synced with Google-drive. While disconnecting sync from desktop, you will have the option "Also, delete data from Google-drive". Enable it and click on the Disconnect button. This will delete the data on cloud and keeping ot on your device.
  2. Now open Enpass on the device where Enpass is working without keyfile and set-up sync again with Google-drive.
  3. Open Enpass on the M1 and try to restore the data again.

Let us know if this doesn't help.


Link to comment
Share on other sites

Hey @Garima Singh

I followed your instructions. After the 1st step, I deleted manually the remaining data on Google Drive:

With these steps the import and synchronization was possible with the M1 MacBook! Thank you very much!

I wanted to finally register Enpass on the M1 in order to be able to use it with all functions. When I try to activate/register Enpass, I ran straight into the next problem...
As soon as I have entered the code for Enpass registration after entering my email address and clicked on "Confirm", an error occurs in the GUI and the registration is not carried out. No matter how often I try it, no matter whether I restart Enpass, confirm the input with the mouse or the input key, the error is always the same.
I create a screen recording of it:

Do you have any ideas how I can fix the problem?

Link to comment
Share on other sites

Hi @Peter Pan,

Thanks for notifying us. I'm glad to know that the problem has been resolved.

Regarding GUI issue: We are able to reproduce this issue at our end, and our team is working on it.

Regarding error: Can you please share the screenshot of the error with the email id mentioned to us on support@enpass.io so we can help you better.

Thanks for your co-operation.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...