Jump to content
Enpass Discussion Forum

Enpass trying to sync with incorrect Onedrive


Rita
 Share

Recommended Posts

I recently updated the password for my personal Windows account, including OneDrive on a PC running Windows 10.  All of my Windows and Microsoft Office software is working correctly following the update on this PC (I'll call it PC#1).  I also access these same Windows accounts from 3 iOS devices and another Windows 10 PC and have no issues following the PW update.

With PC#2 and the 3 iOS devices, I was able to set up Enpass sync through my personal OneDrive without any issues.  With PC#1, when I go to set up sync, Enpass sends the request to my work OneDrive, not my personal OneDrive.  I have checked everything I can find to check and Edge, all of the Microsoft Office applications and File Explorer all reference my personal OneDrive.  I can find no reference to my work OneDrive in any location including Settings/Accounts.

I tried logging out of OneDrive in Edge and log back in, but this did not change Enpass trying to sync with my work account.  I uninstalled Enpass and reinstalled, with no change in behavior.

Do you have any suggestions on getting Enpass to select my personal OneDrive and not my work OneDrive?  Any assistance would be appreciated.

 

Link to comment
Share on other sites

Hi @Rita,

Welcome to the Enpass Community.

As I understood your Enpass is getting Logged in via your work profile. This is an issue of browser and Microsoft sign in page rather than Enpass.  I can suggest you to try:

1. Logout from your other account from Edge browser
2. Clear the cache/cookies for all Microsoft domains from Edge browser

Thanks.

Link to comment
Share on other sites

  • 2 weeks later...

Clearing the cache and cookies did the trick.  Enpass asked me to enter the email address of the OneDrive I wanted to sync with and I was able to connect to the proper system.  Thank you.

  • Like 1
Link to comment
Share on other sites

I am having this issue on t he iPad. I cleared cookies and website data in Safari. I didn't have Edge installed, but I installed it and cleared cookies and website data in there. I ran the onedrive app and verified that it was only connected to my personal account. I logged into onedrive via Safari and Edge and verified it was only using my personal account. And yet every time I go into Enpass to try and add my other vault, it tries to log in via my work Onedrive account. I am a Pro user, and am so frustrated by this I am considering switching to another password manager. Please help.

Link to comment
Share on other sites

22 hours ago, Gulshan Dogra said:

Hi @motocoder,

You can try to take the manual backup of your database and uninstall the Enpass app then re-install Enpass and restore your database.

Although, I have forwarded this issue to our concerned team for further investigation. I'll let you know as soon as I have any updates regarding the same. 

Thanks. I'm only using Onedrive because Enpass only allows one vault on iCloud. If you supported multiple vaults per back end, it would be very nice

Link to comment
Share on other sites

Hi all,

I would like to share that "Incorrect OneDrive account" is not an issue that can be fixed in Enpass. Enpass just uses the account token passed by the browser.  This is a Microsoft issue as clearing cache/cookies from all the Microsoft domains solves this. You have to clear cache manually from the browser settings if you are facing this issue.

Link to comment
Share on other sites

I did clear the cache. Seems it's not possible to have two vaults with cloud sync in enpass, so I guess I will have to look elsewhere. I love the program and have been a user since the Windows Phone days. Am really sorry that I have to switch.

Link to comment
Share on other sites

Hello Enpass-Team!

 

We sync multiple vaults through different M365 accounts (one for each customer). This is achieved by using incognito tabs since Enpass opens the latest tab opened in the standard browser.

 

Workflow:

- Open browser

- Open incognito tab

- Close all other tabs

- Create new vault in Enpass

- Restore from Cloud -> OneDrive

- Login with the account details for the sync-account given by the customer

 

Not the smoothest way but it works. The problem is, this method doesn't work on mobile platforms (tried Android and iOS). We can sync our main-vault but after one or two more vaults we're out of luck. Somehow Enpass stores the last login and it keeps on telling us, that we can't sync a second vault from the same share - of course. We're not logged in on any accounts in the browsers and we tried different browsers but we didn't manage to find a way to make this work.

 

Is there anything we can do about it?

 

 

Best Regards

Richard

Link to comment
Share on other sites

Hello @RichardIT!

Welcome to the Enpass Forum. 

On 9/4/2021 at 11:14 AM, RichardIT said:

Is there anything we can do about it?

 

Make sure you have synced a different M365 account with the other vault. However, Enpass does not store your last login but the browser. Enpass just uses the account token passed by the browser. This is a Microsoft issue and to resolve it, you need to clear the cache/cookies manually from the browser settings on your mobile device.

Link to comment
Share on other sites

Clearing the cache and cookies everytime "solved" the problem, thanks.

 

Edit:

Maybe someone finds this info useful -> sometimes clearing the cache/cookies once wasn't enough. I had to do it multipe times before I was able to connect to another M365 account.

Edited by RichardIT
  • Like 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...