Jump to content
Enpass Discussion Forum

WebDAV sync - again or still broken


Recommended Posts

Hi, in old versions of Enpass, the WebDAV sync worked like a charm. But in the last versions it's broken - which makes Enpass almost useless.

Earlier on, I could establish a WebDAV sync but after a while Enpass stopped syncing with the error message that the WebDAV password is wrong. The password didnt change but Enpass didn't accept the correct password without an error message. Deleting the sync and recreating it with exactly the same password worked for a while ... until Enpass once again stopped syncing ...

I tried again today because the were a few updates of Enpass since I stopped the WebDAV sync. But this time, the error is different. I enter the WebDAV details; they are accepted and Enpass starts syncing. Then I see the spinning dots for a while and suddenly Enpass returns to the 'Set up sync screen'.

I'm using Enpass on Windows 10. 

Link to comment
Share on other sites

  • 2 weeks later...
6 hours ago, Andreas M. said:

I see exactly the same behavior using Mac / iOS devices. I already reset the sync completely, but after a few days the same error occurred again …

Thanks Andreas. So I'm not alone. It's a real pity that this feature which work once is now broken and somehow makes Enpass not fit for purpose anymore.

As a security/privacy tool, I'm not keen to store my sensitive data on OneDrive, Dropbox or another 3rd party service.

Link to comment
Share on other sites

  • 2 weeks later...

Hello @allwiand @Andreas M.,

Welcome to the Enpass Forum. 

I certainly understand your concern about the intermittent WebDAV issue. There could be many reasons behind this issue. However, I would suggest you to perform the following steps to resolve it:

  1. Take a manual backup of your data on your devices. 
  2. Disconnect the WebDAV sync from all the devices.
  3. Open WebDAV in the browser → Open Enpass folder → Select vault.enpassdbsync file → Rename it as oldvault.enpassbdsync.
  4. Reconnect your all devices from WebDAV.
  5. If sync starts to work fine, you can delete the renamed old backup file from WebDAV. Let me know if that helps. 
Link to comment
Share on other sites

Hello @Andreas M.,

Thank you for sharing the results. For further investigation, please share the following details:

  1. Help me with the Enpass version (Downloaded from Store or Website) and OS information.
  2. If possible, please share the demo account credentials of your WebDAV along with the URL. (For security reasons, share the account details in the personal message or share them over support@enpass.io).
  3. Make sure the date & time must be the same on all the devices. 
Link to comment
Share on other sites

Hey @Manish Chokwal, thank you for you reply. I just noted that this problem is *independent of WebDAV*, as I just had the exactly same error message that my password on the server changed for the Wifi sync I used now as an alternative. My Enpass versions are 6.7.2 (887) on Mac (web version) and the most recent 6.7.1 from the App Store on iOS and iPadOS. Does enabling logging on the Mac help for finding the problem? Thanks for your help.

Link to comment
Share on other sites

  • 2 weeks later...

Hi @Manish Chokwal, I now used a completely different WebDAV server (different WebDAV server software, different physical machine) with a completely newly created vault – and the error happened again after just a week of using it. So this is NOT related to anything server-specific, and not even seems to be limited to WebDAV (see report on Dropbox showing the same error here). Unfortunately, I turned on logging just now after the error re-occurred. But it would be really great to see some effort to get this fixed, as this bug kills an essential function for me …

Edit: The only syncing info I get now, after the error occurred, in the logs:

Info: [HTTP]  Using AUTO Proxy detection 
Info: [HttpClient] https://WEBDAVSERVER/Enpass/vault.enpassdbsync curlresultcode: 0 responseheaders: HTTP/1.1 207 Multi-Status
Date: Fri, 19 Nov 2021 11:10:47 GMT
Server: Apache
Content-Length: 864
Content-Type: text/xml; charset="utf-8"


Edited by Andreas M.
Added log
Link to comment
Share on other sites

  • 2 weeks later...
  • 9 months later...

Hi Frettman,

I finally gave up. I raised this issue multiple times. In the forum as well as per support email but it was never addressed. 

So I moved to a self hosted Bitwarden install and couldn't be happier. Suddenly you have a software which works (on Android and Windows devices) and you don't have to fix it permanently. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...