Jump to content
Enpass Discussion Forum

Enpass 6.7.4 (933) loses connection to databas


Recommended Posts

Since the last update Enpass became VERY strange acting:

  1.  Firefox extension cannot connect with the application or database.  Each time I try to open it from Firefox, it goes through the "cannot connect" with the application routine so that I often have to go through the 6-digit code authorization again to get it to run.
  2. When I finally get the extension to run, it has no database items listed.  So I select "Run Enpass" from the menu, and when the main application runs, it also cannot connect to the database.  It claims I have no entries (as opposed to the ~ 250 entries I DO have).
  3. If I close the browser, then open Enpass from the desktop, all the items in my database are shown.  But if, while Enpass desktop is still open I run the browser and open the Enpass extension, it still cannot find the database.
  4. Despite not finding the database, when I go to a  login page in Firefox, the new extension puts a banner over the login page trying to  block the autofill blocks. Clicking the enpass banner does nothing so I have to click elswhere on the  page to make the banner disappear and use the native Firefox PW manager/autofill if I do not want to manually key in credentials.

I tried uninstalling the extension from within Firefox and then reinstalling it but nothing changes.

Any ideas on how to get Enpass desktop AND Firefox extension working together and correctly again?

Link to comment
Share on other sites

Hi @wmc

Please ensure that the Enpass application is running in the background when you are using the browser extension. The “Enable Extensions” under the Browser settings of your Enpass application should also be enabled.

I would also suggest checking that you have the latest version of Firefox installed. If these instructions do not help, then I'll require some additional information. Please share the below details with me, and I'll get this investigated for you -

  1. The version of the OS, Firefox and Enpass extension you are using.
  2. Did you download the Enpass app from the Windows Store or our official website?
  3. A screenshot of any error occurring would be helpful.
  4. Could you please check and confirm if you have allowed the Enpass app in your Firewall and your Antivirus settings? Please share the name of the antivirus as well.
  5. Are you using any VPN service? Please try disabling it to check if the issue persists. Also, share the name of the VPN you are using.
  6. Are you facing a similar issue on any other browser as well?
Link to comment
Share on other sites

  1.  Windows 10 21H1 build 19043.1586; Firefox 99.0 (64-bit); Enpass extension 6.7.0 (last updated April 10, 2022  and then the problems started).
  2.  Enpass application and extensions downloaded from official site.  HOWEVER, an update sometime just after Enpass became available in Windows store seened to use that one for an update which totally screwed things up.  So I tried to uninstall the "windows app" and excess detritus and reinstalled from enpass.io. to get everything working again.
  3. Today the crash report window popped up at system boot time but I simply clicked the "send report" option and did not get a screen shot.  See below for symptoms. 
  4. McAfee (which has seriously dumbed down the UI and user control/visibility of its operation since being acquired by Intel) shows "Enpass Password Manager [C:\Program Files (x86)\Enpass\Enpass.exe] Company: Sinews Software Systems Pvt. Ltd." with "Accesss = Designated Ports" and "Net Guard=ON".  These are the same settings in a nearly infinite (unsearchable, non-alphabetized) list of OS modules, apps browsers and extensions.  No visibility into "Designated Ports".
  5. No VPN in use.
  6. Same action in Chrome on this machine (HP z840 Workstation).  Also on my Microsoft Surface (older machine with up-to-date Windows 10, Chrome as browser, Enpass desktop [from official website] and extension etc.)

Most of the time the problem occurs when I try to open Enpass from the Firefox tool bar.  Then I get the pane that tells me Enpass is looking for the Enpass "App". 

  1. Sometimes it "finds" the app gives me the 6-digit code to key into another enpass extension window in order to open the extension.  I then key in my password and the extension opens, but seems to be tied to a database that has only one item in it - one I added after the  last extension update (Apr 10, 2022). 
  2. Other times it does not "find" the app and opens in the browser the "Connection Error" "page" from the extension.    If I select "Run Enpass" from that page, the application opens, I key in the master password, the UI goes away.  Then I click on the Enpass extension icon in the tool bar. On the workstation it opens asking for the password which I key in and the extension lookup UI presents but is connected to the DB with only the latest entry.  On the MS Surface, when I key in the password, the UI simply disappears.  When I attempt to open it again, it will cycle through the "looking for Enpass", generates and Enpass Crash Reoport, opens the desktop app where I key in the password to unlock it, the desktop app UI disappears, cycle repeats ad infinitum.

The problem appears to be tied to the latest extension update.  Can I download / install the previous extension versions for Firefox and Chrome?

Link to comment
Share on other sites

I've really screwed up! After reinstalling Win 10 to my PC I had to replace apps that had been removed by the process. I got a new download of Enpass from the website but apparently, I created a new vault rather than opening my old vault with about 550 passwords in it. I have my original Master Password but have zero idea how to fix the problem and get my passwords back. Your hlep, ideas or suggestions would be most appreciated.


Link to comment
Share on other sites

1 hour ago, Walter Danley said:

I've really screwed up! After reinstalling Win 10 to my PC I had to replace apps that had been removed by the process. I got a new download of Enpass from the website but apparently, I created a new vault rather than opening my old vault with about 550 passwords in it. I have my original Master Password but have zero idea how to fix the problem and get my passwords back. Your hlep, ideas or suggestions would be most appreciated.


Why are you posting in an existing, non-related thread? 

You should create a new one, or contact support directly if you have a subscription. 

You're safest bet would be if you had Cloud Sync setup in the old installation, then you'd simply create a new vault now and choose restore from cloud when setting it up. If not, then it depends on whether you formatted your drive. 

If you didn't, Enpass creates backups automatically under your personal folder which could be accessible and restored from. 

  • Like 1
Link to comment
Share on other sites

Well, he has the same problem I do.  Installation / update to the newest extensions for Firefox and Chrome on WIndows 10 prevents the extensions from accessing the existing passwords/vaults for some reason or other.

Whether or not the new extension create new vaults or not, I cannot tell since I can only find my existing vault in its expected location, and where the desktop application finds  the vault when the extensions are not used to start the desktop application.  And this problem did not exist with the previous versions of the FF and Chrome extensions, so I am hoping someone can tell me where/how to get the previous version of the FF and chrome extensions so I can revert to them while the developers fix this issue.

Link to comment
Share on other sites

  • 3 weeks later...

@Walter Danley It sounds like you use/upgraded the Windows API (Win32) application, not the modern Enpass app that is installed from the Microsoft Store? Windows API edition Enpass' data location is %UserProfile%\Documents\Enpass by default, where %UserProfile% is your user profile directory (e.g. C:\Users\wmc). Enpass auto backups are enabled and stored in a Backups subdirectory of Enpass' data location by default. You can restore your Enpass vault from a recent auto backup.
I'm guessing you may have both Windows API edition Enpass 6.7.4 (933) and the Microsoft Store Enpass app installed... Default data location for Microsoft Store edition Enpass is different (%UserProfile%\Appdata\Local\Packages\SinewSoftwareSystems.EnpassPasswordManager...) from Windows API edition Enpass. If you have both editions installed, browser extensions may be opening and connecting to the Microsoft Store edition. If you haven't previously used/set up the Microsoft Store edition, that could explain why Enpass isn't connected to a vault. You also mention reinstalling Windows 10. Did you do an in-place "upgrade" or did you do a wipe-and-load (format disk/Windows partition)? If the latter, unless you backup your computer/data (no excuses, this is 2022 after all) or use Enpass native cloud-sync capability (Dropbox, Google Drive, etc), your Enpass vault is toast.
A few recommendations:

  • Don't hijack forum threads. @Ivarson response was spot on, IMO. Your description of the problem you encountered is quite different from the description provided by @wmc. Even if a symptom is similar, you don't know whether the source of the trouble is the same. Better to start a separate thread.
  • Install only Enpass Windows API edition OR Enpass Microsoft Store edition (appears as Enpass Password Manager in Microsoft Store or Windows Settings (app) > Apps & Features). Having both installed can cause unexpected results and create confusion.
  • Use cloud sync. Consider one-way syncing Enpass vault data between 2 clouds (e.g. Google Drive -> Dropbox), where your second cloud service is not readily accessible from your device(s). Enable 2-factor authentication on your cloud accounts (Google, Dropbox). The idea is to make it more difficult for an attacker to leave you high-and-dry by ransoming/destroying your active data and primary backup.
  • Provide more detail when requesting help. Other users and support are more likely to answer and be able to offer better help. Learn how to ask questions in a way to attract good responses. For example, see https://www.biostars.org/p/75548/
Link to comment
Share on other sites

Hi @wmc

Thank you for the details.

I'm afraid it is not possible to roll back to previous Extension versions. We have recently updated our Enpass browser extension to version 6.7.5. Could you please update your Extension and share your findings with me?

Also, as suggested by @Monyker, I would recommend checking if you have multiple Enpass (Windows Store version along with Website version) installed on your device. In this scenario, the Enpass Extension may try to link with the Enpass app you are not using, resulting in the error.

Link to comment
Share on other sites

Sorry for the delay - been overseas for a while and not able to work this issue beyond installing the 6.8 beta (enpass website version) on  a Surface that solved the crashing problem of 6.7.4 (933).  On the Surface, once I keyed in the master password the UI would disappear and the application would terminate.  This behavior only started after the Chrome extension auto-updated, and tried to connect to a non-existent database.

I think when the Firefox, Chrome and Edge extensions auto-updated on both the Surface and my workstation they ASSUMED I was running the Windows Store version instead of the Enpass.io web site version of the desktop application.  Therefore they created new databases in the Windows Store app location, and could not link to the database used by the desktop app and previous versions of the browser extensions.  This appears to be why I now have, on both machines, data in the Windows App Store  location in addition to the standard location for the Enpass web site desktop application.

As for finding and uninstalling the Windows Store app version - not sure how that can be done.  The data store for it exists but there is only one actual Enpass.exe file (dated 11/10/2021 version according to Properties->Details) that was working fine until the Firefox, Chrome and Edge extensions auto-updated in early April 2022.  But then "Programs and Features" says that Enpass is installed 3/30/2022 which corresponds with the Windows App data store dates.  However the only Enpass.exe on the machine is the

So I guess I need to go to a new password manager since the extensions appear to be no longer compatible with the non-Windows Store desktop application.  And with browser extensions installed, the desktop application does not function correctly (can't connect with the existing database on the desktop, can't open the UI after entering the master pw on the Surface).


Edited by wmc
added info
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...