Jump to content
threadstone

Can't sync with WebDAV on Synology

Recommended Posts

threadstone    0

Hi,

I need your help. I want to sync my database with / on my Synology NAS but I don't get it.

On the Synology I installed WebDAV like here: https://www.synology.com/en-global/knowledgebase/DSM/tutorial/File_Sharing/How_to_access_files_on_Synology_NAS_with_WebDAV

On Enpass I use the path http://192.168.178.25:5005/Enpass/ and the user and password from my Synology-user.

 

I don't get an error or something. It just didn't do anything (on Windows PC or Android). On Android I just see the rotating circle and on Windows PC just "connect" is shown.

 

What's wrong? I didn't see any mistake.

 

Thanks in advance.

Edited by threadstone

Share this post


Link to post
Share on other sites
JPK    1

@Vinod Kumar

I have a similar problem.

I want to sync Enpass Pro on my iPhone with my Synology DiskStation using the enclosed path: https:mydomain.synology.me:5006/home/cloudstation/enpass

WebDAV works fine with Finder (Go to server ...) using https:mydomain.synology.me:5006, hence I assume WebDAV is configured properly.

After putting in the credentials I get asked if i want to accept the unsafe connection. After accepting I receive an error message stating not being able to connect to the given WebDAV folder.

Share this post


Link to post
Share on other sites
Anshu kumar    126

Hi @JPK,

I'm sorry to hear about your trouble. If possible, can you please share a demo account of your WebDAV (for diagnosing the issue) to support@enpass.io (mentioning this thread) or in a personal message to me. So that we can investigate where the problem could be.

Share this post


Link to post
Share on other sites
meme    0

Problems here as well.

Sync works one time only on ALL my devices, have to disconnect and reconnect to get it working, its a real pain.

WebDAV is working on Finder, but fails, on Enpass Mac, iPhone, iPad.

Edited by meme

Share this post


Link to post
Share on other sites
JPK    1

Hi @Anshu kumar and @meme,

seems like it's an issue with CloudStation.

As an online connection is somehow a prerequisite while using Enpass it is not really neccessary to me to sync with CloudStation.

Hence I decided to store the enpass file with my home folder by using this path: https:mydomain.synology.me:5006/home/

By choosing this new path Enpass creates the folder "enpass" in my home folder and stores the walletx-file there.

Everything works fine now. I can sync this singel walletx-file with my Mac, my iPhone and iPad.

  • Like 1

Share this post


Link to post
Share on other sites
meme    0

Except I am not using CloudStation, I enable WebDAV, I also do not prefer to use CloudStation for this.

---

I Just removed the WebDAV sync on my Mac and enabled it again, now my iPhone also works again. I dont get it what is going on.

Edited by meme
update

Share this post


Link to post
Share on other sites
Anshu kumar    126

Hi @meme,

I am sorry for the inconvenience you're facing in syncing with WebDAV. It would be great if you can share a demo account on your WebDAV to us at support@enpass.io or via personal message to me so that we can investigate where the problem could be and try to fix asap.

Thanks for your co-operation!

Share this post


Link to post
Share on other sites
DDD    0

Hi,

I have got the same problem with my Synology Webdav.

In principle webdav seems to be working but when trying to sync with Enpass the programm hangs up.

Regards

Share this post


Link to post
Share on other sites
JPK    1

@DDD and @meme

I'm not a professional, but I assume your Diskstation must be available via internet.

I recommend to set up a free account at https://account.synology.com/.

Once connected you need to ensure the required ports are forwarded by your router to your Diskstation, for WebDAV the port is 5006.

Furthermore you got to ensure to grant the specific user the rights to use WebDAV within the system controll settings of Diskstation (see screenshots, unfortunately in german).

 

Share this post


Link to post
Share on other sites
meme    0

Guys, there is no need to connect it to the internet for webdav. Also I just want to use Webdav within my LAN, and there is really no reason why it shouldn't work.

Let me also make clear, everything works, but just once! Every single time I need disconnect and reconnect.

Share this post


Link to post
Share on other sites
NieChe    0

Hello @Anshu kumar,

I also have the problem to access the NAS.

Could you please let me know how to solve that problem. I tried http and https. I can access the Synology NAS by the internet and at home.

Thank you.

NieChe

Share this post


Link to post
Share on other sites
Anshu kumar    126

Hi @NieChe

Thanks for writing in. Please have a look at our FAQ to set up sync with WebDAV.

If your problem still persists, please share some more info so that we can help you in a better way.

  • On which device (Along with OS version) are you using Enpass?
  • Which Enpass version are you using?
  • While syncing what error message or code are you getting?

It would be really helpful if you can share a demo account of your WebDAV so that we can investigate where the problem could be.

Thanks for your co-operation!

Share this post


Link to post
Share on other sites
farbschmelz    0
On 20.8.2017 at 1:38 PM, morten_bendtsen said:

I had similar problems and found out that this path worked for me:

https://DOMAIN:5006/SYNCPATH/Enpass/

(let SYNCPATH replace the path that you are using for the enpass files on your drive)

I do have the same problem as meme and trying this only results in nesting of Enpass folders. I´m able to conntect to all Folders via CMD+K on my Mac and using http://IP:5005/web/web_enpass/ does work – Enpass creates a Folder (named "Enpass") with the walletx-file. But only this first sync is working - to sync again I have to disconnect Enpass and reconnent again. Every time - as meme already described. Pressing the sync button only results in a 1-second loading animation. There are no errors, neither in Enpass or the macOS Console.

Can´t provide a demo account as our Diskstations isnt reachable over internet. We´re using a DS415+ with the newest DSM 6.1.3-15152 Update 3.

Thanks

 

Bildschirmfoto 2017-08-22 um 17.21.05.png

Share this post


Link to post
Share on other sites
Akash Vyas    37

Hello @farbschmelz

Sorry to hear about the trouble you're going through. But it seems that sync is working fine here. 

Actually, Last Synchronized and Last Attempt are two different timings. Last Synchronized shows the interval when the latest successful data is synced and file update on the cloud. While the Last Attempt shows the time interval for the latest check for changes. So there might be different time intervals for both timings.


For Testing Purpose: Make some sample changes in one device like mark any item to favorite, add a new item, add a new folder. Now check if the changes are reflected on other devices and make sure Date and Time are same (preferably, set it to automatic) on all devices.

Cheers!

Share this post


Link to post
Share on other sites
farbschmelz    0

Hi Akash,

thanks! You are totally right. Tested it (should have done it earlier ..) and everything works fine. May I suggest to alter the translation for the german version a little bit? The "Letzer Versuch" in combination with "Zuletzt synchronisiert" leads to the assumption that Enpass tried to sync but it didn´t work (somehow). Maybe "Letzte Prüfung" instead of "Letzter Versuch" would be a little less misleading.

Thanks again!

Kind Regards,
Matthias

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×