Jump to content
Enpass Discussion Forum

Enpass filling wrong values/fields


Recommended Posts

Hi there,

On my wife's phone Enpass somehow fills wrong values, both with autofill and notification system. It used to work fine, but not anymore. She complained passwords were suddenly wrong. So i investigate and found Enpass is using wrong fields to fill. It looks somewhat random. For instance, on one website it seems to use the 'username' field to fill as password and on another site it uses e-mail field as username but with correct password. Both examples used to work and come from our shared vault and both work fine on my phone and on pc. It's just Enpass on her phone that is acting strangely. I already tried to uninstall Enpass and reinstall from Play Store but that did not help. Any advice?

My wife's phone is a Sony Xperia XZ1 Compact, running Android 9 (build 47.2.A.8.24) with Enpass

Link to comment
Share on other sites

Thank you for your reply. Well, one site is https://www.hema.nl (login at https://www.hema.nl/on/demandware.store/Sites-HemaNL-Site/nl_NL/Login-Show?original=%2f), they ask for e-mail and password. The entry in Enpass has just that, an e-mail field and a password field. But when she tries to log in using Enpass, the e-mail address is being used to fill as password. But when i copy that entry into our shared vault and try from my phone then all is good and i can log in. Same for login from pc, no problems there.


edit: A lot of entries are being filled wrong on her phone, but not all. Some are working fine, like login on anwb.nl with e-mail and password is working as expected.

Edited by Maarten
Link to comment
Share on other sites

  • 4 weeks later...
  • 2 weeks later...


I created a log in for the Hema web site to test the problem Maarten is having. Initially Enpass picked up the incorrect user name, after I manually changed the user name to the supplied email address and tried to log in, this time the user name would not fill, but the password did.

If I had to guess I would say it is probably some coding on the web page that is causing the problem, but my knowledge of HTML is limited.  Below is the section of the page, as best as I can tell, that deals with the user name.  May be someone else can see why it does not seem to work correctly:

form action="https://www.hema.nl/on/demandware.store/Sites-HemaNL-Site/nl_NL/Login-Show?scope=" method="post" id="dwfrm_login" data-errorsummary="#login-errors" novalidate="novalidate">
<input type="hidden" name="csrf_token" value="1FqO2YOvE1GGqVudbQ4zN828m4XhtG5pfKdVfiNAk9hgMKwyvBasd_WeJOJflonZ6N1mLkiz75UpeduLPe4RgpflKuaH8Uaxf4W19UKQXHbLun2m-umCVHcpfymWlZxt-oWJK4tM-LDkOZgINN0qum5ID7APYkN2b8cKNsEf9BBXeTKGOrY"/>
<div class="form">

<div class="form-wrapper" data-formgroup-id="login"> 
        <div class="form-group-wrapper " data-country-id="default">
                <fieldset class="form-row ">
<div class="inner inner-full required">

<label for="dwfrm_login_username_default"><span class="label">e-mailadres</span></label>

<div class="field-wrapper ">
<input class="input-text required " type="email"  id="dwfrm_login_username_default" name="dwfrm_login_username" value="" regex="^[a-zA-Z0-9!#$%&'*+\/=?^_`{|}~-]+(\.?[a-zA-z0-9!#$%&'*+\/=?^_`{|}~-]+)*@\w+([\.-]?\w+)*(\.\w{2,61})+$" autocomplete='off' minlength='6' maxlength='255' placeholder='vul je e-mailadres in' />


  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
This topic is now closed to further replies.
  • Create New...