Jump to content
Enpass Discussion Forum

Enpass stopped syncing with OneDrive due to bad master password?


Recommended Posts

  • Replies 77
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I had a very strange problem happen today. I noticed that Enpass was no longer syncing with OneDrive. When I told it to sync, it seemed to connect to OneDrive OK, but then said the (master) password o

Thank you @Pratyush Sharma. Once you have a fix can you please post here.

@Rojma I am sorry for the trouble and the late replies. I regret answering this too late. Could you please follow the below steps to check if the issue fixes: Please disconnect the sync on all t

Posted Images

46 minutes ago, MioMio said:

@Rojima

and? It worked?

So far the issue has not come back, but it has taken up to a week for it to reoccur. My setup is very similar to yours (Windows 10 1909 PCs and Android 9 phones, although I also have iPad tablets).

Link to post
Share on other sites
3 hours ago, Pratyush Sharma said:

Hi @Rojma, @MioMio & @Rain,

Sorry for the trouble you are going through.

Our Dev team is working on it to resolve this issue. Till then, we will request you to please co-operate with us.

Yes @Pratyush Sharma no problem. Any data you need from me please let me know. I am currently waiting to see if the issue occurs again. Have you guys been able to reproduce internally and is this a known issue?

Link to post
Share on other sites

Well I at least think I figured out what was going on with Enpass syncing with my OneDrive for business instead of my personal OneDrive. It wasn't that Enpass was syncing with OneDrive for Business - it was actually syncing with my personal OneDrive. It was that Enpass was saving its local data to my local Documents folder. That folder then automatically syncs with OneDrive for Business. I have gone to my OneDrive settings and switched where to save the local copy saved from my Documents folder to the Documents folder in my personal OneDrive.

  • Like 1
Link to post
Share on other sites

Well it's been about 2 weeks and the issue has not happened again (knock on wood). @Garima Singh and @Pratyush Sharma since you appear to know what the problem is and are working on a fix, can I go ahead and uninstall the "debug" version and go back to the release version or will you still possibly need data from me from the debug version? Please let me know. Thank you.

Link to post
Share on other sites

@Garima Singh and @Pratyush Sharma I just had a strange problem which may be related. I uninstalled the debug version followed by deleting the local Enpass folders in Documents. I then installed Enpass version from the Microsoft Store. I opened it up and started the configuration wizard. I told it to sync with OneDrive and it connected to OneDrive with no issue. However when it prompted for my master password, it would not work. What I had to do instead was set up as a new user. When I set up as a new user and it asked me for a master password I used the same master password as before. From there I then told it to sync to OneDrive and it worked. I don't know why it was not taking my master password from the configuration wizard.

Edited by Rojma
Link to post
Share on other sites

This weekend I had the same sync-error. I tried to disconnect and connect again with One-Drive, but this was mot the solution. In my opinion Microsoft has changed something in their interface. I tried to make changes in my account, but I had to verify myself by a number, sent to me with SMS, Their number contained 7 digits!. When I tried to fill this on their website, it seemed to be an error, because the number has to contain 8 digits.  I was so frustrated with these Microsoft account, that  I changed it in Enpass to sync with a Google-cloud. Afterwards I made a login to my One-Drive and have deleted the Enpass entry . Now it works fine without One-Drive!!

Link to post
Share on other sites
48 minutes ago, pieth43 said:

This weekend I had the same sync-error. I tried to disconnect and connect again with One-Drive, but this was mot the solution. In my opinion Microsoft has changed something in their interface. I tried to make changes in my account, but I had to verify myself by a number, sent to me with SMS, Their number contained 7 digits!. When I tried to fill this on their website, it seemed to be an error, because the number has to contain 8 digits.  I was so frustrated with these Microsoft account, that  I changed it in Enpass to sync with a Google-cloud. Afterwards I made a login to my One-Drive and have deleted the Enpass entry . Now it works fine without One-Drive!!

This particular issue has nothing to with Microsoft or OneDrive. I can connect just fine to OneDrive. The issue I am having is that the password up on the sync site no longer works no matter where you try to sync from. If you are having problem connecting to OneDrive I would suggest you post on a Microsoft forum. From the sounds of it it is prompting you for a code from an authenticator but you are putting in a code from an SMS message or vice-versa.

Edited by Rojma
Link to post
Share on other sites
12 hours ago, Rojma said:

@Garima Singh and @Pratyush Sharma after uninstalling the debug version and installing the release version, the issue immediately came back. None of my clients are able to sync with the vault on OneDrive due to a bad master password. Do you have a timeframe as to when a fix will be available?

And the problem has happened again after fixing it earlier...

Link to post
Share on other sites
17 hours ago, Rojma said:

This particular issue has nothing to with Microsoft or OneDrive. I can connect just fine to OneDrive. The issue I am having is that the password up on the sync site no longer works no matter where you try to sync from. If you are having problem connecting to OneDrive I would suggest you post on a Microsoft forum. From the sounds of it it is prompting you for a code from an authenticator but you are putting in a code from an SMS message or vice-versa.

It proves that MIcrosoft changed something in their sync. Enpass accepts my masterpassword  to open my (local) vault, but sync with One-Drive delivers the error of bad password in One-Drive. It is NOT ME having a problem withe logging to One-Drive (I can reach One-Drive perfectly from any browser) , but it is Enpass. ( The problem of the sms-code indeed is a Microsoft problem).

Link to post
Share on other sites
6 hours ago, pieth43 said:

It proves that MIcrosoft changed something in their sync. Enpass accepts my masterpassword  to open my (local) vault, but sync with One-Drive delivers the error of bad password in One-Drive. It is NOT ME having a problem withe logging to One-Drive (I can reach One-Drive perfectly from any browser) , but it is Enpass. ( The problem of the sms-code indeed is a Microsoft problem).

Are you having a problem with your OneDrive (Microsoft account) password or your Enpass master password trying to open the Enpass file on OneDrive? It is not clear from your posts.

Link to post
Share on other sites
  • 4 weeks later...

When will this be fixed? Same issue here macOS and iOS devices. Access to oneDrive works perfectly but the enPass sync asks "Password of data on OneDrive is required". Please fix that! It's a really annoying issue. Thank you!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...