Jump to content
Alexxander

WebDAV Sync Error Nextcloud

Recommended Posts

@Alexxander@oliwor@jero
It seems its an issue of the saved vault of a old version, so i found a quite easy workaround.
Make sure your local vault has all passwords, disable(disconnect) the sync, delete/rename the files from enpass from the nextcloud and configure the sync again.
Enpass will create a new file, after that i no more have the problem.

Its quite ugly that we have to do that, but it seems enpass dont tested the updates quite good.
 

Edited by False

Share this post


Link to post
Share on other sites

Hey @jero

Please let us know which WebDAV server you are using? Is it nextcloud or some other and also what enpass version are you using on the same device? Thanks for your co-operation.

Share this post


Link to post
Share on other sites

Hello,

I'm not sure if that belongs to the topic, but I'm currently migrating from Owncloud 10.5 to Nextcloud 19.0.2., and have the same problem with Enpass. The username and password are definitely correct, and I still get a 401.

However, I have found that if I bypass the HAProxy connected in front of it, the synchronization works immediately. The HAProxy is in http mode and has so far run with the Owncloud without any problems.

I'm still looking for the problem, but I'm afraid that it could be an interaction with the Nextcloud, since I'm now on the standard configuration of the HAProxy and really can't do much more.

Share this post


Link to post
Share on other sites

@insigma

On 9/8/2020 at 3:00 PM, insigma said:

The username and password are definitely correct, and I still get a 401.

Make sure that the URL you are using in Enpass is in the required format https://{host}/{path}/remote.php/dav/files/{username}  

You could PM me the demo account credentials if you still face an error with the above configuration. Also, let us know the Enpass version and the OS you are using.

Share this post


Link to post
Share on other sites
2 hours ago, Kashish said:

@insigma

Make sure that the URL you are using in Enpass is in the required format https://{host}/{path}/remote.php/dav/files/{username}  

You could PM me the demo account credentials if you still face an error with the above configuration. Also, let us know the Enpass version and the OS you are using.

Hi @Kashish

that wasn't the problem. The problem was a option called "trusted_proxies". After adding everything worked perfectly. Tested with Windows, Linux (Manjaro), OSX and IOS as well as IPadOS.

 

Edited by insigma
  • Thanks 1

Share this post


Link to post
Share on other sites
21 hours ago, Kashish said:

@insigma

Glad to know that the sync is working now. Thanks for your feedback.

Looks good on my side as well. Everything between colleagues via nextcloud seems to sync correctly again.

  • Like 1

Share this post


Link to post
Share on other sites
On 9/10/2020 at 9:57 AM, insigma said:

Hi @Kashish

that wasn't the problem. The problem was a option called "trusted_proxies". After adding everything worked perfectly. Tested with Windows, Linux (Manjaro), OSX and IOS as well as IPadOS.

 

Hi.

Sorry to disturb, it seems I have a very similar problem after migrating my Owncloud server.

What do you mean by "an option called trusted-proxies" ? Is it an Apache option ? A Nextcloud option ? An Enpass option ? Where can I edit this please ? Thanks

Share this post


Link to post
Share on other sites
On 11/28/2020 at 5:10 PM, Byb said:

Hi.

Sorry to disturb, it seems I have a very similar problem after migrating my Owncloud server.

What do you mean by "an option called trusted-proxies" ? Is it an Apache option ? A Nextcloud option ? An Enpass option ? Where can I edit this please ? Thanks

This is a config option in Nextcloud (and newer version of Owncloud i think). Just add

Quote

'trusted_proxies' => '<YOUR PROXY IP>',

to the config.php of your Nextcloud config if you use a reverse proxy in front. This config.php should be in the config directory of your Nextcloud installation.

Share this post


Link to post
Share on other sites
On 11/30/2020 at 7:29 AM, insigma said:

This is a config option in Nextcloud (and newer version of Owncloud i think). Just add

to the config.php of your Nextcloud config if you use a reverse proxy in front. This config.php should be in the config directory of your Nextcloud installation.

Ok I see this, you're right.

But this option seems not to apply to my problem : I don't use any proxy right there ¬¬

This is a strange behaviour : the sync is working on the iOS app, on the Windows 10 app on one machine, but no longer on another Windows 10 app (error 908500).

I have at the moment no idea how to resolve it.

Thanks for replying, by the way.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...