Jump to content
Enpass Discussion Forum

Enpass app terminates. Extension cannot connect.


MarcS
 Share

Recommended Posts

Every morning when I return to my mac and try to login somewhere on Safari, the Enpass extension reports it needs to "find" Enpass. A look at the dock at that point shows that the main app has mysteriously terminated during the night. The extension is successful in launching the app. Even after that however the extension cannot connect to the app: every attempt to login pops a new Safari tab, a search for the app, the app window appearing and getting minimized again, and the same "cannot find" failure from the extension. This happens every day now. 

Extension 6.9.0 on Safari 17.0 with Enpass 6.9.1 on macOS Sonoma 14.0 (so, yeah, everything up-to-date.)

Link to comment
Share on other sites

  • 2 weeks later...
On 10/25/2023 at 5:59 AM, Abhishek Dewan said:

Could you please confirm if this issue is occurring after you put your system in sleep mode? I would also recommend reviewing the auto-lock behavior in Enpass by referring to this link and ensuring that you have disabled 'Autolock When: System Sleeps' and 'Autolock When: System gets locked' options in the app.

Hi @Abhishek Dewan. No, the system is not going to sleep: only screensaver after inactive for 10 minutes and turn off display after 20 minutes. As for Enpass settings: Autolock when system sleeps and fast user switching and inactive for 6 hrs. 

The problem is not so much that Enpass is locked, it's the connection with the browser extension. I can unlock Enpass from the Enpass main window but the browser will still not connect. The only workaround is to disable the extension and re-enable. 

Let me know if you need anything else to troubleshoot. Thanks. 

Link to comment
Share on other sites

Hi @MarcS

The Enpass Extension actually requires an active connection with the app to function. Since you mentioned that the Enpass app is unable to connect with Extension even when its running, kindly try the below steps and share your findings with me -

  1. Ensure that the Enpass application is running in the background when using the browser extension. In addition, the “ Enable Extensions ” under the Browser settings of your Enpass application should also be enabled.

  2. Go to Safari Preferences  >  Extensions  > Enpass . Then click the checkbox next to Enpass Extension in the sidebar.  Turn On  button in the pop-up that appears. Once the extension is installed, connect it to the Enpass desktop app to allow access to your saved accounts and passwords.
    Note - If its already enabled, try disabling and then re-enabling this setting.

  3. Try clearing the cache and cookies of the browser.

  4. Ensure that you have allowed access to Enpass in your Antivirus/Firewall/VPN settings. Also try disabling them to see if the issue persists.

  5. After creating a manual backup of your Enpass data , try reinstalling the app.

If the issue persists, do share a screenshot of the error message as well that you receive when the app in unable to connect with Extension.

Link to comment
Share on other sites

  • 2 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...