Jump to content
Enpass Discussion Forum

Password for data


Recommended Posts

On Windows 10 we have Enpass 6 (we tried from store and the other one). After we install the app and start it, it wants to resync. We tell it, we use Google Drive. It then asks which account and we choose our account. Then it wants to  "Restore from Google Drive" It asks for a "password of data" What is this password? It is not the enpass masterpassword not the password to the google account. To my knowledge there is no special password for Google Drive!?

Link to comment
Share on other sites

Thanks for asking!

No that is not the password of Google account. Let me reiterate

  1. You installed Enpass v6 on Windows.
  2. You asked to restore your existing data from cloud.
  3. You chose Google Drive.
  4. It found the data there and now asking for a master password; which means
    • It has found v6 data on Google cloud (which you might have sync from your Linux, or have upgraded Enpass v5 -> v6 from other device and sync).
    • It is asking password of that Enpass data it has found on cloud.

Please feel free to ping us for any queries.

Link to comment
Share on other sites

  • 1 month later...

I had the same issue as the OP and I have installed Enpass on various computers and mobile devices and every time I have restored from Google it has been my Google password that has worked and now like the OP, this is not the case. The only passwords I have used with Enpass have been my Google password to restore my data and the Enpass Master PW. Neither work on a new installation I was attempting and I have no clue what the 'password of data' refers to as it should be the Google password which is global to everything google, i.e., google, gmail, gdrive, etc.

 @devil - I manage to get around the above issue by creating a local backup and restoring my vault on the new install from that. Afterwards I went to the vault and set up the sync using my Google password and it worked so if you read this, that is a work-around.

Edited by idheaton
Link to comment
Share on other sites

  • 10 months later...
  • 2 months later...

Hi @Pratyush Sharma,

I think I get similar problems very recently since 13th of March on all my PC's but with OneDrive.

The message it displays is: Sync Error, Password of data on OneDrive is required.

This password has been unmodified since creation and see no suspicious logins around that date into my Microsoft account, change of password is unlikely.


- Enpass installed through Windows Store (PC only version), latest version (6.40.632.0) updated 13th of March

- OneDrive syncfile in folder /Apps/Enpass last modified: 13th of March

- OneDrive syncfile in folder /Apps/Enpass 1 last modified: 13th of March


Please let me know when I need to add more details to it!




  • Like 1
Link to comment
Share on other sites

Hi @Hydra

We regret the inconvenience and understand that you’re facing issues with OneDrive sync. Please follow the below steps to restore the sync:

  1. Take a manual backup of the data on both the devices.
  2. Disconnect the sync on all devices.
  3. Rename the folders Enpass and Enpass1 on OneDrive account.
  4. Log in to the site https://account.live.com/consent/Manage with the same Microsoft account and delete all the permissions for Enpass.
  5. Re-set up the sync with OneDrive on both the devices and check.

If the issue persists, please let us know.

Link to comment
Share on other sites

Disconnecting and reconnecting OneDrive sync worked for me - thank you.

At the "Sync Error, Password of data on OneDrive is required" prompt, I entered the vault unlock password and all was well.

The wording (and appearance) of this prompt is very strange and should probably be changed: ideally, we should not be entering the vault password into random prompt boxes!

Link to comment
Share on other sites

  • 3 weeks later...

Hey @doudoufr

Welcome to the forum!

Please update the Enpass app on all the devices, now disconnect the sync from all the devices and reconnect it again one by one. Also, you can refer to this link.

If your problem persists, please share the following details so that we can investigate where the problem could be.

  • On which devices and OS versions (mention all) are you using Enpass?
  • Which Enpass version are you using on each device?
  • Does the Date and Time setting set to automatic on all devices?
  • Does the last synced time get updated on the sync page?


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...