Jump to content
ironicmoka

Enpass RAM issue

Recommended Posts

I noticed a general slow down today and noticed in Activity Monitor a RAM peek usage by Enpass (1,93 GB):

Mac OS 10.14.5
Enpass 6.1.1. MAS
Browser extensions in both Safari and Chrome

iMac running 4 days long (no shut down, just suspended at night)

H7rUY4l.jpg

Share this post


Link to post
Share on other sites

Hi @ironicmoka,

Thanks for reporting this issue and we are sorry for the inconvenience caused to you.

Please let me know are you facing the problem even after restarting the app and share the following info so that we can check further:

  • Number of items and Vaults in Enpass?
  • Which cloud service are you using to sync?
  • Have you changed the Enpass database location?

Thanks for your co-operation.

Share this post


Link to post
Share on other sites

Hello @Anshu kumar,

  • I have 281 items stored in one single vault
  • I'm using Dropbox to Sync
  • Nope, never changed database location

Further info: I restarted the machine 16 hours ago, suspended it for few hours. Right now I'm counting 1,64 GB of RAM usage in Activity Monitor by Enpass process.

Thank you for your assistance.

Share this post


Link to post
Share on other sites

I'm seeing this issue as well since the last update (6.1.1).  I have 376 items in one vault and sync to Google Drive.   1.9GB resident RAM used (more than Firefox with an insane number of tabs open). It behaves slow and sloppy (taking several seconds to autofill in the browser often).

 

I mostly wanted to report here to follow this issue and see if there is any resolution soon. Thanks!

 

Share this post


Link to post
Share on other sites

Hey guys,

Thanks for sharing the details.

Our QA team is looking into this issue. I will keep you update once I hear from them.

Thanks for your co-operation.

  • Like 1

Share this post


Link to post
Share on other sites
On 7/18/2019 at 4:17 PM, ironicmoka said:

I noticed a general slow down today and noticed in Activity Monitor a RAM peek usage by Enpass (1,93 GB):

Mac OS 10.14.5
Enpass 6.1.1. MAS
Browser extensions in both Safari and Chrome

iMac running 4 days long (no shut down, just suspended at night)

Same here using the same computer with the same macOS, except that it is Enpass 6.1.2 now (already happened/started with 6.1.1). I’ve only 59 items in one vault and am using WebDAV instead of anything in any cloud. The database location has never been changed but the memory leak nevertheless appears the longer the application remains active until it’s not usable anymore.

Share this post


Link to post
Share on other sites

I can also confirm that if you quit Enpass the high memory usage goes away for some time.  It came back after waking from sleep (though that may not be the trigger).

Share this post


Link to post
Share on other sites

Mac OS X 10.14.5

Enpass 6.1.1 App Store

Two Vaults with 687 combined items: One synced via Google Drive, one synced via OneDrive.

Also confirming increasing memory usage as time progresses. After an initial memory usage of about 130MB it grows at a pretty consistent rate of about 40MB per hour. Currently at 850MB after 18 hours. The search in Enpass app and extension pop-up in Safari are laggy.

Share this post


Link to post
Share on other sites

Since updating to 6.1.1 I noticed that after using Enpass for some time on a MacBook (without shutting down or restart), it becomes very laggy. After I quit Enpass and start it again, everything is fine. Please fix ASAP!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...